Windows 10 (Fall update) plus new install of Origin UC (updated) = Unplayable?
#11 22-01-2018 
@gwynne - If I understand correctly, going back to an earlier restore point nukes all changes made after that restore point, right? All apps installed, any data made, any registry changes, anything changed after the restore point is lost, yes? All my data is in cloud backup but reinstalling apps would be mildly annoying.

The nice man from our local computer store gave me a 1703 install media USB to borrow/copy in case I can't roll back. It sounds like quite a bit of work to roll back and it's only temporary, right? Windows 10 will force me to update to 1709 at some point, unless I never, ever connect to the net, right?

I just want to know how painful the process is before I pull that trigger. I think I will try eleventy versions of the NVidia driver first since that's less pain for me and I can stop driver updates indefinitely. I don't remember if you already tried several 37x.xx drivers with Windows 10 pro 1709?

#12 23-01-2018 
@gwynne - Thanks for explaining the rollback. Does seem easier than reinstalling the OS from media.

I found some older nvidia drivers on guru3d, the makers off DDU, below. Not available on the nvidia page anymore because they're old.

Going to try some of the old ones and see if that helps before I try rolling back Windows.


edit: I dont' see 'go back to an earlier build' but I do see 'reset this pc', is that the same?

#13 23-01-2018 
Unfortunately "Go back to an earlier build" is the exact wording that was there when I did it:

I think "reset this PC" is a bit more destructive, but I've never used it:

(In those scenarios I just wipe the machine in question.)

I'm trying to keep up with the various threads on this topic, and I know things are a bit scattered, but it does seem pretty apparent to me that on certain machine configurations, Windows 1709 is breaking the game. It broke Battlefront II for some people:

I'll probably keep chipping away at this on my end because I'm stubborn, but I'm unlikely to be the person who finds the fix. All I've really done so far is narrow down the conditions to a set where the problem is 100% reproducible. I've got a lot of different things in mind to try (like my old .iso rips of the CDs, which I no longer own), but not a ton of time, and even if that worked it's a dumb solution when we have the UC all rolled up and easy to install.

I'd actually recommend people start posting directly on the EA forums, because I think that's where the fix will come from. I checked Reddit, but unfortunately everyone there plays sims 4. Wink

Edited to add: I really don't think this is graphics drivers, but for what it's worth:

My original "flashing pink" problem (which started immediately after my original PC installed 1709) was on a PC with a GTX 1070 running drivers from Oct 2017. I ran that game install frequently over the winter. After 1709, the problems persisted after a clean driver install to bring them up to Jan 2018.

Second edit: it occurs to me that I'm posting this in a subforum called "Sims Graphics Cards" while saying I don't think it's a GPU problem. My apologies to the mods, this site is just where I've seen the most troubleshooting happen when it comes to making this older game work on newer hardware and operating systems. If you want the thread somewhere else, please let me know. I can move it over to MTS instead, although there's a certain "it's not happening to me, so it must not be happening" element that persists over there, Smile
(This post was last modified: 23-01-2018 02:13 AM by gwynne.)

#14 23-01-2018 
On my test PC that was broken on 1709, and rolled back to 1703 (now working), I've been slowly adding in all my downloads, saved hoods, tweaks, collections, etc. So far so good.

(This shouldn't really be considered a fix, FWIW, because not allowing Windows to update indefinitely is a bad idea. Just adding more details to the argument that nothing in the game itself caused the problems, it was the Windows update.)

#15 25-01-2018 
Following @CatOfEvilGenius's most recent info:

(All with no-cd .exe and in windowed mode.)

1) Edited Graphics Rules to include: "boolProp enableDriverMemoryManager true". Result, crash on loading household.

2) Clean NVIDIA driver install after DDU cleanout. Result, crash on loading hood. Going backwards now.

3) Used this 4GB patch: ... game is now working on my original PC (identical in specs to top post of this thread, but different machine).

4) Added in all my old hoods and downloads. Entered Contender household ... everything is flashing pink.

5) Slowly did the 50/50 CC test, and never did find anything (each subsequent load was fine).

So ... right now it's working. Unfortunately I don't know which step did it, and don't have time to roll stuff back one piece at a time to find out. Also curious to see how long the game will go without crashing. When I first started having these problems, the game would be okay for a while, and then next thing I knew, the household was pink.

But ... progress.
(This post was last modified: 25-01-2018 04:45 PM by gwynne.)

#16 25-01-2018 
@gwynne - Thank you so much for still testing. I suspect steps 1-3 were all necessary because steps 2 and 3 without step 1 did not prevent crashes for me. Once I allowed the driver to manage memory, I could play without crashing (minor pink flashies on two puddles). I have not tested step 1 by itself without steps 2 and 3 but you did so it looks like all three are needed.

question - Did you try deleting all cache files and all files in the Thumbnails directory.

Hurray for progress!

#17 25-01-2018 
Thanks for the info on what to try, by the way. I had done the "boolProp enableDriverMemoryManager true" way back when I was first trying to solve the flashing pink problem, but it didn't work at the time and it was before I was down the rabbit hole of trying clean installs.

I automatically delete cache and thumbnails on every attempt at this point.

I've let my 'functional' 1703 machine upgrade to 1709, so I'll try these steps in a different order next time.

#18 25-01-2018 
MOST OF THIS IS NOT WORTH READING. Just laying it all out for posterity.

Updated PC2 (PC in top post) to 1709. No-CD .exe, windowed mode.

Attempt 1: crash

Attempt 2: applied 4GB patch: hood view loads, is mostly flashing pink. household loads, is NOT flashing pink. so game sort of works.

Attempt 3: deleted cache and thumbnails (no other changes). Crashed when loading household!?

Attempt 4: boolProp enableDriverMemoryManager true: crashes when loading neighborhood.


Attempt 5: I restored the cache and thumbnail files deleted in Attempt 3. Hood loads. Household loads. However, switching to a different neighborhood crashes.

Attempt 6: Undid changes in attempt 4, so now: boolProp enableDriverMemoryManager false. Hood loads, household loads. Switching to another neighborhood, hood view is about 30% flashing pink. Household loads and looks normal. Exiting out of household back to hood view, it is no longer pink. Tried to load another household, crash. Sad trombone.

Attempt 7: Clean driver install via NVIDIA's executable, PC restart was not requested. Hood loads, household loads, both look normal. Exit household, application has crashed.

Attempt 8: Full cleanout & restart with DDU: Hood loads, household loads. Exit household to hood works. Switching to another hood = 30% flashing pink. Attempt to load the household that crashed in Attempt 6. Application has crashed. Sad trombone.

Attempt 9: Removed cache & thumbnail files. Went straight to secondary hood first, it loads but is mostly flashing pink. Tried to load the crashing household. It crashes again.

Attempt 10: Back to boolProp enableDriverMemoryManager true. Went straight to secondary hood first, it is NOT flashing pink. Tried to load a completely different household not used in any previous tests, but which is part of the same apartment as the household in 9. Loads. Exits back to neighborhood okay. Try to load original crashing household. It loads. Exit back to neighborhood. It works. Switch to another neighborhood. It works.


4GB Patch: Yes
boolProp enableDriverMemoryManager true
NVIDIA drivers reinstalled via DDU & restart
Cache & thumbnails: Deleted

So yeah, all of these things seem to be necessary.

Game is functional to the extent of no pink flashing and no crashes when switching hood or lots, but I haven't let it run for very long yet.

EDIT: Spoke too soon. Was still in Attempt 10, exited out of the most recent household. Main test hood now has a lot of flashing pink. Entered a different hood, it looked fine, but household from attempt 9 is now flashing pink inside.

This is so aggravating. Okay, rolling back to 1703 on this machine, but willing to try stuff again later if more ideas pop up, maybe next week.

#19 25-01-2018 
Rolled back to 1703 without changing anything in the game. Works fine now.

#20 26-01-2018 
The love click on your post is for the effort and infos, not for the aggravation you had to endure. Thank you for sharing test info for science. I may have more tomorrow evening, we'll see.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option