Sims UC crashing, here's what I tried so far
#41 30-01-2018 
Summary list of various registry change tests documented in the posts above. I'm trying to get the UC Origin exe, run from a desktop shortcut, to work. (And maybe get noCD to have no flashies, since it does not currently crash.) I did these tests in the order listed below. Kept changes from each previous test when doing the next one.

* Disable Xbox Game Monitoring in the registry - did not help UC executable from Origin, from desktop, still crashes
* and More Trying to Disable Game DVR in the Registry..., same link as above, scroll down in that post - did not help
* How to Check if Game Bar is sneakily running in the background, according to a Microsoft Engineer
* Disable Game Mode in the registry - did not help
* Remove the xbox app using powershell - did not help, now crashes with no error message, just poof, no more Sims window

*sigh* Not sure what else is left to try at this point. Suggestions?

0
#42 30-01-2018 
====================================

The noCD exe has STOPPED WORKING Argh.

Tried it three times. Removed cache files. Removed Thumbnails files.
First two times, it crashed when arriving at the community lot.
Third time, pink flashy soup, then crash when arriving at the community lot.
Fourth time, not even pink soup, entirely black community lot, then crash.

Fifth attempt to make noCD work again. Removed entire Sims 2 folder from Documents.
Game crashed while attempting to add Bluewater shopping district to neighborhood.

*headdesk headdesk headdeask*

Maybe I need to reinstall xbox app? And undo the registry changes?

Tentative conclusion: Not sure it was Game DVR that was breaking Sims 2.
Definitely something in 1709 broke it, but maybe not Game DVR?

==============================================

Now attempting to undo all the changes I made, reinstall xboxapp, undo the registry changes...

I used Microsoft's powershell instructions for reinstalling xboxapp. It did a bunch of stuff, also gave a ton of errors.
Is this normal? Is xboxapp reinstalled back the way it was? Who knows. :/ Will going back to a restore point restore xboxapp? I have no idea.

see errors at MTS, not sure how to do an infobutton on leefish

now to undo the registry changes manually... then reboot... then try noCD again *fingers crossed*

I'm looking at process explorer and the xbox DLL that was listed when I searched for xbox is not showing up.
I think it should if I undid all my changes. It was there before the changes, now it is not there anymore. This worries me. Sad

-------------------------------------------------------

System Restore FAILS!

Trying to do a system restore. A system restore scan for affected files says Origin will be affected! I don't recall changing any Origin stuff at all! I uninstalled xboxapp. Could this have somehow corrupted Origin? And why is the scan saying nothing about restoring xbox app? Did my attempt to reinstall it work, despite the ton of errors powershell spewed at me???

The system restore failed. Said it couldn't access some file, said maybe this is due to an antivirus program running (only one is damn Windows Defender, nothing else), and said it had an unspecified error. Well crap. Changing three registry setting, uninstalling xboxapp, putting it back according to Microsoft's own directions, and restoring the registry manually apparently made it impossible for me to do a system restore. Crap crap crap.

I'm going to try to do a system restore in safe mode next... Crap.

[Image: zu1a88.png]

[Image: 20a28n9.png]
(This post was last modified: 30-01-2018 03:10 AM by CatOfEvilGeniu.)

0
#43 30-01-2018 
@gwynne - My computer is working, as in it boots up and seems fine, but I'm not sure what all got borked in my experiments so badly that system restore failed (see previous post). What's a good way to reinstall Windows without losing all my data?

----------------------------------
brief summary of several posts above

sequence of events, what I did to try to get Origin UC to work on Windows 10 version 1709

1) I make a Windows restore point
2) I change the registry according to directions from Microsoft and Steam
Changed one registry key value and created two others.
3) I uninstall xboxapp in powershell, again, according to Microsoft instructions.

I tried to undo all the changes I made by hand.

reverse 3) I try to reinstall xboxapp according to microsoft instructions. This spews a page of errors. Maybe it worked, maybe not, no idea.
reverse 2) I remove the two registry keys I added and change the third one back to the value it had.

This does not appear to make my computer do what it did before. When I check what processes are running with Microsoft's process explorer 64, I notice some xbox DLL that was getting loaded is now no longer getting loaded. Also, my noCD Sims UC has STOPPED WORKING right, now it keeps crashing. So I try a system restore, thinking, whew, glad I made one, now all will be as it was. Silly, silly naive me.

I am trying to do a system restore of Windows 10. I made a Windows 10 restore point before changing my registry and uninstalling xboxapp (what Windows uses for Game DVR). Was not trying to do an Origin repair. I may just uninstall and reinstall Origin maybe.

reverse 1) Windows says the system restore would affect Origin, which I DID NOT change, and nothing about xboxapp, which I did change. Then it fails to do the system restore.

That's where I'm at now. Maybe I forgot to set Sims in game lighting to medium again and that will fix it. I seriously need sleep.

----------------------

10.5.10.24870 - 0 this is the Origin version Origin says it is right now, Help, About

10.5.10.24870 this is what Windows restore said it would remove when attempting to do a restore (which failed)

10.5.8.17910 this is what Windows restore said it would put back but the restore attempt failed

The Windows restore point was from EARLIER TODAY. Origin must have updated versions TODAY while I was doing all my experiments with the registry and xboxapp because this is not complicated enough already. One could get a headache, I swear.
(This post was last modified: 30-01-2018 04:57 AM by CatOfEvilGeniu.)

0
#44 30-01-2018 
So maybe reinstalling xboxapp worked? I tested using Game Bar to record a video clip (of me running Notepad).

* enable Game Bar in Windows Settings, Gaming, Game Bar
* open notepad
* press Windows + G
* use Game Bar video record start/stop
* back in settings, gaming, game dvr, open folder - there's my awesome notepad video

So if xboxapp is needed for game bar video recording, then it did get reinstalled, I guess? Or maybe it's only used when doing background video recording of games? I don't know. But at least game bar seems functional so I didn't break that, maybe. *sigh*

Now to uninstall and reinstall stupid Origin that went and updated itself today, after my system restore point, and apparently made that system restore point unusable because Windows can't access a file (probably Origin's) now. *sigh*

0
#45 30-01-2018 
Quote:@gwynne - My computer is working, as in it boots up and seems fine, but I'm not sure what all got borked in my experiments so badly that system restore failed (see previous post). What's a good way to reinstall Windows without losing all my data?

I've tried System Restore once during this process and had the same result. I don't use it often, but it used to work a lot better. >.> (Mine also whined about antivirus.)

If you decide to reinstall Windows, you can get install media here (you can burn to a disc or install from USB media, but the latter will be dependent on if your PC wants to boot off USB media ... most will these days).

https://www.microsoft.com/en-us/software.../windows10

When I used the 'media creation tool' yesterday, the Windows 10 Pro disc I ended up with installed 1703 (not 1709). That said, manually 'pausing' Windows updates (to try to avoid 1709) causes other problems, or appeared to. (For example, installing new applications. I didn't have a lot of time to test, but once I unpaused updates I stopped having problems.)

Otherwise, reinstalling Windows is mostly a matter of backing up all your personal files on C:\, so desktop, documents, downloads, anything you might be storing in weird places on your C:\ drive.

1
#46 30-01-2018 
@gwynne - That is good to know about the restore media.

---------------------------------------------------

Is graphics memory the issue? I think not entirely. Once we get sgr files to match our cards, the game does appear to have more texture memory available, or at least crashes less, takes longer to crash, has less pink flashies. I looked at Task Manager, at the the CPU and GPU usage while the game was running. My GPU's memory usage was at less that 10% the whole time. Maybe the game can only use the first half gb or something? And Windows happens to be stuffing just that portion up? I don't know.

Some folks have been mentioned the possibility of obscure deprecated graphics driver calls. Don't know what we can do about that. I have tried an nvidia driver, 37x something, from a year ago, did not help at the time. I think this was before I tried several other things so maybe try an older driver again?

Some mentioned turning off shaders. I may try that next, even though I can't stand not having bump mapping.

I suspect there is some other reason for the game not working, in addition to the ones we have tried to address, and it has to do with Windows 1709. I think I'm out of ideas. Anyone else got ideas?

I have given up on Origin at this point.

0
#47 31-01-2018 
Whew, that's a lot to test!

I'm not entirely convinced that the updated Nvidia driver didn't break something as well. For me, the Origin exe will not load the game at all anymore. The noCD exe is not giving me any trouble. The only thing I changed between the Origin exe working and not was the clean install of the driver. I'd put off updating it in the first place because I'd read about others having to roll back Nvidia drivers for breaking games (not just TS2, but "older" games in general).

Also, I'm curious as to what caused this recent wave of pink crap. I found references to it as far back as 2016, but it seems to have become a lot more common recently. For me, Windows was updated to 1709 before I even installed the game, but I didn't have the pink stuff at all in the beginning - the game wasn't exactly stable, but I had no graphics issues at all while it was running. The pink stuff is a more recent development. It's also gotten "crashier". What changed?

2
#48 31-01-2018 
@CatOfEvilGeniu about those deprecated graphics driver calls - I've been actually looking into it like I said I would. And it's probably time to share what I've found as I've hit the wall with this.

I used VirtualBox to get Windows XP on my computer and then installed The Sims 2 and all the stuff packs and expansions to it. Without changing anything in the Graphic Rules.sgr I ran the game, and got very interesting results indeed. You can see from attachments by yourself, but basically the game recognized right away that the VirtualBox's GPU has more than 127MB memory (as originally that's what it's trying to check, not the exact number for the amount of memory - having more than 127MB allows using of "high" graphic options). Also for the comparison I ran the Ultimate Collection on the same computer with the original Graphic Rules.sgr, and as you can see from attached file, it didn't recognize how much memory my GPU has and therefore forced the number to 32MB.

Please notice:
- On Windows XP (VirtualBox), manually installed The Sims 2 and all the expansions and used noCD exe.
- On Windows 10, The Sims 2 Ultimate Collection using noCD exe.

As far as I know the Ultimate Collection didn't change anything else than the folder system, but I can't know for sure (it's EA we're talking about). Might be also good to add that I didn't really get The Sims 2 working with the VirtualBox as it crashed straight from the launch. But I didn't push the matter as I got the data I was looking for.

So, with these results it does seem that we are missing an API here. But which one? Well, The Sims 2 with all the expansions is DirectX 9 game, and as the DirectX handles the APIs related to the graphics it's good probability that we are missing some of those. So I continued with this assumption.

At this point I had two thoughts on my mind.

1) Can we somehow add the missing dll?

I looked into this, and at least for now I'm pretty convinced that it can't be done. The internet seems to be full of theory-wise people who advise how to do this, but sadly not so much people around who have actually got some old program working by doing this. So I should probably say that it CAN be done, but it doesn't help. Windows 10 doesn't really know how to use different DirectX versions, so while I installed pretty good amount of dlls, it didn't make any difference. So to my second thought...

2) Can we use some kind of wrapper to log, interrupt or emulate the missing calls?

Well, in theory, this can be done. But this is way beyond my area of expertise, so I'm not able to do it by myself, and I have not any interest to learn how to do it either. Luckily though, The Sims 2 is definitely not the only freaking game in the universe which has problems with older DirectX versions. So I started looking for ready-to-use wrappers done by someone else, and actually also found couple of them. Sadly they were focusing on even older games and mainly supported DirectX 1-7 and older systems to handle graphics.

While searching, I came across with a neat little program called DxWnd. It's kind of a wrapper in a program form and is fully adjustable. Mostly it's meant for enabling the windowed mode with the older games, but I soon found out that it's capable of doing A LOT of things. It supports DirectX 9 AND has already support for Sims 2 too (noCD exe only).

The main disadvantage with that program is that it really takes some studying and playing around to learn how to use it. There's not actual manual anywhere. And there's so much variables with the compatibility fixes that it would take ages to try each of them.

This was looking very good when I found this, but right now I have tried many things with it and nothing seems to help to get Graphic Rules.sgr recognize my GPU properly. I didn't also get rid of the pink flashing, though the program didn't make things worst either. I'm still curious about the program - at least with my game it seems to reduce the general lag, and it might help some people to play The Sims 2 in windowed mode, as I know that there are people who have difficulties to get it work. And the logging possibilities it brings are very interesting. But to be honest right now it doesn't get me anywhere, and as I've been using several days to research this path I'm kind of tired at the moment and I've been postponing things I should do in real life. So I will stop looking into this for now.

One thing though - DxWnd does seem to have very active forums, and they are solving compatibility problems with many older games in there. So asking from there might be logical next step, though I'm not going to do it right now, as I don't have time to start another discussion about this and then run the needed tests. But just letting you know if someone feels like doing it.

Phew, a lot of text again. But still seems like little compared to the amount of work this has been. Hope this brings new ideas to someone.

Attached files:

.txt  SIMS2BOX-config-log.txt (Size: 9.38 KB / Downloads: 198)

.txt  GOREPUTER-config-log.txt (Size: 14.88 KB / Downloads: 206)

//Edited this a bit just to clarify some parts. Also I'd like to add (if someone pays attention) that the forcing to the 32MB happens with the modern system even if the graphics card is found in database. At this case I wanted to run this test without editing anything, so that's why I didn't use the corrected Video Cards.sgr for this.
(This post was last modified: 31-01-2018 04:19 PM by Epi7.)

1
#49 31-01-2018 
What *I* note, right off the bat, is that the W10/UC version finds TWO graphics cards, both identical. But the XP/disk version of the game finds only ONE graphics card, which is entirely DIFFERENT from the two found by the UC. I hope you're not telling us that you have three graphics cards in your system, right???

0
#50 31-01-2018 
@BoilingOil heh, no, I have only one NVIDIA GeForce GTX 1080 on that computer I ran the tests with. The reason it shows the information twice is because I have actually two displays connected to that computer. As you can see with the "first" GPU it writes Monitor: \\.\DISPLAY1 and with the "second" one Monitor: \\.\DISPLAY2. I forgot to mention about this, I usually play with different setup so this was the first time I saw this happen too.
(This post was last modified: 31-01-2018 01:13 PM by Epi7.)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option