Sims 2 is lagging terribly (Win 10)
#1 23-01-2018 
  • Registered
  • 0
  • 3
Hi! I hope I'm posting this in the right thread.
So, when I got Win 10 about a year ago, it started lagging, couldn't find a solution, so I uninstalled the game. Now, I got the Sims 2 Ultimate Edition from Origin. And it's laggy again!
Scrolling, the neighbourhood-view; it's all really laggy. If I enter a household and don't move the camera or I'm in a loading screen, it's working just fine.
My hardware:
Win64
AMD Radeon HD 7800 Series
Intel ® Core™ i5-4570 CPU @ 3.20GHz

I can play games like Overwatch, Sims 4 or Star Wars Battlefront with my settings on high but Sims 2 just won't work.
I hope that's all the important stuff.
I'd be really happy if somebody could help. Smile

Here's my config-log.txt:



.txt  LEONIE-PC-config-log.txt (Size: 10.33 KB / Downloads: 27)

0
#2 24-01-2018 
Oh dear. I'm really hoping you do not have Windows 10 with update 1709. If you go to the Windows search thing, type in dxdiag, run it, and save info to a text file, you can post it here. It can show us if you have 1709 or not. 1709 broke lots of games, Microsoft admits this and is "working on it". You may want to try rolling back to 1703 if you can although I don't recommend that, neither does gwynne although she tested it for science. It leaves you vulnerable to security threats that 1709 addressed and it's only temporary. And you could lose stuff. Windows 10 will force you to update back to 1709 eventually unless you disconnect it permanently from the network.

how to roll back to 1703
https://www.drivethelife.com/windows-10/...ws-10.html

You may first want to try a clean install of your drivers. Not sure if 1709 borks AMD drivers but it sure borks nvidia drivers and a clean manual driver reinstall helps, if you count taking longer to crash than before as helping in my case. For some folks, it resolves issues, for others, it doesn't really.

clean install of nvidia drivers, instructions may be similar for AMD
http://www.guru3d.com/files-details/disp...nload.html

Gwynne and I have threads in this forum both about 1709 issues and this is what we've come up with so far by gleaning the internet and experimenting on our own. She has verified that a rollback to 1703 fixes things for her and updating back to 1709 breaks things again.

0
#3 24-01-2018 
  • Registered
  • 0
  • 3
@CatOfEvilGeniu

I've uploaded the dxdiag text. Really hope it's not that 1709 thingy, cause that sounds pretty bad.
Thank you so much for replying!


.txt  DxDiag.txt (Size: 76.82 KB / Downloads: 26)

0
#4 24-01-2018 
You do have update 1709 according to the dxdiag. This protects against Spectre/Meltdown malware (good) but can also break Ultimate Collection from Origin, especially the updated version (not good). Wish I had better news.

Try playing in windowed mode, not full screen.

Try a manual uninstall and clean reinstall of your graphics driver. I can post instructions when I get home. (Need to turn off Windows driver updates first)

If that doesn’t help, and your issue is due to 1709, all we found so far that helps is roll back to 1703, risking Spectre/Meltdown and/or wait for Microsoft, NVidia, or Origin to fix it.

Just to be sure it is 1709 and not bad cc, I would test a vanilla game with no cc, fresh unplayed neighborhoods. But I suspect 1709, sorry.

0
#5 24-01-2018 
I looked again at your config file and it says you only have 32mb of texture memory. I bet it's lying. Please go to Windows search, look for dxdiag, run dxdiag, tell it to save all info to your desktop. Then open dxdiag.txt and look for Display Devices. Then look for a line that says 'dedicated memory' in the Display Devices section. What number to you see there? Write it down. Now open your graphics rules sgr file and look for where it sets texture memory. There may be multiple lines where it does this, find them all. Change the 32 to the number you got from dxdiag.

change this line(s) in your graphics rules sgr file (in both Config and CSConfig)
change the 32 to the number from dxdiag (or if you see Kiri's 1744, also change that to the number from dxdiag)

seti textureMemory 32

--------------------------------------------------

I just saw this clever suggestion from Epi7. It may or may not help, I don't know, but I say definitely worth a try.


# never trust the driver to manage its own memory
boolProp enableDriverMemoryManager false

to this, below. The logSystemInfo just adds a line of text to your config log. The more important part of the code is changing the false to true.

# let's trust the driver to manage its own memory, shall we?
logSystemInfo "let driver manage its own memory"
boolProp enableDriverMemoryManager true

Some crashes are due to running out of memory so this may help. Or not. But worth a try.

0
#6 25-01-2018 
  • Registered
  • 0
  • 3
Alright, I did the thing where I changed all the 32's. You were right, it was different than what it said in the dxdiag, so I changed all the 32's to 2028's and I hope that was correct.
I'm pretty bad at computer stuff. Big Grin

Also, where do I have to do the "boolProp enableDriverMemoryManager false" thing? Cause I can't find it anywhere in the sgr file. And what's Kiri's 1744?
I'm sorry for needing so much help, I'm just very lost. ^-^
Thank you so much again!

0
#7 26-01-2018 
No worries, don't apologize for asking questions. Smile I should have given more detailed directions.
If you open graphics rules sgr in Notepad, you can do a search. Press CTRL-F and type 1744.
When you find the first one, change it to your value, 2028. Press F3 to find the next 1744, if there is one.
Change that one too. Just keep looking for 1744 until you find them all and change them all to 2028.
There should be one or two, maybe three tops, if I recall. Save your sgr file.

Next, go to the very top of the file, click on the very top to put your cursor up there, and press CTRL-F again.
This time, search for enableDriverMemoryManager. When you find the line(s) that look like this,

boolProp enableDriverMemoryManager false

change the false to true. I think there's just one line like this but keep searching with F3 and change any other if they exist.
That line should now look like this

boolProp enableDriverMemoryManager true

Again, save your sgr file. Then make sure you copy your graphics rules sgr to both the Config AND CSConfig directories, both places.


It is also important to do a clean reinstall of your graphics driver. @gwynne and I both had games that would crash and what got them running for us, after days of testing lots of things, was these three four steps (1-3 done in whatever order).

1) make sure you do the 32 texture memory fix in your graphics rules sgr
2) allow the graphics driver to manage its own memory, again, change that in the sgr
3) do a clean manual reinstall of your graphics driver
4) run the noCD ultimate collection exe that Kiri links to, not the Origin exe, especially not the updated Origin exe
Run it as admin, in windowed mode, and in compatibility mode for Windows XP sp 2. I can post instructions for all of step 4 if needed, just ask.

clean reinstall instructions for nvidia cards are similar to reinstall instructions for radeon cards, I think
see the video Kiri linked to here

* first, turn off Windows driver auto updates (Windows 1709 messes up nvidia drivers installs, maybe radeon too, I don't have Radeon)
Go to the Windows search thingie in the lower left corner. Type in System Settings, run View Advanced System Settings, go to the Hardware Tab.
Look for the Device Installation Settings button and turn off automatic driver updates. You need to do this because if you don't, and you uninstall
your driver, Windows will just reinstall it when you next boot up, and we don't Windows to do that because it is borking graphics drivers.
We will install it ourselves.

* download the latest radeon driver for your machine from radeon,
select manually select your driver and pick the one for your system, don't do an auto install from the web

* Make a Windows restore point now, just in case. You shouldn't need it, but if you do, you'll be glad you made one. You can google how to do this, it's quick and simple.

* You will need guru3d's display driver uninstaller (DDU). Boot into Safe Mode with Network (NOT Safe MOde Command Console) Run DDU. Select the uninstall driver and reboot option. DDU will uninstall the graphics driver and reboot your machine. Wait until it reboots.

* Your machine will reboot and look wonky because it has no graphics driver. Your screen may be low res and your icons all over the place. This is fine. Do a manual installation of your Radeon or AMD or whatevs driver. You will probably have a driver installer exe you downloaded, double click on it. The nvidia ones let you select express install or custom install, radeon probably has something similar. You want custom install, and make sure you do a clean install, so if there's an option or checkbox or something for clean install, select that. I don't have radeon. After doing the clean install of your graphics driver, reboot again. Then reboot again because why not. Your screen should look lovely again, good resolution, icons where they should be.

I found some instructions for a clean install of AMD drivers here that you may want to follow. I'm not sure if the disable anti-virus step is necessary nor a good idea. I didn't do that, wasn't necessary for me. What I did do was run DDU after booting Windows in Safe Mode with Networking. Don't do Safe Mode Command Window! You want Safe Mode with Networking. I've also read that some people used DDU without being in safe mode first and it worked fine but I'd rather do it in safe mode.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option