Game Crashing
#1 24-01-2018 
  • Registered
  • 0
  • 1
Hi! I've been playing the sims 2 ultimate collection and it will crash at random times. I've read posts on here and tried to use the suggestions to fix it but none have worked so far. Sad. Any help would be greatly appreciated Smile

Attached File(s)
.txt  H-config-log.txt (Size: 10.31 KB / Downloads: 58)

0
#2 24-01-2018 
I just saw this in one of @Epi7 posts. She had a great idea to try letting your GPU manage its own memory. Find this line(s) in your graphics rules sgr file and change it from this:

# never trust the driver to manage its own memory
boolProp enableDriverMemoryManager false

to this, below. The logSystemInfo just adds a line of text to your config log. The more important part of the code is changing the false to true.

# let's trust the driver to manage its own memory, shall we?
logSystemInfo "let driver manage its own memory"
boolProp enableDriverMemoryManager true

Some crashes are due to running out of memory so this may help. Or not. But worth a try.


I note that your config log shows you are using an Intel graphics driver. Do you have an integrated Intel card and also an NVidia card? You'll want to use the NVidia, not the Intel. Or the Radeon or whatever you have that isn't the integrated intel. If you have NVidia, right click on your desktop, select NVidia Control panel, then look at 3D settings. Near the top there should be an option that lets you select which graphics card you are using. Pick the NVidia. I would give better directions but I only have one card, no integrated Intel, so can't reproduce this on my machine. I'm telling you what I remember reading elsewhere.

-----------------------

One more thing you may want to try is increase your texture memory to what dxdiag says you have. First, make sure you are using your better graphics the card, the NVidia or whatever, not the integrated Intel. Then in Windows search, type dxdiag. Run dxdiag. Tell it to save all info to a text file on your desktop. Open that text file and look for dedicated memory or dedicated graphics memory or some such. It says dedicated in there for sure. Put that number in your graphics rules file for texture memory. Tell it to use as much as you have since running out of memory is a big cause of crashes.

find this line in your dxdiag.txt in the Display Devices section
Dedicated Memory: 6052 MB <-- what number do you have here?


find this line(s) in your graphics rules sgr
seti textureMemory 6052 <-- my dxdiag says I have 6052 mb so I put 6052 here

------------------------

You said you tried a lot of things but they didn't work. Can you list the ones you have tried please? That will help folks help you.
(This post was last modified: 24-01-2018 11:10 PM by CatOfEvilGeniu.)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option