Win10Pro Crashes doing anything other than loading neighborhood
#1 24-01-2018 
  • Registered
  • 4
  • 8
OS: Windows 10 Pro
Game: Sims2 UC DOWNLOAD (no disc)

Config log attached

Troubleshooting already tried:

Run Origin as Admin
NVIDIA texture fix into both locations
NVIDIA make your own video card into both locations

I can load the game just fine.

I can load any neighborhood just fine.

I crash trying to enter any lot. It's a hard crash where I have to restart computer. I can click graphics settings and see various resolutions now, just not 1260x1080. I seem to have all the graphics options now except for shadows which is greyed out in the "on" position. I tried lowering all the graphics or leaving them all at default-- same with resolution-- but nothing works. It crashes if I try to do anything other than look at menus.

Attached File(s)
.txt  sims2uc-config-log.txt (Size: 10.33 KB / Downloads: 36)

0
#2 25-01-2018 
Sorry to hear that. I may have some ideas that may or may not help, but would really love to see your dxdiag.txt file first. Can you please go to Windows search, type dxdiag, run dxdiag, save all info to a file on your desktop, dxdiag.txt, then upload that dxdiag.txt file here?

Meanwhile, have you tried either of these?

1) If you have Windows update 1709, it may have borked your graphics driver installation. You can try a manual uninstall and clean reinstall of your nvidia graphics driver. Instructions in this video below. Didn't fix my crashes, but it now takes longer to crash. Yay?
https://www.youtube.com/watch?v=8BezddIWVM0

2) You can probably increase that texture memory in your graphics rules sgr from 1744 to something higher. I'll know what number once I see your dxdiag. Look in the Display Devices section of your dxdiag.txt, then look for dedicated memory and use that number instead of 1744. Find all the 1744's in your sgr file and change them to that number, then copy your sgr file into Config and CSConfig
I did that. Didn't help much, still crashing, but worth a try, may help you.

If you have Windows 1709, the crashes might maybe be due to that. Rolling back to 1703 may fix them but that's risky because then you're vulnerable to Spectre/Meltdown. Also, Windows 10 will force you to update back to 1709 eventually unless you permanently disconnect it from the network.

Finally, here's an idea from Epi7 that is totally worth a try. May help or not, I don't know, but interesting idea.
In your graphics rules sgr, find the enableDriverMemoryManager line(s) and change them.

# never trust the driver to manage its own memory
boolProp enableDriverMemoryManager false

to this!

# do trust the driver to manage its own memory
logSystemInfo "trust the graphics driver to manage its own memory"
boolProp enableDriverMemoryManager true

0
#3 25-01-2018 
  • Registered
  • 4
  • 8
Thanks so much for your reply! I attached the dxdiag for you.

I do have Windows version 1709. I don't want to rollback because it will just re-update. I tried clean uninstall and reinstall of video drivers. Didn't help.

I tried changing the memory number in sgr to the 8088 dedicated memory on my gpu. Didn't help.

I tried the epi7 fix you posted. Didn't help.

Still open to suggestions. I will try anything to be able to play Sims2 again.

Attached File(s)
.txt  DxDiag.txt (Size: 70.55 KB / Downloads: 28)

0
#4 25-01-2018 
Are you starting UC from Origin or did you make yourself a desktop shortcut to Sims2EP9.exe? Or are you using the noCD exe that Kiri linked here somewhere?

I got the game to play without crashing by using the noCD exe, patching it to use 4gb with CFF (may not be necessary, need to test without patch), and finally using Epi7’s sgr change. That last bit got noCD to finally not crash. Did get some very minor pink flash for a bit but no crash.

Origin exe still crashes but I have some ideas to test tomorrow. See last post in my thread for boring details.

Sorry don’t have link to noCD on hand can find tomorrow.

0
#5 25-01-2018 
  • Registered
  • 4
  • 8
At this point, I have reinstalled the game because I made so many changes in so many places with no effect.

1. Re: NO CD w/4gb patch: I tried to find your posts about "no cd" and "4gb patch" but I got lost. I can't find epi7's post on how to do it. Is there a FAQ on this? I am a novice. Even if it's something to download, I'll need help on how to get it/open it/and where to put it.

2. Would I still need to do the NVIDIA texture fix into both config locations and the NVIDIA make your own video card into both config locations?

3. Your post said something about -w? Was this part of your fix, and what does that mean?

4. I did find/remember the epi7 idea to let the driver manage it's own memory and I know how to change the dedicated memory number.

Sorry for being dumb. Thanks in advance!

This is the fix I am trying to do, but need help with the no cd 4gb thing-- as posted by catofevilgenius and epi7:

* noCD exe instead of Origin exe
* used 4gb patch, not sure yet if this is necessary, have not test noCD without 4gb yet
* Epi7's idea to let the driver manage its own memory (requires a change in the sgr)
* I did do a manual uninstall and clean reinstall of the NVidia driver earlier, I suspect this helped
(This post was last modified: 25-01-2018 05:41 PM by giveasmile.)

0
#6 25-01-2018 
Sorry for no links, was typing on my phone last night. Your question is not dumb, I just failed to give good instructions.

* change your graphics rules and video cards sgr files per Kiri's instructions (you already did that, keep those changes)
* change the 1744 to your 8088 that you got from dxdiag (find all the places in the sgr where it says 1744, change all of them)
* use Epi7's change to let the graphics driver manage its own memory
* always double check that you copied both sgr files to Config and CSConfig (I wrote myself a batch file to do this so I don't mess it up)

* get the noCD exe from the link Kiri provided in this post
* Please note, I did NOT overwrite my Sims2EP9.exe as Kiri suggests. Instead, I named the noCD exe Sims2EP9_noCD.exe and made a shortcut to it on my desktop.
* On the shortcut, right click, properties, Shortcut tab, click Advanced, check run as Admin, click Apply
* Now look at the Compatibility tab. Select run in compatibility mode for Windows XP sp2. Check run as Admin and click Apply
* On that shortcut, I turned on windowed mode to avoid the Windows 1709 fullscreen gaming 'optimization' borkage.
Shortcut tab again, then look at target. Add a -w after the quoted stuff.
I also read that telling it to only use one CPU, since that's all it knows to use anyway, may help , so I added -CPUCount:1 then clicked Apply
The CPU count thing may or may not be necessary, may or may not help. NVidia may try to multithread with UC, maybe we don't want it to. Not sure.
My target line now looks like this:

"C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9\TSBin\Sims2EP9_noCD_with_4gb_patch.exe" -w -CPUCount:1

* patch the noCD exe to use 4gb of memory (this last step may not be necessary), try it unpatched first
even if it is not necessary, still a good idea to allow more memory usage

CFF notes here
http://simswiki.info/wiki.php?title=Sims_3:CFF_Explorer

download the patch utility here
http://www.ntcore.com/exsuite.php

When opening in CFF, if it says file is bigger than 40, would you like to open just first 40, select No, otherwise, file gets truncated to first 40.
After patching, save your exe to a different file name, like Sims2EP9_noCD_4gb. Make sure it is the same size as the unpatched one, not smaller!
If it is smaller, it got truncated. Run the patcher on the unpatched noCD exe again, don't truncate it. Then to use the 4gb noCD exe, just make
yourself another shortcut, put -w and -CPUCount:1 on it, run as admin, compatibility mode, and you'll have the same setup as me.

Let me know if that works for you or not.

---------------------------------

Forgot to add this:

* I always remove my cache files and files in my Thumbnails folder
* if using the no CD exe, I make sure Origin is closed, not just minimized, although that may not make a difference
No reason to have Origin running with the no CD exe, it does not need Origin.

2
#7 25-01-2018 
Also forgot to ask, when you did the uninstall/reinstall of the driver, did you use guru3d DDU to uninstall? When reinstalling, you said you did that manually, right? So you did NOT use GeForce Experience? Do NOT use GeForce Experience. It can hang, did for me, and it may not install the drivers right. Download the driver from NVidia, double click the driver installer, do custom install, clean install. Is that how you did it? That is what I did and it definitely helped, I saw an increase in play time before crashing. (That was before I allowed the driver to manage memory itself.)
(This post was last modified: 25-01-2018 07:16 PM by CatOfEvilGeniu.)

0
#8 27-01-2018 
  • Registered
  • 4
  • 8
I did all of that, catofevilgenius, and now I can't even load the game.

My best attempt (able to load into a house but not save it or go back to the neighborhood without crashing) was after changing the graphics rules, graphics cards, changing the texture memory number to match my card, and using epi7 fix to let the driver manage its own memory.

I've been at trying to fix this with EA, random searches/suggestions and the BEST help here , but after reading Gwynne's testing I am concluding that Windows 1709 is not going to let this game work with my hardware no matter what I do. I am so disgusted with MS.
(This post was last modified: 27-01-2018 09:20 PM by giveasmile.)

2
#9 03-02-2018 
  • Registered
  • 4
  • 8
I wanted to try again this weekend. I did all of this as written by catofevilgenius:

* change your graphics rules and video cards sgr files per Kiri's instructions (you already did that, keep those changes)
* change the 1744 to your 8088 that you got from dxdiag (find all the places in the sgr where it says 1744, change all of them)
* use Epi7's change to let the graphics driver manage its own memory
* always double check that you copied both sgr files to Config and CSConfig (I wrote myself a batch file to do this so I don't mess it up)

* get the noCD exe from the link Kiri provided in this post
* Please note, I did NOT overwrite my Sims2EP9.exe as Kiri suggests. Instead, I named the noCD exe Sims2EP9_noCD.exe and made a shortcut to it on my desktop.
* On the shortcut, right click, properties, Shortcut tab, click Advanced, check run as Admin, click Apply
* Now look at the Compatibility tab. Select run in compatibility mode for Windows XP sp2. Check run as Admin and click Apply
* On that shortcut, I turned on windowed mode to avoid the Windows 1709 fullscreen gaming 'optimization' borkage.
Shortcut tab again, then look at target. Add a -w after the quoted stuff.
I also read that telling it to only use one CPU, since that's all it knows to use anyway, may help , so I added -CPUCount:1 then clicked Apply
The CPU count thing may or may not be necessary, may or may not help. NVidia may try to multithread with UC, maybe we don't want it to. Not sure.
My target line now looks like this:

"C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9\TSBin\Sims2EP9_noCD_with_4gb_patch.exe" -w -CPUCount:1
_________________________________________________________________________________________

At this point the game can't even load a neighborhood. So I wanted to patch the no cd w/ 4gb but I am a little unsure of how to do this. Do I have to download two different things? You put:

CFF notes here
http://simswiki.info/wiki.php?title=Sims_3:CFF_Explorer

download the patch utility here
http://www.ntcore.com/exsuite.php

I found the 4gb patch.zip but I am really unsure of what to do or how to get the CFF thing. It's a bit daunting. Can anyone walk me through this step?

1
#10 03-02-2018 
@giveasmile - as far as I know you can do the same thing with both CFF explorer and the 4GB patch you're talking about. No need to use both. 4GB patch is a lot easier way though, if I remember it right the program pretty much walks you through it. CFF explorer is more manual way of patching the exe, but I used the 4GB patch myself and it worked just like it should.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option