The Sims 2 UC Smooth Edges Greyed Out/Flickering
#1 05-02-2018 
  • Registered
  • 0
  • 2
Hi there,

I've been browsing around this site trying to fix my game and it seems there's a lot of helpful info on here. However, unfortunately all the common fixes to my issue are not working, I've tried everything that I could find both on this site and others and I'm at a loss, so my last option was to make an account and post on here in hopes some direct help would solve my issue. I do apologize in advance if I'm breaking any rules by rushing into posting for some support, as I do intend to participate on this site further, but I am desperate to fix my game because I love making movies with it, and I simply can't have graphical errors in my videos. I don't have the best machine graphics wise, but it's all I have and I want to run the game at the best settings I can on it.

OK, so going to my issue. I recently was able to get The Sims 2 Ultimate Collection. I've been trying to get my game to run without graphical hiccups on my current device. So far I haven't actually played the game for long, so I'm not sure if there are any other issues currently, but the main issue seems to be that when I move the camera around in the game, it flickers and will briefly display fragments of other parts of the game (such as outside, floor tiles, etc.) I've updated my graphics rules file as well as my video cards file (attached) and nothing has solved my issue. After browsing around on google I found that some people solved this issue by changing the smooth edges settings. However these settings are greyed out in my game, and I've changed every enumerateMultisampleLevels in graphics rule to true. Despite doing so, the smooth edges setting still remains grayed out and the flickering issue persists.

I am running my game on Windows 10, with Intel HD 4400 Graphics. If any help can be provided, I would GREATLY appreciate it so I can finally get back to doing some creative work, which I have missed out on for so long and unfortunately can't achieve nearly as well with TS4.

Thanks!

Attached File(s)
.txt  config-log.txt (Size: 10.37 KB / Downloads: 77)
.txt  Graphics Rules.txt (Size: 34.12 KB / Downloads: 79)
.txt  Video Cards.txt (Size: 25.98 KB / Downloads: 71)

0
#2 06-02-2018 
@Cmac7 - Hi there, I hope we can help. I've been away from the boards for some days, just saw your post. Can you please also upload your dxdiag.txt file? That will help folks help you. Windows search, type dxdiag, run dxdiag, press save all info, that makes a dxdiag.txt file.

0
#3 07-02-2018 
  • Registered
  • 0
  • 2
Hi,

Thanks for getting back to me. Smile

Here's the dxdiag file.

Attached File(s)
.txt  DxDiag.txt (Size: 77.09 KB / Downloads: 98)

0
#4 12-02-2018 
I didn't see anything wrong in your files, but I'm not Kiri, even by the longest stretch of the imagination. ;}

Don't know if it'll help, but Direct X 9c will install and work on a windows 8.1, or 10 system. Maybe try installing that. I've done it with both Win8.1, and Win 10. It works just fine. Other things that I've done that someone said wouldn't work?

My most recent "Simmers" are both quad core. One is an MSI, i7 7700hq, running at 3.9Ghz, with both nVidia GTX 1050, and Intel HD 630. Sims don't need the nVidia, the HD 630 is more than adequate. Smooth as glass at 1600x900, at all high settings.

The other, is a Lenovo Thinkpad T440p, with i7-4700mq, running at 3.4Ghz with HD4600. It plays VERY well on med/high settings, at 1366x768.

I made no game file modifications, other than graphic rules, and video card, to either machine. Probably, because I don't use my game disks.

You may want to download ImgBurn, and burn a game disk .ISO to your hard disk, and download, and use Daemon Tools, to mount that image. It worked well for me.

Doing it that way, erases a LOT of the evils of playing on Win8.1/10 with a game disk.

Also, in your Video Card file, you may want to change the line:

card 0x0a16 "Intel® HD Graphics Family"

To

card 0x0a16 "Intel® HD Graphics 4400"

I had to do this to get my T440p, with HD Graphics 4600 to work. It didn't like the vagueness I guess. At least, that seemed to be the fix.

BTW, Sims2 should run fine on the HD Graphics 4400, if you run it on medium settings, and 1366x768 resolution.

Hope this helps.

[Edited by BoilingOil to remove quoted Original post]
(This post was last modified: 12-02-2018 05:36 AM by Kunder.)

0
#5 12-02-2018 
Took a look at your files, I see this in config log...

boolProp enumerateMultisampleLevels true

And yet your smooth edges is grayed out. Very puzzling! Is it grayed out just in neighborhood view or when you are inside a lot? Please double check inside a lot.
If you had a nvidia card, I would have some ideas but you have an Intel, I'm not as familiar with those. You don't happen to have a dual card machine with an nvidia card in there, do you?
Or is it just the Intel, nothing else?

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option