Sims 2 Crashing on Win 10- But Worked fine before!
#1 09-02-2018 
  • Registered
  • 2
  • 3
As the title says... I'm desperate and joined here just to see if anyone can help. The game crashes randomly in bodyshop and when playing on a lot, both with and without CC. I have also had Purple flashing in the neighbourhood view, but tinkering with the Graphicsrules seems to have fixed that. Oh, and I have original CDs and DVDs, all EPs and SPs, and I use a noCD crack.

What I've tried:
Re-installing game and generating new neighbourhood, so it can't be game or neighbourhood corruption
CFF Explorer + DEP tricks
Editing GraphicsRules with GraphicsRules maker
Reduced the amount of CC (currently 3.9 GB)

The funny thing is, it was working fine until just two months ago, on the same computer with the same Win 10, same graphics card and specs etc. when I did the CFF Explorer + DEP tricks, it seemed to fix the crashing for a while, but then I had the purple flashing and the crashing started again.

Thanks in advance for any help!

Attached File(s)
.txt  Graphics Rules.txt (Size: 33.56 KB / Downloads: 49)
.txt  Config-log.txt (Size: 4 KB / Downloads: 60)

0
#2 09-02-2018 
Windows updated to v1709 recently for you? That would be why it will no longer work. Thank MicroSoft for doing a crappy job. Sad
There are many recent threads in the Sims2 Graphic Cards forum that talk about this. You just happened to put your thread in the wrong place, and therefor didn't see all that people are saying about it, including some serious attempts to help people figure out work-arounds.

EDIT: Also notice that I have now moved your thread into the appropriate folder, where it's easier for others to find Smile

1
#3 10-02-2018 
  • Registered
  • 2
  • 3
yep, my windows is update 1709. curse you, Microsoft! Thank for moving my thread and pointing me to those other threads!

0
#4 12-02-2018 
This might be a situation where applying the 4GB patch to the no-CD .exe resolves your crashes:

http://www.ntcore.com/4gb_patch.php

http://www.simbology.com/smf/index.php?topic=9322.0

With vanilla Windows 1709 and install via Origin/Unlimited Collection, I got random crashing until I did this. (I still have persistent pink flashing on any GTX 10## cards.)

Also, if you're following the standard wisdom of 'delete all cache files', particularly groups.cache, each time you load the game ... try *not* deleting them, for now.

EDIT: I actually forgot one important step if your main problem is crashing:

In you Graphics Rules.sgr, try changing this from false to true:


# never trust the driver to manage its own memory
boolProp enableDriverMemoryManager true
(This post was last modified: 12-02-2018 03:43 PM by gwynne.)

0
#5 12-02-2018 
Definitely allow the graphics card to manage its own memory as @gwynne said above.

Also, after several days of testing, I noticed that my game seems to run better *without* compatibility mode and without CPU throttling.
Therefore, do NOT use compatibility mode. Also, do NOT use -CPUCount:1 unless you notice a lot of graphics lag.
This applies to the noCD executable.

1
#6 14-02-2018 
  • Registered
  • 2
  • 3
I actually ended up re-installing windows 8, because this isn't the first time I have had trouble with windows 10 and its forced updates...

2
#7 27-02-2018 
  • Registered
  • 2
  • 4
Well... good to know I'm not alone, lol. Geez.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option