Sims 2 Frame Rate Drops On Windows 10
#1 20-02-2018 
  • Registered
  • 1
  • 4
I purchased a new computer with Windows 10 about two years ago, and I recently installed The Sims 2 Ultimate Collection on it. Whenever I enter a household, the frame rate drops. My computer is a Lenovo IdeaCentre 300S.


.txt  DESKTOP-BI3J6U3-config-log.txt (Size: 7.64 KB / Downloads: 52)

0
#2 20-02-2018 
Hi @Rocker93,

I'd like to point out that any system that you bought two years ago, can hardly be considered "new" in the computer business.
Also, could you give us a bit more info, please, like how much RAM memory it has? I noticed from the config-log.txt that your Free Memory was very low, so I tried to find information about your system on the internet (we shouldn't need to do that, but you did not give us much to work with), but the Lenovo website simply says that this system is no longer available.
If your system has only about 2GB, for example, then I would say it isn't suited to play TS2 UC at all. Maybe it would manage to play the Base Game with one or two extensions, but not much more.

And to what level does the frame rate drop? Because many people nowadays seem obsessed with frame rate, and even start screaming if their system drops below 120 fps, even though the human eye won't process more than 24 fps anyway. For example 60 fps should be completely fine. But if the frame rate is so low that you can't even play because everything is frozen, then I can imagine that you need help fixing it.

Another thing: if your Win10 recently updated to v1709, then you're in a bit of trouble. Because many people have problems playing games after that update. And not only TS2, I've read reports of other games no longer loading, too.

1
#3 20-02-2018 
Well, at least I'm not seeing any mention of crashes or pink flashing soup! Big Grin

Here are some things that may help.

* Turn off Windows 10 automatic driver updates and do a manual clean reinstall of your graphics driver.
If you have nvidia, do NOT use GeForce Experience to update your drivers. Turn off driver auto updates in there too.
* If you have a laptop with dual graphics cards, make sure you're using the good one. For nvidia, use NVidia panel, right click the desktop, and select the nvidia card, not the integrated card.
* Do not use the Origin UC executable. Use the 'George' noCD executable instead.
* Apply the 4gb patch to the noCD executable.
* Right click on the shortcut to the noCD executable, click Properties.
--- Make sure compatibility mode is NOT used!
--- Make sure run as administrator is checked.
* Do NOT use CPU throttling, -CPUCount:1 unless it actually helps with the lag
* Do run in windowed mode, add a -w to the shortcut target path, example below

"C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9\TSBin\Sims2EP9_noCD_4gb.exe" -w

* There are also things you need to do with your graphics rules and video card sgr files. For example, I noticed you have not added your card to video cards sgr.
There are several pinned topics in this forum about grahics rules and video card sgr files. Some are premade, just download the ones for your system and see if they work.
If there isn't one just right for your setup, you'll have to edit the manually. Let us know if you have any questions about sgr files.

Let us know if that helps.

1
#4 21-02-2018 
  • Registered
  • 1
  • 4
BoilingOil:

My computer has 4GB of RAM. Please let me know what other information you may need.

Thanks!

As for the frame rate, my rough estimate is that it is at best half of what it was. It may only be about 12 frames per second.
.txt  DxDiag.txt (Size: 73.85 KB / Downloads: 54)
(This post was last modified: 21-02-2018 03:06 AM by Rocker93.)

1
#5 21-02-2018 
Yeah, I get it, Rocker93; 12 fps sounds bad enough. 4GB isn't really a generous amount of RAM, either, but the game should probably work fine, as long as you don't add too much custom content.
I'm hoping for you that CatOfEvilGeniu's tips help you improve performance.

0
#6 02-03-2018 
  • Registered
  • 1
  • 4
I've played The Sims 2 a little more and I just realized something: the frame rate drops only when there is more than one sim on the lot. Furthermore, when I position the camera so no sims are on screen, the frame rate is smooth as silk. Maybe I'm looking at this problem wrong.

0
#7 02-03-2018 
Yup, I think so, too.

For example: very high poly hairs and outfits may cause this drop in frame rate. If there are no sims on the screen that use these, everything is OK. And the more of these sims appear on screen, the worse it gets. But not all sims may be using those... some may be walking around in simpler, less taxing outfits and hairs. THEY should NOT be a problem for your game.

But an extremely high resolution skin is much more of a problem. Especially if it's a default replacer for the normal skin. Because EVERY sim is going to be using it, unless they are one of the supernaturals.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option