Weird Glitches and Crashes on Save with UC
#1 09-04-2018 
  • Registered
  • 0
  • 5
Hey! Okay, so I've not seen anything like this before and the further I dig into it the less it all makes sense, and the more frustrated I become. In all honesty I don't even know if it's a graphic card issue or just general shenanigans so please let me know if I've posted in the wrong place. Since about November '17, I think, things started getting weird, but I had chalked it up as my ancient hood finally reaching BFBVFS status. However, as I tinkered and started fresh it all went sideways. The game seems to freeze whenever it saves. Either on the lot, or when leaving a lot to neighborhood view. It appears to load the neighborhood behind the load screen, to the point where I can click and actually move things around. I always have to shut it down via task manager.
Then these awesome glitches started to appear on the lots where this happened:
[Image: Vb42rQw.png]
**This particular family who's glitching out this lot doesn't even live here. They exist in a separate subhood.
[Image: Kz4EFAS.png]
[Image: JuWQWJ0.png]
**Harville was on the way to being a new hood. Besides this family and lot, it was empty of anything.

I've gone through my cc, and while a good portion of it seems fine, it's the most random of files that cause the issue, and it's not recently added files either. Hair for instance will cause the 'crash' when it's with the rest of the cc, but seems fine on its own. This also occurs with Accessories, Clothing, and a handful of different Buy Mode things (though not all categories). Which makes me think it's a conflict somewhere, but I haven't gotten anything really new since it last played nice. The only thing I had added in attempt to avoid further issues were things such as Cyjon's debugger. I also completely uninstalled my game, thinking I'd screwed something up trying to install it to a different drive, which was around November, but this continues even with it installed in the default folder and with a completely clean hood (minus the two sims I made to test).
I'm on Windows 7 and my config log should be attached.
I really appreciate any help with this. Banging my head against the wall hasn't proved effective...

Attached File(s)
.txt  ARTING-CHILD-config-log.txt (Size: 10.26 KB / Downloads: 55)

0
#2 21-04-2018 
  • Registered
  • 0
  • 4
Oh, my goodness! This is the same thing that is happening in my game.

I recently got a new computer. I specifically bought another Windows 7, so I wouldn't have issues with The Sims 2. But I knew there was still a chance a newer graphics card could give me issues. Well, as it turns out, I have a whole host of issues. First I had the 800X600 problem. I had this problem on my last computer, so I actually had old forum posts saved to fix the issue. Only this time, changing Graphics Rules manually didn't work right. (I also tried the Graphics Rules Maker program.) I could run the game in the right settings, but any time I tried to take a screenshot with the camera tool, the game would flicker and freeze, and I would have to use Task Manager on it. I tried just playing the game without taking any pictures, and after a while, I tried to save and go back to neighborhood. The game crashed just like you said. Next load, I was left with Natasha Una's face stacked next to the household I tried to save and a picture of a game console in the family popup window. (I couldn't seem to take a screenshot of this. My Print Screen key just got my desktop underneath.) I don't think I have ever seen anything like this in all my years of playing The Sims 2. I have saves that still work from around 2005. This, however, was in Desiderata Valley, a neighborhood I never played much and only used for taking pictures and designing houses for characters from my book series.

I doubt this is a CC or old neighborhood issue, because I tested the game with the exact same Neighborhoods and Downloads folders on my old computer before switching. I noticed that you have the same line of graphics card that I have. Mine is the AMD Radeon ™ R9 360. Maybe this is a very specific card issue? All I know is this giving me so much anxiety that I don't know how to handle. My old computer still works, but it's been making bad fan noises for a while now and it's almost 6-years-old with heavy daily use, both personal and work-related. I'd rather switch back to that than be stuck without my The Sims 2, which is a major part of my anxiety-relief. But I can't help feeling I'll be on a countdown to my old computer's demise if this issue never gets fixed.

Attached File(s)
.txt  SOREN-config-log.txt (Size: 10.25 KB / Downloads: 42)

0
#3 21-04-2018 
  • Registered
  • 0
  • 4
Update. I did three things. I went into Device Manager and rolled back the graphics card driver, I copied over my old The Sims 2 folder in its entirety from my old computer, and I also copied that version of Graphics Rules. The game loaded. Weird picture glitches were gone. Was able to take pictures in that house. Was able to save. Went back to the neighborhood. Switched to Pleasantview, which is way more populated. Loaded the overly full Goth house. Played and saved several times. Only thing odd was a toddler glitching out of the birthday sequence once. But I've had that happen before. Grew up two toddlers. Saved again. Everything was fine. Tried to go back to the neighborhood. Big crash. Audio stuck dinging. I went back in and the save seemed fine. Exited out to neighborhood again fine. Played the house next door for a little bit. Saved. Exited back to neighborhood fine. And quit the game from there with no crashing.

So, I don't know. Maybe the Goth house just had too many sims in it. Maybe it was just random. Maybe I've still fixed it. Or maybe it's only working slightly better than before and will get worse. But I thought I'd add this post in case anyone wants to try what I did. Not sure which of the things or which combination of things helped.

0
#4 22-04-2018 
  • Registered
  • 0
  • 5
Well holy crap. I thought I was completely alone in this! Cause yeah, I've not read anywhere about other people having this problem. Interesting you have the same card I do too.
It's kinda feeling like a driver update? Since rolling back the driver seems to have worked? Sorta? For me the game works perfectly fine, at least in my testing, when I have all my cc out. And really I've not had any trouble with my massive global mods and hacks installed either, or with the majority of my cc in. It's like when the custom hair goes in, or the clothes, etc., that tips the scale in being too much. I don't know. That's incredibly weird... And the glitches?? Like what the actual hell? The ones I posted are just examples, they're usually like you describe, my sims' faces plastered and stacked in neighborhood view and the family portrait of something random (I've had everything from objects to passing npc sims faces). I've never seen anything like it....
When I finally work up the nerve to start testing again I'll try rolling back the driver and see if that makes a difference. Just kind of soul crushing constantly being disappointed and unable to play my game that's usually my go to. Have to be in a mood to go through all that frustration haha

0
#5 24-04-2018 
  • Registered
  • 0
  • 4
That's really strange about the CC hair and clothes. I didn't even try taking my CC out because I had just tested all of it in my game before the switch. I'm thinking it's probably the driver update as well. I also remember getting it in some kind of Dell updater that popped up one day. I don't know if that is relevant to your situation, but I thought I'd add in any extra details I could think of. We seem to be the only two people in The Sims 2 fandom having this issue at the moment. What an odd glitch! You'd think we'd be hearing about it all over the place, since it's so comical. (Even as frustrating as it is!) I know what you mean about having to be up for the testing. That first day of testing actually gave me a panic attack. (Which isn't rare for me, but still.) The Sims 2 has been a huge part of my life and escaping the stress of reality. The idea of not being able to play it any more would be heart-breaking. But I really hope the driver roll-back helps! Please keep me posted. If it doesn't work, we can continue to troubleshoot together.

Since I last posted, I had two totally normal sessions with the game. Camera icon worked fine. Birthdays worked fine. Saving worked fine. Going back to the neighborhood worked fine. Switching to a sub-hood was fine. I didn't notice anything off at all. And I played for at least two hours both times. (Just in general, I've noticed that playing the game for more than three hours at a time greatly increases the likelihood of a crash, especially with something like a big birthday party.) Have you had trouble with taking pictures with the in-game camera? That's where my crashes started. And the pictures showed up with small icons of a sim's portrait instead of the picture I tried to take. Also, how big is your Downloads folder? Because if it's something to do with that, it would be good to compare. Right now, mine is 2.52 GB. Though I have a lot of stuff I want to go through and weed out... and even more I want to install. I figure I'll try a couple more sessions as is, though.

Hoping for the best for both of us! <3

0
#6 26-04-2018 
  • Registered
  • 0
  • 5
Right?? I've been searching for months now to find anyone having any kind of similar, and just nothing. I would have imagined, like you said, with these insane glitches that it would show up by now. I'm amazed you were able to find this in all honesty xD And yeah, this has absolutely sent me spiraling some days, 'cause sims is definitely my go to when I just need to relax and escape for a bit, so I totally get you. Surely we'll manage something eventually haha

My computer is my own build, so nothing Dell related would apply to me, but windows may still have something to do with it. I know that more recent updates have really screwed with some other programs of mine, so I wouldn't be that surprised. I've looked up just general Radeon or AMD updates that messed up stuff for people, sims hasn't come up but there was an update last September that seemed to be giving a lot of people trouble. It seems to have been fixed with subsequent updates though. So I'm not sure if that would apply to our current issue. With it becoming likely to crash as time goes on that almost feels like a memory/texture leak thing. That tended to happen in my ancient hood, the longer I played the more it'd start glitching and getting the flashing textures. I could see that being related to my being unable to play with the custom hair/clothes/etc. in since that takes up more memory etc.... least how I understand it. Could absolutely be fantastically wrong on that front.
I haven't used the in game camera in a long time, so I wouldn't be able to tell you if that started glitching out :/
My download folder is a bit of a crazy mess since it's in the middle of testing, but the latest backup of it has it at being 3.69GB probably a bit less now that I've cleaned a bit away (though not much).
I'll let you know when I get to testing it on an earlier driver! With our powers combined!!

0
#7 01-05-2018 
  • Registered
  • 0
  • 5
Hey @fireflyslocket
Something I came across in my wandering. They don't list sims as an affected game, but I wouldn't be surprised at all if this has something to do with it:
https://techraptor.net/content/amd-adren...lder-games

0
#8 01-05-2018 
  • Registered
  • 0
  • 4
@ramblingtree

That absolutely sounds like it could be relevant to the issues we're having! Nice find!

0
#9 12-05-2018 
  • Registered
  • 0
  • 5
@fireflyslocket
I'm not sure why, but I guess my last message never went through, then the site borked and I couldn't get back haha But! I came across this thread on modthesims and found another person having our troubles!
http://www.modthesims.info/showthread.ph...ost5387338
This link should take you to the last page, and our conversation where we've been discussing what we've tried and what our next steps should be. The best news is that people are aware of it, and are trying to figure out why it's happening. Weirdly it only seems to be us three... So please join us there and hopefully we can get to the bottom of it Smile

0
#10 19-05-2018 
Actually the count is up to 4. and we figured it had to do with the amd update. so we need to go further back than that update I would assume to get things normal?

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option