Game Crashing, flickering lots and deco + other problems
#1 29-08-2018 
  • Registered
  • 3
  • 4
Hi!

I have this problem with my Sims 2 UC (all the the expansions and stuff) that the game crashes a lot randomly, the smooth edges doesn't work even though it is enabled and full, the light snow in daylight (not at night) flickers and in one or two neighbourhoods all the lots and deco + other details disappear entirely from the view or flick on and off. They come to normal view on the deco editing mode however. I have tried all the tutorials I can find here and elsewhere but nothing has helped yet. I have lots of mods but I have already tried to rule out them. The problems started when I started playing on windows 10. If I try to override any settings with Intel or Nvidia the game crashes immediately on the Nh view. I use graphic rules maker. I would be so grateful if anyone can suggest anything!

Attached File(s) Thumbnail(s)
   

.txt  HATSHEPSUT-config-log.txt (Size: 10.34 KB / Downloads: 16)
.txt  DxDiag.txt (Size: 107.23 KB / Downloads: 17)

0
#2 30-08-2018 
Your config log is not helping us unfortunately, this is because the game is crashing on load.

Try the steps outlined in this post.

http://www.leefish.nl/mybb/showthread.php?tid=6881

1
#3 30-08-2018 
  • Registered
  • 3
  • 4
I have tried those steps but unfortunately they haven't helped. I'm not sure what you mean by crashing on load? but here's another log when I was able to play without crashing. Thanks for your help in any case!

Attached File(s)
.txt  HATSHEPSUT-config-log.txt (Size: 10.4 KB / Downloads: 14)

0
#4 30-08-2018 
It seems like the game is not recognizing the graphics card as installed and is using the Intel. With ultimate collection your Intel processor is struggling to run the game I think. It is beyond me to help with this, you would need kiri but she is not around at the moment.

You could try this. Go to the Nvidia panel, in the "3D settings --> Glonal settings", and set the "main graphic processor" to "Nvidia with high performance". In the other tab, "Program settings", you may have to choose Sims 2 (Whatever EXE file that's at the end of the shortcut you're using, if that makes sense), and set this to the same setting, "Nvidia with high performance".

In the "3D settings --> Adjust image settings with preview", set the game to "Use advanced 3D settings" (and set these to whatever suits you), OR "Use my prefrence on ... Balanced"

Also, look at this thread http://www.leefish.nl/mybb/showthread.php?tid=8257

1
#5 30-08-2018 
I see no indication of crashing in either log. Everything seems to be all right. The only thing that I think might be responsible for certain graphics options not (properly) working, is your Texture memory. A total of 512 MB is not an awful lot, really.

Both logs also show that the game was running with an Intel Graphics card. Trying to use NVidia settings would be pointless, unless you also have an nVidia card in the same system. But even then, it can still crash if the wrong settings are chosen.

Sadly, last thing I heard of Kiri, she said that she threw the towel in the ring. She's had to deal with some rough stuff IRL, and could no longer bring up enough energy to fix all those TS2 problems. She is sorely missed, for sure, because the problems keep piling up! I hope she is doing better now, but Im not expecting her to pick up the workshop again. Sad

2
#6 30-08-2018 
The only other answer might be installing anygamestarter for UC (modthesims) and see if loading less eps takes the strain off.

2
#7 31-08-2018 
  • Registered
  • 3
  • 4
Thank you both for these!

Leefish: I tried what you suggested with Nvidia, but the game unfortunately keeps crashing. I am however able to play for awhile with certain families. In general if I try to put the game in high performance with Nvidia it crashes even more. I tried the anygamestarter but I wasn't able to play my own saves. I moved my stuff into the anygame folder but after that it said error the files are not created by the anygame.

BoilingOil: I fixed the texture memory. I don't know why it was so low! Unfortunately it didn't help either. Thanks anyway.

2
#8 04-09-2018 
  • Registered
  • 3
  • 4
I used 4gb patch and now seems that my problems (except for the snow) have been solved! Now I get weird pink flashing every now and then but that is a lot better than crashing.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option