Here's to hoping that its a simple fix I over-looked
#1 15-09-2018 
  • Registered
  • 1
  • 2
Hey all.

I have been going through this site and many others looking for a way to get this game to work. I had the Sims 2 a while ago, and when Origin gave away the free upgrade to Sims 2 UC, I has happy. Jump-cut to now, and with a newly upgraded to Windows 10 Pro 64-bit computer, the game no longer works. Ive got a Intel Quad-Core i5 2500k overclocked to 4.3GHz per core (Native is 3.3GHz), an NVIDIA GTX 1060, and its installed on a 500GB SSD with close to 50GB of space left. I am sure my computer can handle it.

I am working with a fresh install of the game. No CC, no mods, just the Origin installed Ultimate Collection. The game boots up fine. It hits the splash logo, plays the intro video, and sticks me in the neighborhood section menu. I have tried clicking and loading every one of the neighborhoods, but the same things happens for all of them. It shows the loading screen, and as the bar lights up across the top and finished the first "lap", the game pops up an error and crashes.

I have tried many things.
I did a Display Driver Uninstall and Reinstall with fresh new drivers.
I have repaired and reinstalled the game.
I changed the Video Cards.sgr and Graphics Rules.sgr. (Ive tried the ones listed here for download, made my own, and used Graphics Rules Maker)
I have a No-CD patch.
I also used CFF to use more ram and used 4GB Patching tool.
I have killed the .cache files.
I got rid of SecuRom.
Ive have also run the game with "-w -CPUCount:1", "-w -CPUCount:2", "-CPUCount:1", "-CPUCount:2".
I have run in Compatibility Mode for Vista(SP3-1), XP(SP3-2), both as an Admin and not.
I have tried with the install folders both as Read-Only and not.

If any one has any more ideas on what to do, please help.

Attached File(s)
.txt  GAMEING_RIG-config-log.txt (Size: 10.23 KB / Downloads: 8)

0
#2 15-09-2018 
What is the error exactly?
Do you have an error log file?
Where do you have the no CD exe?

1
#3 15-09-2018 
  • Registered
  • 1
  • 2
Sorry to waist your time. As a last ditch effort after I made the first post, I uninstalled Origin and Sims 2, then deleted every file with Origin, EA... in the name on the entire drive. After reinstalling both Origin and the game, and making all the changes I listed one last time, It booted up into the neighborhood. I still need to stress test it, but I am guessing that there was some file that went bad somewhere that didn't get deleted when you just uninstall the game. But I do want to thank you so much for getting back with me so quickly.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option