Sims 2 Ultimate; only one resolution after graphics fix
#1 16-09-2018 
  • Registered
  • 0
  • 4
I just got the Sims 2 Ultimate Collection and decided to go through all the bits and bobs and fixes etc that needed done before I started adding mods and cc.

I followed this guide to fix the shoreline graphics glitch I was getting. I have a dual card system so i did the dual card fix and got the Intel graphics rules. I have Windows 8.1.

Only now, when I load the game, the only screen resolution option I have is "800x600" when before I was getting up to 1600x900.

I've also noted my config log complains my graphics card isn't in the database, and that the anti-aliasing is still false.

Attached File(s)
.txt  LYNN-LAPTOP-config-log.txt (Size: 10.4 KB / Downloads: 21)

0
#2 16-09-2018 
Did you try and use the dual card fix?

Name (driver): Intel® HD Graphics 4000 - This tells you what Graphics Card the game thinks you are using. Note if you have a Dual card and it's showing up with Intel, see the Dual Card Fix below

What to do if you have Dual Cards (NVidia)?
(courtesy of Lee and Poisson)

1. go to Nvidia control panel / select your latest installed game (SP9 most often) / force the game to use the good graphics card (not the integrated one) by selecting Nvidia high perfomance;

2. Set Compatibility - if you have Windows 8, use Windows 7. If you have Windows 7 - try XP Service Pack 2.

3. and finally -always- run as an admin.



4. Install the Graphics Rules card that goes with the graphics card that the config-log.txt says because that's what it's using to set the options.
That is, you want the game to specify hi-res/hi-cpu.

0
#3 16-09-2018 
  • Registered
  • 0
  • 4
Yeah, I did all that. It's on win7 compatibility, running as admin, set to nvidia graphics through the control panel. It did fix the jaggy shoreline glitch. But stuck me in 800x600 screen res with no other options, and the log says anti-aliasing is false.

0
#4 16-09-2018 
Please can you post your graphics rules file? Rename it to .txt to upload

0
#5 16-09-2018 
  • Registered
  • 0
  • 4
I used the one provided in this guide.

Should I have Not?

Attached File(s)
.txt  Graphics Rules.txt (Size: 34.12 KB / Downloads: 16)

0
#6 17-09-2018 
As everything else seems to be working, try editing the below

option ScreenModeResolution
setting $Low
uintProp maxResWidth 800
uintProp maxResHeight 600
uintProp defaultResWidth 800
uintProp defaultResHeight 600

setting $MediumButDefaultLow
uintProp maxResWidth 1280
uintProp maxResHeight 1024
uintProp defaultResWidth 800
uintProp defaultResHeight 600

setting $Medium
uintProp maxResWidth 1280
uintProp maxResHeight 1024
uintProp defaultResWidth 1024
uintProp defaultResHeight 768

setting $High
uintProp maxResWidth 1600
uintProp maxResHeight 1200
uintProp defaultResWidth 1024
uintProp defaultResHeight 768
end

0
#7 17-09-2018 
  • Registered
  • 0
  • 4
Oh, I uh was poking about and noticed your Graphics Rule Maker program. So i just used it, and everything seems to be working fine now. Thank you!

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option