Flickering - UC Win10 Intel HD Graphics 4600
#1 25-11-2018 
  • Registered
  • 4
  • 4
Hey, sorry to add yet another topic on this. I've gone through several threads, changed and downloaded the Graphic Rules files a million times, reinstalled the game and still it's flickering like this. I'm pretty sure the problem is the option to smooth edges being greyed out, but no matter how many times I edited Graphic Rules, it always stays greyed out.
I do have dual graphic cards (Intel & nVIDIA), but I'm using Intel on Sims, as it runs on high settings without a hitch (except for the flickering). Also, when I try to use nVIDIA, that's another array of issues I don't want to get into. I just want to make it run on Intel.

Attached File(s)
.txt  -config-log.txt (Size: 10.24 KB / Downloads: 16)

1
#2 25-11-2018 
(25-11-2018 03:04 PM)buvky Wrote:  Hey, sorry to add yet another topic on this. I've gone through several threads, changed and downloaded the Graphic Rules files a million times, reinstalled the game and still it's flickering like this. I'm pretty sure the problem is the option to smooth edges being greyed out, but no matter how many times I edited Graphic Rules, it always stays greyed out.
I do have dual graphic cards (Intel & nVIDIA), but I'm using Intel on Sims, as it runs on high settings without a hitch (except for the flickering). Also, when I try to use nVIDIA, that's another array of issues I don't want to get into. I just want to make it run on Intel.
@buvky

I also run my Sims 2 on my Intel HD 4600, and it runs very well, with no flickering whatsoever.

IF you haven't tried this file.

Try downloading the Intel - Texture fix from here:

http://www.leefish.nl/mybb/showthread.php?tid=6888

Unzip it.

You're indicating you have Mansion and Gardens stuff (EP9).

Shut down your game.

Navigate to C:\Program Files (x86)\EAgames\The Sims 2 Mansion and Garden Stuff\TSData\Res

You'll see two file folders:

Config, and CSConfig.

Rename your current Graphics Rules.sgr to: rafic Rules.sgr (eliminate the "G"), in both the Config, and CSConfig folders.

Copy and paste the new Graphic Rules.sgr that you unzipped, into both, your Config, and CSConfig folders.

close out everything, and try your game again. See if that helps.

If that doesn't work, try:

Navigating to C:\Program Files (x86)\EAgames\Pets\TSData\Res
and Try again.

Anything more complicated than that, You'll need to ask Boiling Oil, or "Kiri".

What are your computer specs?
(This post was last modified: 25-11-2018 06:32 PM by Kunder.)

0
#3 26-11-2018 
  • Registered
  • 4
  • 4
@Kunder
Hi, thanks but I've tried this before and it didn't work. I tried again (I put it in EP4 & SP9 as i have the Ultimate Collection).
My specs are:
Intel Core i5-4210M (2,60-3,20GHz) (BNCH-4215b)
15,6" HD 1366x768px TN LED LCD
4GB DDR3 1333MHz
HDD 1000GB (5400rpm)
nVidia GeForce 840M 2GB DDR3
WiFi / BT 4.0 / USB 2.0 / USB 3.0 / VGA / HDMI / DVD-RW
Win10H 64-bit
(This post was last modified: 26-11-2018 11:41 PM by buvky.)

1
#4 27-11-2018 
(26-11-2018 10:49 PM)buvky Wrote:  @Kunder
Hi, thanks but I've tried this before and it didn't work. I tried again (I put it in EP4 & SP9 as i have the Ultimate Collection).
My specs are:
Intel Core i5-4210M (2,60-3,20GHz) (BNCH-4215b)
15,6" HD 1366x768px TN LED LCD
4GB DDR3 1333MHz
HDD 1000GB (5400rpm)
nVidia GeForce 840M 2GB DDR3
WiFi / BT 4.0 / USB 2.0 / USB 3.0 / VGA / HDMI / DVD-RW
Win10H 64-bit
There are a couple of odd things about your setup. You're running 4gb PC3-1333. A 4th Gen system should be running PC3-12800. This is a problem.

Windows 10Home is it's own issue all together. You have some serious bottlenecks in your system. I'm not saying you don't have an issue with your game, but some of your specs are CERTAINLY not helping. This system should be running Win7, or Win8.1.

Windows 10, on a system with 4gb PC3-1333. Not good! I've tried this already, and it is inadequate. Even without running Sims.

Ram is cheap. At a minimum, I'd at least put the proper ram, in the proper amount in your system. 8gb PC3-12800 would go a long way in helping. SIMS don't require 8gb/RAM, however your computer has to run the REST of your system, while you're playing the game. 4gb was fine for older systems because Sims were designed to run on them, and the background stuff wasn't nearly as massive.

Newer computers need more ram, simply for the system to "keep up", as it were. Your computer does millions of things per second, besides running Sims, and a NEWER computer has millions MORE of things to do in the background than older systems. You need to get the right memory for your computer.

I have also run Sims 2 on AMD 6/8 computers, with R5 graphics, with poor, or at least, less than satisfactory results. These are "newer" machines.
I run Sims 2, on a Core2Duo, with Radeon Mobility 3650 graphics with GREAT success. This is an "older" machine.

Other than this, I can't offer any more help, sorry to say. Maybe @Boiling Oil, or Kiri can help you, However I HIGHLY recommend you get the right ram for your computer.
(This post was last modified: 27-11-2018 03:42 AM by Kunder.)

1
#5 27-11-2018 
I totally agree:

Fix hardware first: Upgrade memory to at least 8GB of the proper type for this Mobo/CPU combo, and consider installing SSD instead of HDD for a boot drive.
Check windows version next: W10 may be great, but it doesn't respect the needs of older games very well.
THEN let's look at the game again.

I don't think I have anything to add, except... way to mutilate my name, @Kunder. I thought you knew better by now Tongue Cool Big Grin

2
#6 27-11-2018 
BoilingOil
With a space
Gives modder BO
A grumpy face

*bows*

2
#7 27-11-2018 
* BoilingOil rolls on the floor laughing at leefish' little rhyme Smile

2
#8 27-11-2018 
  • Registered
  • 4
  • 4
@Kunder @BoilingOil

The thing is, I've been running TS2 on this laptop for 2 years just fine before - with nVIDIA. But ever since the last Windows update, whenever it's used, there are black dots and glitches on the screen. Tried reinstalling drivers and all that. Didn't work, so I thought I'd switch to Intel, at least for Sims. But thanks for all your suggestions.

1
#9 27-11-2018 
  • Registered
  • 4
  • 4
Uhh, okay I just noticed I copied those specs from a different model, I'm dumb, cause I do have 8GB ram. Here's the dxdiag file just in case.

Attached File(s)
.txt  DxDiag.txt (Size: 93.12 KB / Downloads: 9)

1
#10 27-11-2018 
(27-11-2018 08:34 AM)BoilingOil Wrote:  I totally agree:

Fix hardware first: Upgrade memory to at least 8GB of the proper type for this Mobo/CPU combo, and consider installing SSD instead of HDD for a boot drive.
Check windows version next: W10 may be great, but it doesn't respect the needs of older games very well.
THEN let's look at the game again.

I don't think I have anything to add, except... way to mutilate my name, @Kunder. I thought you knew better by now Tongue Cool Big Grin
Sorry BO, I was REALLY tired when I posted that.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option