Nvidia Windows 10 DirectX problem
#1 28-11-2018 
  • Registered
  • 0
  • 4
Hello

I have been searching for hours with my tech-savvy fiance and we are stumped as to how to get my game to work properly on my new laptop! I already expected and knew how to fix the shadows and anti-aliasing problem, but I'm left with two issues:

- When I try to open the game in fullscreen mode it always comes up with the DirectX error message as attached;
- It will run on windowed mode, but only ever at 640x480 resolution (though it runs very well for speed and graphics within that window).

I would much rather be able to play it fullscreen as I have really bad shoulder issues and it's a lot less painful to be able to do things via edge scrolling than keeping my hand up on the keyboard to move around. I've tried using Graphics Rule Manager, I've tried adjusting the .sgr files manually to increase resolution and add my graphics card to the database, but for some reason it just is not recognising those changes when I try to run the game.

This is a brand new laptop, it doesn't have an onboard graphics card, only has NVidia 1060 dedicated card. I downloaded the game from my Origin account (so it's Ultimate Edition and should be valid), and I've managed to play TS2 fine on a previous Windows 10 computer, but for some reason it's just not having it on this one. I also looked into downloading DirectX 9, but the link I tried said it wouldn't work unless I had like Windows 98, and I don't think that's actually the problem. I also turned off Origin In-Game as apparently that's given some people trouble, but nothing has worked :/

Please help if you can!

Attached File(s) Thumbnail(s)
       

.txt  JESS-LIFESAVER-config-log.txt (Size: 10.27 KB / Downloads: 11)
(This post was last modified: 30-11-2018 07:40 AM by Mzyra.)

0
#2 30-11-2018 
  • Registered
  • 0
  • 4
Sorry to double-post (I know it was against the rules on an old TS2 forum I used to be on), but I come with another picture in case it helps at all. I keep trying things that have been suggested for other people that have worked for them, but I can't get anything to work for me.

And, you know, not to get all sob-story on you, but I'm basically bedridden with increasingly severe chronic fatigue and pain, and was meant to be getting this laptop for Christmas but have been so depressed that my parents let me have it early. I've tried playing other games, but I really just need to be able to lose myself in the sims like I always used to, but nothing I try seems to work. So please, if you have any ideas or if I can give you any more helpful information, please let me know.
(This post was last modified: 30-11-2018 07:38 AM by Mzyra.)

0
#3 30-11-2018 
try this card:

card

0
#4 30-11-2018 
  • Registered
  • 0
  • 4
Thank you - do I put it in config and csconfig?

Edit: I put it in both, replacing the existing files, but the same problem occurs - tiny in windowed, doesn't work at all if not windowed.

Also, the screen being 640x480 doesn't make any sense to me anyway, because the default smallest size is meant to be 800x600. Where is it even getting 640x480 from anyway?

Another edit: I (inadvertantly) did Repair through Origin. With no changes to the installed game it had the same problems, but I also couldn't edge smooth. With the card in, I can smooth edges, but same issues of screen being too small in windowed or not working if not windowed :/
(This post was last modified: 30-11-2018 07:47 AM by Mzyra.)

0
#5 30-11-2018 
If you have edited all the screen settings in the graphics rules etc then it might be your Nvidia card enforcing this odd set up re the screen size. Have you looked in the Nvidia setup for how it manages older games, or specifically sims2?

Some people find ts2 UC works better with a nocdhack hack. Are you using one?

0
#6 30-11-2018 
  • Registered
  • 0
  • 4
Alright, tried and found a noCDhack, no difference in how it worked besides not dragging Origin into it.

I'm not sure if I'm looking in the right place, but I've attached what I've found for how Nvidia is specifically treating TS2 (attached). I'm not as tech literate as some, but I can't see anything obvious in the options there, it all seems to be about 3D...

Also, it seems like somewhere between the noCDhack and then editing the .sgr files TS2 stops responding entirely :/ I've had it work with each of those things, but somewhere with both of them it just ignores me trying to open the game... I attach another Log in case it's any more informative since things might have changed. My fatigue-y brain is really struggling to keep understanding right now.

Edit: Actually, I've found the GeForce Experience and TS2 isn't in it. I've tried having it scan the various folders that contain aspects of the game (primarily the TSbin that has the .exe) and it just doesn't seem to see it. I found a list of games that GeForce works with and TS2 seems to be too old, so that's probably natural, but I can't find a way to dictate what it should do with old games like this...

Attached File(s) Thumbnail(s)
   

.txt  JESS-LIFESAVER-config-log.txt (Size: 10.29 KB / Downloads: 9)
(This post was last modified: 30-11-2018 10:22 AM by Mzyra.)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option