Pink glitch in CAS
#1 06-12-2018 
Hello guys.
I've bought a new computer a week ago (https://i.imgur.com/4X9AqJZ.png) + GTX 1050 Ti (4gb) and installed all the Sims 2 EP and Stuffs (I have Fun with Pets), putting my 19gb of downloads and I put the 4 gb patch, I changed the cd crack thing etc but now I'm dealing with this: https://imgur.com/a/C1vYoc3
can someone help me please? I can't find any solutions on the internet

Entwistle
(This post was last modified: 06-12-2018 11:45 PM by Entwistle.)

0
#2 07-12-2018 
+ my config-log.txt (sorry for double post)

Attached File(s)
.txt  ENTYPC-config-log.txt (Size: 10.2 KB / Downloads: 20)

0
#3 07-12-2018 
Clearly a thread that belongs HERE.

Hi @Entwistle, because you do not mention the operating system, I assume you're running Win10 with that? If so, then I'm sorry to say that thousands of others with you have so-called "pink glitches with TS2 and NVidia GTX 10xx cards under Win10". If there is a solution, they would all like to know.

Win7 users don't have this problem, though. And users of other video cards seem to be unaffected, too.
O hope, though, that someone with more recent information will correct me and help you fix this...

By the way, your config-log file looks quite all right. It doesn't seem to be any problem with your setup. Good graphics card recognition, good texture memory setup, everything looks perfect.

One question: how much RAM does your system have? If it's really only the 4GB that the log says, then that's a bit slim. 8GB would be better.

0
#4 07-12-2018 
Woops sorry for not have been enough precise!
I do have w10 family and I have 8GB of RAM, so thats quite weird that the log says that I have 4GB?
And sorry for the wrong place for the topic I’m a newbie here.

0
#5 07-12-2018 
The place you chose for the post wasn't entirely wrong, @Entwistle, but the Graphics Card section is more suited for this type of post. A moderator or admin will easily fix such a thing without much of a fuss. So don't worry about that. Missing the OS info was something that was easily fixed by someone asking about it. Had you known to post in this section, then you might have seen that this info could also help. Now you didn't. Again, it's not a problem that you need to apologise for.

The memory thing... ah, well, the TS2 diagnostic gets it wrong on one system, and right on the next. So I saw only 4GB reported whereas you have 8GB. These things happen. At least now we can be sure that your problem isn't a memory thing, either.

However, that significantly reduces the chance of any of us being able to help you fix your pink glitch. At least, I dont know of a solution...
Another Graphics Card might help, but that comes at a price. We prefer to find solutions that don't require any cash.
So the first option is waiting for someone to have a brainwave that helps you solve it.
However, if you *do* want to go for another card, the best advice would be: if you buy NVidia again, make sure it is NOT one of the 10xx models. Another brand card would also be an option.
There is, of course, still the option of downgrading from Win10 back to Win7. But that requires having (or buying) a Win7 installation disk. And it would take some doing. I know and can understand that some people would not be looking forward to such a task. So I don't blame you if you're not considering that an option.

1
#6 07-12-2018 
(07-12-2018 05:44 AM)BoilingOil Wrote:  The place you chose for the post wasn't entirely wrong, @Entwistle, but the Graphics Card section is more suited for this type of post. A moderator or admin will easily fix such a thing without much of a fuss. So don't worry about that. Missing the OS info was something that was easily fixed by someone asking about it. Had you known to post in this section, then you might have seen that this info could also help. Now you didn't. Again, it's not a problem that you need to apologise for.

The memory thing... ah, well, the TS2 diagnostic gets it wrong on one system, and right on the next. So I saw only 4GB reported whereas you have 8GB. These things happen. At least now we can be sure that your problem isn't a memory thing, either.

However, that significantly reduces the chance of any of us being able to help you fix your pink glitch. At least, I dont know of a solution...
Another Graphics Card might help, but that comes at a price. We prefer to find solutions that don't require any cash.
So the first option is waiting for someone to have a brainwave that helps you solve it.
However, if you *do* want to go for another card, the best advice would be: if you buy NVidia again, make sure it is NOT one of the 10xx models. Another brand card would also be an option.
There is, of course, still the option of downgrading from Win10 back to Win7. But that requires having (or buying) a Win7 installation disk. And it would take some doing. I know and can understand that some people would not be looking forward to such a task. So I don't blame you if you're not considering that an option.

The thing is the computer is all new. I can’t change the graphic card :/ and the flash thing happened when I put my 19gb download, it just happens when I’m on CAS. Tried to play in a household and build/ buy mode and it’s perfercl fine. Perhaps the problem is CC? Can it be? I don’t really know. I never had this problem before because when I was on w7 it was super fine until I drowned my old computer lol (rip)

0
#7 07-12-2018 
Yes, well, if you bring it like that, @Entwistle, then it is indeed quite likely that there is something about the CC that screws the game up.
I must also say that *I* personally think that 19GB of CC is pushing it. But there are people who have more, and as long as everything works, it's all fine.

I would start by separating all the clothing, makeup, hairs, skins, and eyes (as far as you know which files they are) from the rest of your downloads, because those are the most likely files to cause the problem. Put all those files somewhere else for a little while, and see if CAS will work. Then start doing the 50/50 test with the stuff that you took out.

Here's how the 50/50 test works: devide the CC that contains a problem file in two halves. Put the first half in the game, and see if the game and CAS properly work. If it does, then that half is OK, and the problem file must be in the half that you left out. But if CAS breaks, then there is a problem in the CC that you put back in. So take it back out and divide it in half again.
If you keep repeating this process, eventually, the packs that you need to test become smaller, until you find a single file that causes a problem.
When the first half works fine (perhaps minus a few files that you've removed during the testing), then you put in the second half, and repeat the entire process with that set.

It can take some time, especially if you have a lot of CC.

Good luck.

0
#8 07-12-2018 
Thank you for your message. I'm gonna try that. I hope I'll work! I've never separated my CC it's going to take ages lol but thank you a lot (I have a lot of mods too such as the inseminator and inteen for instance)

0
#9 08-12-2018 
You never separated your CC? So you've thrown it all in one folder, without discrimination? Oy, that must be hell. Many things may not actually work the way they were intended.
And especially in cases like this, when something is breaking your game, it's helpful to know which file does what. The only way to get that, is by sorting your files by type, keeping them separated from other types.

Well, I wish you good luck getting it sorted. I'm afraid that it's going to take a lot longer for you than I first thought...
So, again, good luck. You'll need it.

1
#10 08-12-2018 
Maybe just try loading CAS with no cc in downloads at all? If that pink is only happening in CAS then it is very likely to be CC, maybe a skin file.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option