Sim Shadows not showing
#1 18-12-2018 
Okay, here's the thing. I'm running the DVD version of TS2, with all EPs and SPs, under 64-bit Win7 home. My monitor is actually a 49" LED TV, capable of displaying 3840x2160 resolution, and my graphics card will happily support it. I can even coax my game into accepting such settings, but then the UI gets so tiny that I can't make out any of the texts at 6 ft distance. So my game resolution is set at 1600x900, so I can at least read most of the labels, descriptions and notifications. All other graphics options are set to max.

Now here's the problem: everything in my game casts the proper shadows... EXCEPT my sims, who don't cast any shadows at all! In fact, no matter what resolution I select, my sims are like ghosts: they have no shadows!

I have just no idea where to look. This is one problem that I don't know how to handle. I'm grateful for any suggestions anyone may have.

Attached File(s)
.txt  DxDiag.txt (Size: 23.93 KB / Downloads: 72)
.txt  MONSTER-config-log.txt (Size: 10.42 KB / Downloads: 33)

0
#2 18-12-2018 
In your graphics rules file, do you have sims shadows off?

0
#3 18-12-2018 
(18-12-2018 06:08 AM)leefish Wrote:  In your graphics rules file, do you have sims shadows off?

Hi Lee,

I opened the file "E://Game/The Sims2 Deluxe/EP9/TSData/Res/Config/Graphics Rules.sgr" in my text editor to check.
The only line, where even the word "shadows" is used, reads:

Quote: log $logGroup $logLevelInfo "Disabling caustics as these cause cards cause problems with shadows"

No other mention of the word "shadows" in the entire Graphics Rules file.
And when I looked for lines containing "shadow" (without an 's' at the end), I found one other log line, but again no setting rule whatsoever.

EDIT: looking a bit closer WITHOUT using the find/replace tool (maybe I should have set it to ignore upper-/lowercase), I've found some lines mentioning:
Quote: boolProp simShadows false

Apparently, THAT was what you must have been asking about... I'll change it to true, and see if that fixes it. Thank you!

EDIT 2: Ah yes, that fixed it. Except that now there is a new problem: the huge black rectangles under my sims! Which will go away if I lower the Shadows setting in game, but that leaves my sims without shadows once more!!! This is getting ridiculously funny!

1
#4 18-12-2018 
Known issue, known fix here Smile http://www.modthesims.info/d/569585/

2
#5 18-12-2018 
Ah, yes. THAT might be exactly what I need. I'll check this out and report as soon as I know more. Thanks again, Lee Smile

0
#6 18-12-2018 
Yea, as an NVidia user I had to get the really not misty version, but its best to just check and see. One will work.

1
#7 18-12-2018 
So much better! I'm an nVidia user as well, but the normal version seems to do it for me.
Long, long ago, when I first started playing, I knew of only three shadow types:
  • none,
  • simple round blobs under the sims,
  • and proper shadows that were too much for the old machines of the time.
So, I learned to live with simple round blobs...

Then, at some point after either a windows-upgrade (from WinME to WinXP or from WinXP to Win7), or a major hardware upgrade, suddenly, the options had changed to:
  • none,
  • simple round blobs under the sims,
  • horrible huge black rectangles that spoiled everything.
So I continued to live with simple round blobs...

Now recently, however, I realized that since my last hardware overhaul, some 8 or 9 months ago, I haven't seen ANY kind of decent shadow anymore. Not even simple round blobs, either.
I cannot remember ever having set the simShadows to false, but after my last upgrade I have downloaded one of Kiri's Graphics Rules files. It must be from there that I've inherited the missing shadows.

And now, for the very first time ever, I can play with proper shadows! Thanks to simNopke for making that shader-override. And thanks to you for pointing that thing out to me.
I remember having seen mention of this mod before, but imagine me actually finding something. With my Google-Fu, hat's not a very likely scenario.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option