Ultimate Collection, Windows 10: stuck with 800x600
#1 21-12-2018 
  • Registered
  • 6
  • 9
Bonjour everyone!
I have read pretty much everything there was to read on the matter and found someone with a similar issue but it seems that he/she never got an answer.
I have no other option than 800x600, and the images look like Windows 95!
I have downloaded the Ultimate Collection on Origin on my new laptop operating with Windows 10, but I do not have all the same files as you do apparently, so I am a bit confused about what to do.
I attached my config-log document that I already tried to edit with 1920x1080, but every time I launch the game, nothing has changed and when I exit and check the file again it went back to 800x600.
I would be very grateful if you could help. I attached screenshots for you to see exactly what I am dealing with.
Cheers!
               

Attached File(s)
.txt  EXCELSIOR-config-log.txt (Size: 10.33 KB / Downloads: 42)
(This post was last modified: 21-12-2018 07:54 PM by Justine.)

0
#2 22-12-2018 
Hi Justine,

When you say you tried to edit the config-log with 1920x1080, I hope you didn't mean you literally edited the config-log file itself, because that is pointless. The game does NOT read that file, but only writes to it. You would have to change a different file to tell the game what to do.

Let's try to do first things first: go to DOWNLOADS - GRAPHIC RULES and VIDEO CARDS and download the file "Graphic Rules - NVIDIA - Texture Fix - Max Screen size 1920x1080". Unzip that file, and put a copy in the folders TSData/Res/Config and TSData/Res/CSConfig of your Mansions & Garden Stuff installation folder. Then start the game and see what happens.

There is a little more that we can do, but for that I need more information from you. After trying the new settings, I would like you to give us a NEW copy of your config-log file, but I would also need a dxdiag report, if possible.

Finally, your Logs folder contains THREE config-log files. I suggest you keep only the one that was created LAST, and remove the other two to prevent confusion.
Also, I see a lot of OLD (.mdmp) memory dump files in that folder. Where do those come from?

0
#3 22-12-2018 
  • Registered
  • 6
  • 9
Hi there! Thank you for your help!

Yes, I did, haha. That's what I thought I had seen on YouTube... But it was indeed quite pointless! Just realised that I was not even editing the correct file!

I tried copying the NVIDIA files you mentioned in Double Deluxe/Base/TSData/Res/Config and TSData/Res/CSConfig as I couldn't see Mansions & etc, as you can see (attached). But there was no change.

So I tried creating a video card for Intel® HD Graphics 530 using the method here, as I have two graphic cards (which I didn't know but just found out apparently) and it seems that the game does not recognise the NVIDIA one, but just the Intel one as you can see in my config-log file (I deleted the extra ones btw). It didn't work either. Undecided

About the several (.mdmp) memory dump files, they come from my original game that I started almost ten years ago, haha. Every time I changed computers, I copied my files on my old computer, installed the game on the new one, and pasted them on the new one to keep playing with my dear families. It has always worked so far. No issue, ever. So I don't think this is the problem really?

Thank you again for your help! Truly appreciated.

Here are the latest copy of my config-log file and the DxDiag report.

   
.txt  DxDiag.txt (Size: 63.41 KB / Downloads: 40)
.txt  EXCELSIOR-config-log.txt (Size: 10.33 KB / Downloads: 34)
(This post was last modified: 22-12-2018 02:34 AM by Justine.)

0
#4 22-12-2018 
Ah, wait... No wonder that your game doesn't change. You're in the wrong place AGAIN... hahahaha. Sorry, my mistake Smile I had assumed that, as a user of the UC, you would know where to find the right folder. I do NOT have the UC, but still play the ancient disk-based version, so I don't know anything from personal experience.

Anyway... I believe you should find a folder named "EP9" or something similar in the "Fun with Pets" folder. In that EP9 folder is where you should find the right TSData/Res/Config and TSData/Res/CSConfig folders to put the files in.

Oh, and before you start the game up, please DELETE EVERYTHING in the logs folder, first. You don't need all those old log files, which must be somewhere in the hundreds, if not thousands, by now. Just the most recent ones will do, and the game will create the entire set as soon as you start it up again.

As a result of putting the files in the wrong folder, your latest config-log is actually the same as the first one... so when you're done making the changes and test-driving the game, I WILL need a new copy of that. I will NOT need another dxdiag, though, because I have all that I need from that file. If everything goes well, I'll suggest a few changes to your Video Cards.sgr and Graphics Rules.sgr files.

0
#5 22-12-2018 
  • Registered
  • 6
  • 9
Amazing! It works! I could pick the resolution I wanted. Thank you so much!

However, and I don't know if we can fix it, the image is still not very smooth as you can see (attached).

I also attached my new config-log file as requested. It still says that the graphics card can't be found... I am not very techy, so I don't really understand the implications. Hope you can make something out of this!

Also, do you think that by deleting every file in the Log folder I might also lose all my families. I am very attached to that ten-year-long game, haha, so don't want to take any risk.

Thank you so much again!

   


.txt  EXCELSIOR-config-log.txt (Size: 10.44 KB / Downloads: 31)

0
#6 23-12-2018 
(22-12-2018 09:38 PM)Justine Wrote:  Amazing! It works! I could pick the resolution I wanted. Thank you so much!

However, and I don't know if we can fix it, the image is still not very smooth as you can see (attached).

I also attached my new config-log file as requested. It still says that the graphics card can't be found... I am not very techy, so I don't really understand the implications. Hope you can make something out of this!

Yes, I know. That's why I said that after you test drive with the downloaded file, I'd give you information on how to fix the rest.

(22-12-2018 09:38 PM)Justine Wrote:  Also, do you think that by deleting every file in the Log folder I might also lose all my families. I am very attached to that ten-year-long game, haha, so don't want to take any risk.

First of all, if deleting log files would kill your sims, do you really think I would tell you to do that? What kind of help would that be?
You *do* know what logging means, right? Log files are reports on various parts of your computer and your game. It's only OUTPUT to help us find and fix problems. The game only WRITES to these files, but it doesn't use that for playing the game.
No, PLEASE destroy those log files as soon as possible. Many of them will be extremely old, and they are of no more use at all. The only thing they do, is use space on your harddrive!

Now I promised to help you fix more, and here it comes. Since you keep saying how you're not technical and all, I think I will try to make it as easy as possible.
I've created two new files, and put them in a ZIP file. Now I want you to download that, unzip it, and put the two .sgr files that you'll find, in the same folders where you put the "Graphics Rules.sgr" earlier. So that's in "Fun with Pets/EP9/TSData/Res/Config" and in "Fun with Pets/EP9/TSData/Res/CSConfig"
And if Windows starts complaining that there are already files with those names, just ignore it and tell the system to overwrite the old files! I promise, nothing is going to break!

Then, let's see if that fixes everything!
If not, we'll see if we can find more to fix...

Attached File(s)
.zip  Justine.zip (Size: 11.87 KB / Downloads: 31)

0
#7 23-12-2018 
  • Registered
  • 6
  • 9
I am learning so much right now! I had no idea of everything you've explained. I deleted everything there was in the Log file, and indeed, everyone is still alive, haha! Thank you!

Thank you so much for your help, but please don't put too much of your time in it. I'll learn how to do things properly myself after a few attempts, that's all. Big Grin

This time when looking into the config-log file, it doesn't say that the device can't be found, however, the image is still not very smooth (attached). Also, do you know why the game is working with Intel and not Nvidia? Sorry if that is a silly question.

Oh, also, now there are black squares under my Sims!

   

.txt  EXCELSIOR-config-log.txt (Size: 10.41 KB / Downloads: 38)
(This post was last modified: 23-12-2018 04:37 PM by Justine.)

0
#8 23-12-2018 
Hi Justine,

Don't worry about how much time I spend on your problems... I have way too much free time on my hands as it is.
Alas, however, there are things that I still have no idea about.

This is the first time you mention NVidia. Ah yes, now I see it in the Dxdiag.txt: an NVidia GeForce GTX 950M !!
Not that I would know how to make your game use a different card, though. Kiri (@celebkiriedhel) would know, but she retired from fixing graphics issues, and is hardly ever here anymore. We miss her.

Also, the not-so-smooth things... I have no idea how to fix that, either... Kiri would, but knowing that doesn't help you much, I suppose.

There is one more thing that I *can* help you with, though... Them black boxes under your sims... Go to this MTS page for the fix.

1
#9 24-12-2018 
hi Smile

I had a look in your config log and there was this line: boolProp simpleTerrain true

So I opened the graphic rules in Notepad and searched for all uses of simpleTerrain true and changed it to false. I updated BO's zip, see attached. Follow his instructions again and see if that works.

Attached File(s)
.zip  Justine.zip (Size: 11.99 KB / Downloads: 32)

1
#10 24-12-2018 
  • Registered
  • 6
  • 9
Thank you both so much! I fixed the black boxes issue and the smooth image one as well. My game looks absolutely perfect now!

Thank you again a thousand times! I have learnt so much. Very happy to have found this forum.

I wish you both very happy holidays (mine will be absolutely perfect with my beautiful sims, haha!)

3

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option