DirectX 9.0c error message (Windows 10 / Intel Graphics 630/ Nvidia GTX 1050 Ti)
#1 02-01-2019 
Good evening everyone.

I'm having trouble getting the Sims 2 Ultimate Collection to run on my Windows 10 laptop.

Every time I try to launch it I get a DirectX 9.0c failure error message.

I have an Intel UHD Graphics 630 and a Nvidia Geforce GTX 1050 Ti (4 GB).

I've tried several attemps to fix it :

Download and install DirectX 9.0c,
Download and install Graphics Rules Maker,
Make a Video Card.sgr (with celebkiriedhel guide : http://www.leefish.nl/mybb/showthread.php?tid=6882 ),
Launch the game with Windows 8/7/Vista/XP compatibility...

I can only launch the game using the windowed mode (with "-w") but I want to play in fullscreen mode (the windowed mode is a little bit laggy).

I joined a config-log.txt and a DxDiag.txt

Can anybody help me ?

Have a nice day.

Attached File(s)
.txt  MSI-config-log.txt (Size: 10.35 KB / Downloads: 27)
.txt  DxDiag.txt (Size: 100.05 KB / Downloads: 26)
(This post was last modified: 03-01-2019 02:33 PM by Benjis.)

0
#2 03-01-2019 
Oh my, this is going to be tough. I don't know where to begin...

First of all, the Intel graphics card has way too little dedicated Texture Memory. Which means very poor graphics optionsm even under the best of circumstances. But the current circumstances are not in your favor; the game only sees one quarter of what little texture memory there is. That's why currently the game only opens in 800x600 Windowed mode; not enough video memory to do any better. There is one chance, but I cannot guarantee that it works.

Then you still have the NVidia GeForce GTX 1050 Ti, but nobody knows how to make that card work with TS2 under Win10. Under Win7, it would be easy as pie.
And even if it could be fixed, I don't know how to make the game use the NVidia card instead of the Intel card.

And I don't even know how to solve the DirectX 9.0c problem...

Making the video cards known to your game:
------------------------------------------------------
Ok, if you know how to use a text editor, at least you can edit the file named Video Cards.sgr in the folder "Fun with Pets/EP9/TSData/Res/Config/" so your game will recognize both video cards properly:
  • In the Intel section, you need to add a new line that reads:
    card 0x3e9b "Intel® UHD Graphics 630"
  • In the NVidia section, you need to add a line:
    card 0x1c8c "NVidia GeForce GTX 1050 Ti"

Then you need to save the file, and make a copy of it in the folder "Fun with Pets/EP9/TSData/Res/CSConfig/"

Now the Texture Memory problem:
------------------------------------------
For this, you need to open the file Graphics Rules.sgr in the same place where you got the Video Crads.sgr.
Somewhere near line 48 of this file, you will see a line that says something like:

seti textureMemory <some number>

Whatever that number is, remove it, and make it 4147 (if your game still uses the Intel graphics), or 8040 (if you can get the game to use the NVidia card).
Again, save the file, and make a copy to the CSConfig folder.

I'm sure the game is still not working the way you want it after all that work, but it will be closer than it is now.

I hope that someone else will come along to help you with the things that I couldn't fix.

1
#3 03-01-2019 
First of all : I thank you for your assistance, BoilingOil.

I followed your instructions : I can't launch the game in fullscreen mode but it loads much faster in windowed mode (I guess it's due to Texture Memory edit).

I don't know if the game use the Nvidia card or the Intel dedicated graphic...

I tried to force the game to use the Nvidia card (with Nvidia control panel) but I can't tell if it works.

When I play in windowed mode the screen resolution is 320x200 (it's the only choice in the game parameters).

I want to know if it's possible to add higher screen resolutions (like 800x600, 1024x768...).

0
#4 03-01-2019 
You're welcome, @Benjis. In fact, I feel like I do not deserve your thanks by a long shot, yet. I've not done anything to improve your situation, it seems.

It's not hard to tell what card the game is using. After closing the game, just open the config-log.txt in any text editor (simple double-click should do the trick), and it'll be easy to see.

The config-log that you uploaded earlier, shows the following piece of text:
Code:
=== Graphics device info ===
Number:          0
Name (driver):   Intel(R) UHD Graphics 630
Name (database): Intel(R) UHD Graphics 630 <<NOT FOUND IN DATABASE!>>
Vendor:          Intel
Chipset:         Vendor: 8086, Device: 3e9b, Board: 121a1462, Chipset: 0000

which tells me that your system is using a card that it recognized as an unknown Intel card. Unknown, because it could not find the card's identification numbers in the database. That's why the Video Cards.sgr needed to be updated.

320x200 is a rotten resolution. That doesn't do you much good... Could you send a new config-log file, so we can see what happened after you followed my instructions?

0
#5 03-01-2019 
You're right, the new config-log.txt points out that the Nvidia Geforce GTX 1050 Ti is used by the game and is in the database.

I joined the new config-log.txt.

Attached File(s)
.txt  MSI-config-log.txt (Size: 10.23 KB / Downloads: 19)

0
#6 03-01-2019 
Indeed, it does. So selecting the video card was done in the NVidia Control panel... good to know! Thank you.

But now I see that there is STILL a texture memory problem. So I want you to go back to the folder "Fun with Pets/EP9/TSData/Res/Config" and edit the file Graphics Rules.sgr.

Find the line that says (somewhere around line 48):

seti textureMemory <some-number>

and change that number to 4021.

Then save the file again, and copy it to the folder CSConfig.

Then start the game again, see if that makes more window sizes available. And after closing the game, post the newest config-log again, please. Maybe you need more changes, and that's something we will then know.

0
#7 03-01-2019 
I changed seti textureMemory to 4021 then I launched the game.

I can't change the window size : the only choice remains 320x200.

I joined the config-log.txt.

Attached File(s)
.txt  MSI-config-log.txt (Size: 10.23 KB / Downloads: 17)

0
#8 04-01-2019 
Hmm, your config-log looks better, but the game still wants to be unreasonable. I hate it when that happens.
Could you please put your Graphics Rules.sgr in a zip file and attach it? I need to see what is going on in there.

0
#9 04-01-2019 
Ok.

I joined the Graphics Rules.sgr.

I hope you can find something.

Attached File(s)
.zip  Graphics Rules.zip (Size: 7.03 KB / Downloads: 18)

0
#10 04-01-2019 
Ah, I see I should've asked for that file sooner, because now I've found one little snag...

I mentioned the line "seti textureMemory <something>" being somewhere near line 48. But in your file, there is no line like that in that area. So you changed a line with that text almost 100 lines lower in the file, which doesn't help. DON'T blame yourself, though, because you couldn't have known.

I also found some other annoying things that the Graphics Rules Maker did with your file, like disabling Sim shadows entirely. I'm not trying to fix any of that, so I'm sending you *my* file. Unpack it, and put copies of it in your Config folder AND in your CSConfig folder. Then see if that changes things. And please, for the time being, do NOT try to run Graphics Rules Maker again...

Let me know how it goes, OK? Good luck!

Attached File(s)
.zip  Graphics Rules.zip (Size: 7.31 KB / Downloads: 19)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option