Sims 2 Crash When Loading Neighborhood
#1 28-04-2019 
  • Registered
  • 0
  • 3
I have gone through lots of threads to fix this issue but nothing seems to be working. I took all cc out, repaired my game, and deleted cache files & NeighborhoodManager. The game loads fine up until I select a neighborhood. It loads about halfway, then I get the dreaded "The application has crashed. The application will now terminate." AppErrors.log seems to hint at an audio issue, but I do not know where to begin fixing that. My computer runs Windows 10 and I have the Intel integrated graphics card. :/

Attached File(s)
.txt  DESKTOP-A1T0F7D-config-log.txt (Size: 10.44 KB / Downloads: 19)

0
#2 28-04-2019 
What CPU? Model of computer? Brand? Can you downgrade the O/S? Win 10 does NOT play well with TS2.

I see you have HD520 graphics. IF you run Win7, or Win 8.1, it would work properly on medium settings.

You need to correct the <Not found in Database> error, in your Video Cards.sgr. Let me see if I can upload you the proper Video Cards.sgr. I'll re-post in a little while.

0
#3 28-04-2019 
  • Registered
  • 0
  • 3
I have an HP Pavilion Notebook. Windows 10 came pre-installed, so I do not believe it is possible to downgrade. I fixed the database error using the Graphics Rules Maker. Sims 2 has been running just fine for a few years but it might just be time for a new computer.

0
#4 28-04-2019 
NO!!! DON'T DO THAT!!! New computers, with Win 10 will *NOT* run TS2! Do *NOT* purchase a newer computer, especially a new, expensive gaming machine, and expect to play TS2 on it, you'll be *VERY* disappointed!! If you do, you'll have much better luck playing TS3.

Even if it does play it, the first major Win10 update will make TS2 non-playable. Get a refurbed, or used ThinkPad T440p with Win7, or Win 8.1!

You can also get a ThinkPad T430, or T420. If you get one of these, you'll NEED the nVidia graphics, and at least 8gb/RAM, and Win7 or Win8.1.... NO WIN 10!


READ THIS!
Please!

http://www.leefish.nl/mybb/showthread.php?tid=8788

Consider this if you want to play TS2! I have one EXACTLY like it, and it plays well with TS2 on the HD4600 on-board graphics.

https://www.ebay.com/itm/Lenovo-T440p-Co...Sw~dhcxGF1

0
#5 28-04-2019 
  • Registered
  • 0
  • 3
Okay, no need to yell. Many people have already told me I shouldn't expect this much from my laptop anyway. I have done most of what you linked already (defrag, ccleaner, cleaning out fan/inside, etc.) I run MalwareBytes regularly and at this point I am more interested in getting the Sims 2 to run. I can't necessarily afford a new computer and this one runs fine.

0
#6 28-04-2019 
I'm not yelling. I'm trying to keep you from driving over a cliff. Sorry if I seemed like I was yelling. That wasn't my intent. Smile

I do recommend the above laptops for playing TS2, because I know they work, and work well.

You might be able to get Windows 8.1Pro to work on your computer, if the drivers are available. I know the video drivers are. I've done many Win10, to Win8.1 conversions on "newish" computers.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option