Tried everything: still pink flashing!
#1 21-08-2019 
  • Registered
  • 4
  • 9
Hello everyone!
I can't find words to say how sorry I am to have to open another post for the same problem of everyone: the infamous pink flashing!

I know the issue was discussed in several posts, and I think I read all of them and tried almost everything (or at least was I was able to try without risking to mess my machine) but still I could not solve this problem. Is for this reason I kindly ask you help (if possible, but I suspect my case is beyond help) and/or suggestion.

This is my case:
I bought a new laptop (damned me!) and I could not manage to play properly with the Sims 2. My old machine was a 10 years old computer, which I suspect was better to play with the Sims 2 (despite I had some problems too), but I had to change it.

The specs of my new machine are attacched in my DxDiag file.
My config log attached.

This is the problem: I was able to install the sims 2 and expansions on windows 10 (following some trick I fonud online) and the game runs very good (despite the default and only resolution available was 800x600, but I changed it from the graphicrules.sgr).
when I put my old game backup and wanted to play, the disaster begun: entering in the neighborhood everythin was pink flashing: trees and water.
Tried to apply the 4 gb patch (the max I could reach was to grow up ram from 1gb to 2 gb...not the promised 4 gb). Changed the videocard.sgr and graphicrules.sgr adding my graphic card, resolution and texture memory. When entered the game again there was not immediate flashing in the neighborhood but it begun after some minutes playing, followed by sudden crashing.

I can imagine my custom content is too much (11 gb), but I could play with the same amount of custom content in the old machine (pink flasginh and crashing did happen, but not immediatly, normally after some hours of game play, or did not happen at all in hours and it is strange to have this issue with a much better machine!)

Is there someone that can imagine why all the used methods (which seem to work for other persons) do not work for me? Is there something I did not do properly?

And finally: I am considering on changing my sistem to windows 7 (my old pc was windows 7)...Would it help? Because by now is the only thing I did not try.

Attached File(s)
.txt  DxDiag.txt (Size: 85.87 KB / Downloads: 308)
.txt  MSI-config-log.txt (Size: 10.18 KB / Downloads: 320)

#2 22-08-2019 
Please read this:

Unless you can find Windows 7 drivers for your MSI, you likely won't be able to use Windows 7. You MIGHT have much better luck with Windows 8.1Pro, and play with your Intel 630 on board graphics.

#3 22-08-2019 
  • Registered
  • 4
  • 9
(22-08-2019 12:28 AM)Kunder Wrote:  Please read this:

Unless you can find Windows 7 drivers for your MSI, you likely won't be able to use Windows 7. You MIGHT have much better luck with Windows 8.1Pro, and play with your Intel 630 on board graphics.
Thank you for your reply. I had already read this post, but unfortunatly after buying those new-expensive machines is suggested not to buy... I can set the Intel graphic card as the used one, but do you think it worths to get windows 8.1 Pro? Beacuse even if I do not have any idea of how much it may cost, I imagine it has a cost...

Moreover, I have supposed that the problem might also be the not proper application of the 4 gb you think it has a sense? This was a big problem to me and I could not find a solution, even if I tried all the tips found on the web (moving it on the desktop, moving in the CSBin folder, etc...). Someone wrote in one comment I read about a more flexible .exe, but I could not find the way to get it.
I wonder if someone had the same problem.

#4 22-08-2019 
For me? Yes. It's worth it. But that's me. Win8.1Pro, is much more friendly towards older games like TS2. there are quirks, but nothing you can't easily work around.
I'll PM you later. In the mean time, you need an external USB 3.0 drive to image with, Even a 500gb drive will work. Just in case it DOESN'T work.
You'll need to download Macrium Reflect, to image your drive with.
Download Mini Tool Partition Wizard, also. Both programs are free.

Also, I would download "Classic Shell" to use with Win 8.1Pro.

If you do NOT image your current drive, it's not worth the risk. Up to you.Smile


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option