TS2 Still Crashing even though 4GB Patch is applied? Is texture memory the problem?
#1 27-08-2019 
  • Registered
  • 0
  • 3
Hello, leefish. I have previously tried to find help in MTS but it seems that finding help here is worth trying.
I am encountering a strange problem that I couldn't seem to find solution to.

Now, I know that my laptop is way too new to play TS2 UC (using Windows 10 1809 to boot), but for the past 1 month, TS2 played flawlessly on my new laptop, thanks to the 4GB patch provided by NTCore, and just today it decided to crash again. This is my only problem that I am looking for solutions to. Previously I had pink flashing only happening to two sims but deleting thumbnails and restarting the game fixed it.

Now it's this crashing that I have no idea why it happened. The 4GB patch is applied (as you can see from my config-log) so i ruled out that as the cause, so i took another look at my config-log to see that I only had 32mb of texture memory (!). I previously made the Graphic Rules using the Graphic Rules Maker, so i figured that the program caused the texture memory to default to 32mb. So I ran dxdiag to find that these are the numbers that displayed for GPU memory

Quote:- Display Memory: 9157 MB
- Dedicated Memory: 2032 MB
- Shared Memory: 7125 MB

So i changed it manually from the graphics rules to 2032mb from the instruction laid out in the Anti-Aliasing part of this page. But however, it still crashes. Admittedly the lot i was playing at was this lot, which used to crash all the time BEFORE applying the 4gb patch. Before this problem happened, playing in that lot for hours with the 4gb patch applied is possible. Now it crashes in a certain point.

Now, I looked at this MTS thread, along with the video and i thought that memory allocation might be my problem? I haven't tried to fix the standby memory problem as I am too afraid to fiddle with stuff i don't understand just for one game, but just in case, this was my memory allocation when the game crashed

I have attached my config-log, Graphic Rules, and a copy of Graphic Rules where the texture memory was 32mb. I also added DXDiag results just in case.
Also my CC Folder is 1.67GB.

Honestly, I am out of solutions to try, and I am too afraid to fiddle with the texture memory even more in fear of more problems. Anyone here might know what is happening? Thank you for your attention, and answers...

Attached File(s)
.txt  DESKTOP-00GP85O-config-log.txt (Size: 10.26 KB / Downloads: 23)
.txt  Graphics Rules.txt (Size: 33.69 KB / Downloads: 21)
.txt  Graphics Rules - 32mb texture memory.txt (Size: 33.68 KB / Downloads: 18)
.txt  DxDiag.txt (Size: 80.65 KB / Downloads: 43)

#2 27-08-2019 
I think where you have edited it is not being used properly, being nested inside if/then/else's.

Try adding seti textureMemory 4096 after seti cpuLevelUnsupported 0 at around line 45. Note mine is set to 4086, half of my actual ram.

#3 28-08-2019 
  • Registered
  • 0
  • 3
Hello, thank you for the reply! I tried it and changing 2032 in the graphic rules to 4096 in Line 136 too, but it seems that it's still not working...it still crashes
(This post was last modified: 28-08-2019 01:10 AM by michiruze.)

#4 31-08-2019 
Sounds like a Win10 update, killed your ability to run TS2. Pretty common.

#5 31-08-2019 
(28-08-2019 12:59 AM)michiruze Wrote:  Hello, thank you for the reply! I tried it and changing 2032 in the graphic rules to 4096 in Line 136 too, but it seems that it's still not working...it still crashes

Line 136 is not what HugeLunatic said, is it? She said to add a line at around line 45. If you do it the way she said, you should not need to change anything else.

But I have another question for you: In the early days of Windows, when 4 MB of RAM was a lot of memory, but many computers still had to get by with as little as 1 MB or less of RAM, a sizeable pagefile could help. But your system seems to have 16 GB of RAM memory!! So I am wondering what the hell you need a 16 GB pagefile for? If you really must have a pagefile at all, I think 1 or 2 GB should be more than enough.

A 16 GB pagefile only makes your system work harder for no good reason at all. Windows now needs a large portion of its time and its working RAM to juggle all that 'on-disk virtual memory'! If your main drive is a mechanical HDD drive, that is a lot of wasted time! And if your main drive is an SSD drive instead, the situation is even worse. SSD drives work a lot faster than HDD drives, but they also wear out faster if you write to them often. That pagefile will cause so many write actions, that in a year's time your SSD is good for the garbage bin.

#6 02-09-2019 
  • Registered
  • 0
  • 3

Thank you for the reply, but pardon if i sound like an idiot, because if i'm looking at Advanced System Settings, it showed this as the size of page file that I have?
Advanced System Settings

And my pagefile.sys file in C: weighs around 2.12GB when I looked it up (so i don't know where you have figured that my pagefile is 16GB)

#7 02-09-2019 
That may be, but if you will please take a look at the DxDiag.txt that you attached in the first post, at line 15, it clearly claims the following:

>> "Page File: 6974MB used, 9451MB available"

And since at that time I had no other information to go on, I had to assume that this was correct. I hope that you'll agree that it does look like there is 7 GB in use, and 9 GB more available. Hence my calculation of a total of 16 GB.

So you're not necessarily an idiot. You don't sound like one to me. So now it looks like DxDiag's measurements cannot be trusted.

#8 02-09-2019 
Again, your editing in the nested if/then/else. Add it where I said to add it and try that.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option