TS2 Still Crashing even though 4GB Patch is applied? Is texture memory the problem?
#11 29-12-2019 
(02-09-2019 07:37 AM)michiruze Wrote:  
(31-08-2019 04:52 AM)BoilingOil Wrote:  

Thank you for the reply, but pardon if i sound like an idiot, because if i'm looking at Advanced System Settings, it showed this as the size of page file that I have?
Advanced System Settings

And my pagefile.sys file in C: weighs around 2.12GB when I looked it up (so i don't know where you have figured that my pagefile is 16GB)
Try running WITHOUT a pagefile. If you have an SSD, you might want to install a second spin drive to keep the page file on, and keep it off your SSD.

My computer has two, 1tb, 2.5" Samsung Evo 860 SSD's (C, and D drives), and a 480gb M.2 NGFF (E) drive. so, essentially, I have three SSD's. There's a reason for this.

1) I render graphics, edit photo's, run multiple VR's, write, and test software.
2) I NEED the speed, and space.
3) I'm a bit of a gamer, and this configuration, makes everything work smoothly, and preserves my SSD's.

I have no need for a pagefile. As a matter of fact, I've found that TS2, is less jittery, if you don't have one. The same for other games.

My D: drive, holds my C: drives original image. I store data, and most of my games there.

My E: drive (M.2), is where all my "personal" folders, "Downloads" folder (NOT the TS2 downloads), all my TEMP/TMP files are there, and the most current image for my C: drive. If I'm going to do lots of read/writes to an SSD, I'd rather it be to my M.2 drive, instead of my expensive EVO drives. So far, the M.2 drive, despite massive read/writes, is still at 100% health after a year and a half.

The reason I'm posting this, is to let others know the best way of preserving your SSD's, and you most likely DON'T need a pagefile. Like I said, TS2 doesn't need it, if you have at least 8gb/RAM. It seems to run better without it.
(This post was last modified: 29-12-2019 06:06 AM by Kunder.)

0
#12 29-12-2019 
  • Registered
  • 0
  • 4
Thank you so, so much for replying. I was afraid that this thread might be dead. Also, I've redone and reinstalled so many things that I forgot to redo them the last time (however, I did make the graphics rules a txt because it wouldn't upload for mew otherwise).

Here are the most up-to-date versions in my Mansion & Garden Folder with the 4GB, DXVK filed added to my TSData->Res->Config Folder, Vulkan test passed, Graphics Rules Maker used with seti textureMemory 4096 inserted, and compatibility settings box unchecked. The game runs fine without any CC, but crashes (even in body shop) when I add my old neighbourhood and CC back to the EA folder.

.txt  Graphics Rules.txt (Size: 34.15 KB / Downloads: 7)
.txt  LAPTOP-S60LICD3-config-log.txt (Size: 10.26 KB / Downloads: 4)

Sorry, what should I be doing to my video card? Do I still need to do it with this version of my Log?
(This post was last modified: 29-12-2019 09:39 AM by Xleronze.)

0
#13 29-12-2019 
  • Registered
  • 0
  • 4
Side note, my CC is 2.20 GB. I did the 50/50 CC test to see if it was any of my custom content that was just messed up, but everything worked nicely in small groups. My game only crashed when I re-added about 1 GB of CC back to the downloads folder.

Before I trouble you further with my issue, is the general consensus that people aren't allowed to have much CC or will everything we're doing here allow me to have this much content?
(This post was last modified: 29-12-2019 08:14 AM by Xleronze.)

0
#14 13-01-2020 
  • Registered
  • 0
  • 4
Okay, figured it out after putting down the game for a week. I didn't do a proper 50/50 review of the custom content. There was a single file that came with a pre-made sim I downloaded. She was quite pretty but deadly.

For anyone who sees this, if your game is STILL crashing even without custom content, google the following that I researched from countless blogs (AND BACKUP EVERYTHING FIRST):

1. force a higher texture memory than 32MB
2. use graphics rules maker to increase screen resolution
3. make sure your graphics card was successfully added to your video card.config
4. update the graphics rules and video card in Config AND CSConfig
5. check the logs to see if things have been modded properly
6. everything you modify should be in the latest expansion pack (prob mansion and garden)
7. always run as admin and compatibility for windows 8, if you're at 10. If not, may need to run for Windows XP or Vista compatibility
8. use the 4GB memory patch
9. always run in windowed -w mode and just increase the size via resolution in-game
10. delete thumbnails folder
11. make groups and accessory caches read only so they never fill up (you can download ones from google)
12. create a task to free up memory every 5 mins (tutorial online)

Best of luck! But if your game runs smoothly without custom content, it honestly just might be a bad file.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option