I need help running TS2 on Win10
#1 19-11-2019 
  • Registered
  • 0
  • 2
Hi there,

I'm sure there are hundreds of topics with the same age-old issue, but I am really struggling to get TS2 UC to work on my Windows 10 PC.

I have tried several solutions, including but not limited to:
- Adding my GPU to VideoCards.sgr;
- Installing the 4GB patch;
- Altering Data Execution Prevention settings to exclude TS2.

Despite this, I keep getting the error on launch. My monitor resolution changes to what looks like 800x600 and the I get the error message pop up before the game even launches.

See attached for error logs.

My PC specs are:
AMD Ryzen 5 3600X
AMD Radeon RX 5700XT (had to add this to the videocards file)
16GB DDR4 RAM

Thank you everyone, I hope someone can give me a little hope. I can run it on my laptop fine, but it doesn't perform as well as I hoped it would.

Attached File(s)
.txt  THE-ONE-config-log.txt (Size: 9.35 KB / Downloads: 36)
.txt  Sims2Exception 2019.11.19 20.13.17.txt (Size: 14.52 KB / Downloads: 40)
.txt  DxDiag.txt (Size: 84.77 KB / Downloads: 38)

0
#2 19-11-2019 
  • Registered
  • 0
  • 2
I fixed it! Finally!

https://docs.google.com/document/d/19JMr...I6rOs/edit This guide helped me tremendously.

0
#3 19-11-2019 
I finally tried to follow step by step all this, but everything is now worse than ever before... Sad

My game won't load and with an error message appearing. And if I use the Origin repair tool, the game won't load AT ALL and WITHOUT any message. Sad

Hopeless... Sad

Plus, there was a virus detected on the Graphic Rules Maker software from simsnetwork.com!

I have won everything.

[Image: b2u8.png]

0


Sorry, that is a members only option