4 gb patch not working.
#1 26-11-2019 
i previously had trouble getting sims to run in a large window mode, i finally got that and now i have found a new problem. i asked on mod the sims as well https://modthesims.info/showthread.php?t=635099 but it seems that the problem has left everyone baffled.

basically i installed the 4gb patch, but the game's config log thinks it only has 2048MB i am running a patched executable. my path points to that patched executable. i am running a 64 bit OS and mycomputer has more than enough memory to use the extended address space. and despite this it still refuses to acknowledge it has more than 2048 mb. im not even sure what i did that fixed my resolution problems from before .. i am not eager to try and uninstalling and reinstalling everything again.. id have to fix the resolution all over again. >< my game has been crashing randomly and while i do have mods, (the memory issues happens regardless of mods, i checked to be sure) i mostly only have cas and buy mode mods and not all that many of them atm and im thinking the crashes are coming from the memory issue. even if the memory issue is not causing the crashes it still needs to be fixed. anyways if anyone has an idea or two im totally out of ideas but not quite ready to start from scratch again.

also not sure if this is a graphics card issue or not, my config log does seem to recognize my graphics card atm but idk where this kind of memory problem lies.

1
#2 30-11-2019 
I just had a read of everything over at MTS - you've had some great tips and hints from there, so I'm not sure why it wouldn't work.

Now. I'm pretty sure that George actually has the 4Gb patch applied to it - as I'm using it and it's got the 4G patch applied.

Can you post up both your graphic rules and your config-log.txt here - and I'll have a look at it.

You're using UC with Win 10, is that right?

0
#3 01-12-2019 
Move the patched exe to the csbin instead (yes it will work from there) and see if the 4 gb patch shows up.

I actually came up with this after I had a power supply issue that seemed to cause a problem with mine (at least I THINK that was the cause) I actually made copies of my tsbin and run mine out of tsbin3 now lol. It will only work with a no cd exe however... it can't be the origin one or the one that comes with the game.

1
#4 02-12-2019 
(30-11-2019 08:31 AM)celebkiriedhel Wrote:  yea sure, the graphics rules wouldnt upload so i resaved it as a .txt rest assured its the original .sgr that im using.

[quote='gayars' pid='45607' dateline='1575160856']
Move the patched exe to the csbin instead (yes it will work from there) and see if the 4 gb patch shows up.

I actually came up with this after I had a power supply issue that seemed to cause a problem with mine (at least I THINK that was the cause) I actually made copies of my tsbin and run mine out of tsbin3 now lol. It will only work with a no cd exe however... it can't be the origin one or the one that comes with the game.

I already Tried that, Doesn't work. i only use the cds i missed out on the ultimate collection..

Attached File(s)
.txt  SIM-GALAXY-config-log.txt (Size: 10.29 KB / Downloads: 10)
.txt  Graphics Rules.txt (Size: 33.69 KB / Downloads: 5)
(This post was last modified: 02-12-2019 01:34 AM by legendary444.)

0
#5 02-12-2019 
(30-11-2019 08:31 AM)celebkiriedhel Wrote:  I just had a read of everything over at MTS - you've had some great tips and hints from there, so I'm not sure why it wouldn't work.

Now. I'm pretty sure that George actually has the 4Gb patch applied to it - as I'm using it and it's got the 4G patch applied.

Can you post up both your graphic rules and your config-log.txt here - and I'll have a look at it.

You're using UC with Win 10, is that right?
no i missed out on the ultimate collection, its just the disks on win 10 but its all the expansions. so the most up to date is mansion and garden, so ep9 i guess.

2
#6 02-12-2019 
@legendary444

OK. I'm a bit concerned at your texture memory -- can you do a dxdiag for me? I need to see if that's really your texture memory.

In windows 7, we use "Run" and dxdiag - then after it's done, "Save all information" creates a dxdiag.txt - if you could upload that. That would be great.

0
#7 02-12-2019 
here. i think why its so low is that i was messing with the graphics rules maker program. i had been told that by changing the 'force texture memory' you can get rid of the purple flashing, so i was playing around with that.

Attached File(s)
.txt  DxDiag.txt (Size: 71.41 KB / Downloads: 6)

1
#8 03-12-2019 
@legendary444

STEP ONE: Fix the Graphic rules
OK. I've had a look and will make you your own Graphic Rules that should fix that problem. (It may help with the other problems as well). Your game was recognising 908Mb, and you have 10178 MB. So that will help a few of your issues.

Your new Graphic Rules: Download Graphic Rules for NVidia texture memory fixed and trace added

rename your old graphic rules, and put this in the same place in both folders.

\Program Files (x86)\EA\The Sims 2 - Mansion & Garden\TSData\Res\Config\
\Program Files (x86)\EA\The Sims 2 - Mansion & Garden\TSData\Res\CSConfig\

STEP TWO: 4Gb Patch Installed for sure
This is George - Download George4G

George is definitely 4G patched. It's the one I've been using, and has registered in the game as working. What I want you to do, is rename your old Sims2EP9, so it doesn't get used - from exe to old.
Put George in the same place as the original Sims2EP9.exe
(\The Sims 2 - Mansion and Garden Stuff\TSBin)

And then double click on George to start the game up. (From the exe not the shortcut.)

check the config-log.txt, and let me know if that worked. Regardless of whether it worked or not - upload the config-log.txt for me so I can check my traces.

1
#9 03-12-2019 
That worked! it now reads 4096MB for memory Big Grin

Attached File(s)
.txt  SIM-GALAXY-config-log.txt (Size: 10.28 KB / Downloads: 3)

0
#10 03-12-2019 
still has a problem with crashing tho :/ will randomly just freeze up and stop. that could be a mod thing tho ill have to check.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option