UC still lagging!
#11 10-01-2020 
From the tone of @HugeLunatic's question about compatibility, I get the impression that you should turn that option off. And it makes sense, too. I assume that the suggested patch was made to have your game work with Win10. If you run in compat mode, you're obviously no longer using the Win10 mode, thereby hindering the changes the patch made.

And after patching the exe, did you copy the patched file back from the desktop to the original folder? Because that is implied, too. The patch needs the exe to be in an un-protected area like the desktop. But for the game to work, the patched exe must be put back in the original folder, overwriting the original. Otherwise, the patch has no effect.

1
#12 10-01-2020 
I just deactivated the compatibility mode and I'll check the game right now. I did the 4 GB patch again just in case I did something wrong. Let's see if it works!

PD: I just wanted to thank you guys for being so helpful and patient with me, just that. Hope you're having a wonderful day!

Little update! I turned off the compatibility mode and this happened:

Failed to enumerate any DirectX 9 compatible graphics adapters in this system!

Please make sure you have a DirectX 9 compatible graphics adapter and have installed the last manufacturer provided driver.

The application will now terminate...


This happened to me some time ago and I remember trying to download DirectX 9 in my computer, but this version of DirectX isn't compatible with Windows 10 (I believe?). Do you guys have any idea of what should I do? Thanks in advance! Heart
(This post was last modified: 10-01-2020 12:35 AM by miaisbored.)

0
#13 10-01-2020 
Forget what I said! It's working now!

0
#14 10-01-2020 
Uploading my config-log.txt again!

Attached File(s)
.txt  DESKTOP-M4JL9DB-config-log.txt (Size: 10.35 KB / Downloads: 132)

0
#15 10-01-2020 
Ah, the trick with DX9 is, that it is indeed not compatible with Win 10. And DX12, which is usually recommended for Win 10, is incapable of properly emulating the required DX9 functions for TS2. The only solution to THAT is to install DX11 on top of DX12.

Thank you for uploading yet another version of your config-log. Usually, it is not required once everything works the way you hoped it to, but it CAN help us confirm that everything is indeed correct now. Thank you for your patience with us, too. Sometimes, it can be rather frustrating to see people talk about all kinds of stuff that doesn't seem to directly solve your problem.

1
#16 10-01-2020 
Well, when I opened the game last time I noticed that the map view (?) isn't lagging that much, so that's something! But the gameplay is still kinda laggy. Maybe is because of my graphics card? I mean, TS2 is an old game but maybe it doesn't work with my graphics card? Unless there's something else I can do.
I just downloaded the DX11 and I'm gonna install it right now!

Edit: hey guys! So, I installed DX11 and tried to lauch my game but the same message about DX9 still appears. I'm so lost! Sad
Edit 2: okayokaykay! I don't know what I just did but now it works!
(This post was last modified: 10-01-2020 01:20 PM by miaisbored.)

0
#17 10-01-2020 
Wow, what a roller coaster! lol In the end the game runs, so hurrah! Hopefully with the video card and 4gb is lags less? Not sure what else to fix. I know my game lags on large lots, but my pc is ten years old.

1
#18 10-01-2020 
Yup, this journey was a whole roller coaster! The game is running a little faster, so that's something! My PC isn't that old, but it was a kinda cheap one so yeah lol I wasn't expecting my game to run like, 60 fps and the highest graphics. Maybe a part of the lag is because of the cc polygons? I'm deleting some cc that has around 20k-30k polygons, I hope it helps too!

Thank you both for being so helpful!

0
#19 10-01-2020 
Yeah, high-poly CC will slow the game down considerably. And once you've coillected enough of it, it will simply kill the game outright! The fewer of these large monster files you have, the better your game plays.

Anyway, I'm glad your game is playing 'normal' again, at least for now. You're welcome for the help. We do what we can, because we ourselves would hate it to not be able to play, too.
I've noticed a pattern, though. Every time when you've made a change to the configuration, the game crashes with some kind of error concerning DX9, but when you start it again, everything works... So, next time, maybe you could retry a few times before panicking and saying that it doesn't work... Big Grin

1
#20 10-01-2020 
Is such a shame that the cutest cc out there is usually high-poly Sad Having the capacity to play with so many pieces of cc made me forget about the days when I was picky as hell! Slap From now on, I'll try to be more careful about poly counts.
And I'm so sorry about me panicking so much! I'll do my best to follow your advice!

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option