OUTOFVIDEOMEMORY! but my PC is compatible with Vulkan
#1 05-02-2020 
hey there guys! how are you doing today? i'm personally dying of heat (it's summer here in argentina!). Glare
so, i was reading about vulkan some weeks ago and how it could make your game run so much smoother and blah blah blah. i checked if my pc was compatible with this vulkan thing with the program and it gave me the success message so my laptop is, in fact, compatible with it! Celebrate
the problem is... when i copy and paste the .dll archives in my TSBIN folder and try to open my game this message pops up: *i attached it down in the archive thingy*
trust me, i looked for any solution that the internet could give me but nothing works! i tried forcing all the texture memory that i could with the GRM; it didn't work. maybe forcing a bit less? nothing. i literally ran out of ideas, i've even tried applying the 4GB patch again but it didn't work either and i'm so mad! i mean, i could play my game without this but the lag is slowly killing me and it seems like this is the solution to (at least the majority of) all my problems!

if someone knows how to fix this, please let me know! i would be forever grateful with you!
thank you in advance! love y'all Heart

Attached File(s) Thumbnail(s)

#2 05-02-2020 
Sorry about it not working, but here's something I do not get. I thought we had your game working. So why would you mess with that? It's already hard enough to get TS2 going on any Win 10 computer. Messing with it when it finally works, is ASKING for trouble.

And then, when it went sideways, against all advice NOT to use GRM with Win 10 because they don't work well together, you just flippin' did it anyway.
Right now, I'm trying VERY hard not to get mad at you for ignoring our advice when all we do is trying to help you. But okay, let's try to fix this.

When you copied the Vulkan DLLs into the TSBin folder, did you need to overwrite any existing files? If not, then it should be enough to simply delete all the Vulkan files that you moved in. Otherwise, though, maybe you could try to get Origin to repair your installation. Or, if you have a system backup or system restore point from before you tried to install Vulkan, you could try to restore your computer to that point.

But if neither of these three methods work, I think it's best to uninstall the game. But again, that is just *my* opinion. Others may think differently, and you're welcome to hear them out before you decide what to do.

#3 05-02-2020 
Well, I guess the lag (even without cc omg) was kinda killing me.

#4 05-02-2020 
Yeah, playing with lag is not ideal. But still, using GRM? Not a good plan, because you could've known that that wasn't going to help here. But what's done, is done.

How much stuff is there running in the background? How many things populate your system tray? The more you have active at the same time, the more your game has to suffer.

Anyway, since I know little of Win 10, nor of the UC (if that was what you were using), I think I'm in no good position to help you any further than I did before -- and I realize that even that was not much. So let us hope that at least one of my three suggestions is any good, or that someone else knows how to get your game on the right track again.

#5 05-02-2020 
idk what happened with my last answer, I swear it was longer!
There I said things like that I didn't know that GRM and W10 were a bad mix, I literally didn't see that anywhere! Every single video that I saw about people fixing their games in W10 used this program and it seemed to work.
When I start playing TS2 I close every single background program because it won't work okay if you play it while you have Opera in the background (for example).
So, I just checked what the system tray was and I only have three icons (four if we're counting the language one): the battery, the volume and the Internet.
I get it if you don't know a lot about these kinda things and hopefully someone can tell me what's going on here.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option