[TS2 Ultimate Edition - Windows 10] Game crashes upon entering Create-A-Sim screen
#1 03-03-2020 
  • Registered
  • 0
  • 6
Hello! I've been browsing this forum for a while and attempted many of the fixes, but to no avail. Basically, whenever I start up the game and enter the Create-A-Sim screen, the game crashes before I can do anything. The game runs smoothly up until this point. Here are all of the things that I have tried so far:

1. Running as Administrator and setting the compatibility settings to Windows XP (Service Pack 3)
2. Adjusting the Graphic Rules.sgr with Graphic Rules Maker and updating my Video Cards.sgr with the one in the pinned post
3. Applied the 4GB patch
4. Deleted the Accessory.cache and Groups.cache files, and replaced the Groups.cache file with a blank one and setting it to Read-Only mode

My operating system is Windows 10 Home, and my graphics card is a NVIDIA GeForce GTX 1060.

Just to be safe, I'm going to add in a screenshot of the settings I chose for my Graphic Rules.sgr.
   
I appreciate any help, and thank you in advance!
   

Attached File(s)
.txt  LAPTOP-239GH1FK-config-log.txt (Size: 10.16 KB / Downloads: 17)

0
#2 03-03-2020 
You mention crashing when going into Create-A-Sim, but other than that, everything is all right. So I guess that the problem might be in some outfit or clothing files, hairs, skins, anything that is related to creating and dressing up a sim. If you have downloaded content, then I would first start looking THERE. See what happens if you run without any CC.

Good luck.

0
#3 03-03-2020 
  • Registered
  • 0
  • 6
This is getting pretty strange, because I don't have any CC whatsoever. I also discovered a new problem in that attempting to change the sound settings in-game would also cause a crash. Trying to enter any lot, including empty ones, would also crash the game.
Should I just try re-downloading, or is there another problem happening?

0
#4 03-03-2020 
The 4gb patch is not applied, your log shows only 1024mb. Make sure you are not using compatibility mode after applying.

0
#5 03-03-2020 
  • Registered
  • 0
  • 6
Okay, so I definitely made sure that I applied the 4GB patch, and it's still crashing. I also double checked to see if I was on any compatibility settings, and I wasn't.
Here is the updated log file. What should I do now?

Attached File(s)
.txt  LAPTOP-239GH1FK-config-log.txt (Size: 10.19 KB / Downloads: 6)

0
#6 04-03-2020 
Other than increasing texture memory in graphics rules.sgr, I'm not sure what else to do. Somewhere around line 46 - 48, add seti textureMemory 4096, just below the if/else statement about os version.

If it's just in cas that it crashes, is it cc? High poly cc can cause crashers.

0
#7 04-03-2020 
  • Registered
  • 0
  • 6
Just to confirm, I put the textureMemory line in this spot? If so, then it still crashed.
   

Also just double-checking; CC stands for custom content, right? I made sure that there was none of that in there.
I also want to mention that it not only crashes while going into the CAS screen. It also happens when I try to enter a lot, and also when I try to adjust the in-game sound settings.

0
#8 05-03-2020 
Yep, right place. CC does mean custom content. I'm sorry, I'm not sure what else to try.

0
#9 06-03-2020 
  • Registered
  • 0
  • 6
That's okay. I really appreciate all the help I've gotten.
I'll try re-downloading the game to see if it helps.

EDIT: Okay, wow. Did not expect re-downloading would actually fix the problem! The game runs properly now without crashing, but now my game is stuck at 800x600 resolution, despite trying to fix it with the Graphics Rules Maker. Sorry, I've already asked for so much help, but maybe someone can help me with this?
(This post was last modified: 06-03-2020 01:33 AM by Soggy.)

0
#10 06-03-2020 
GRM? Really? We tell everyone NOT to use GRM with win 10, and they still go on doing it? GRM does not work well with Win 10! Do NOT use it!

Sorry, @Soggy, I apologize for that outburst. But in every thread where people say they tried GRM, we tell them that they shiould not do that. And it is very frustrating that everyone else NEVER reads those threads, but they all keep using GRM anyway. They all make it harder for themselves, and then they depend on US to fix it again. And we are running out of ideas too!

Also, I'm sorry, but with every update Win 10 becomes a more hostile environment to older games such as TS2. Meaning that it gets harder and harder every day to keep the game going. I advise you to install the game on an older machine that can work with Win7 or Win8.x. @Kunder has written several posts about what kind of computer to get, and he is probably even able to help you procure one. That will work a lot better, without the need for any help from us.

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option