TS2 M&G on VirtualBox running Windows 7 64-bit - graphics device not recognized
#1 29-03-2020 
  • Registered
  • 0
  • 4
This doesn't seem like something that had been attempted before (at least, not from what I can find). So I installed a 64-bit version of Windows 7 in a VirtualBox 6.0.18 virtual machine. I gave the virtual machine two CPU cores, 6014MB base memory (RAM), 256MB video memory, VBoxSVGA graphics controller with both 2D and 3D acceleration, 128GB of storage, and VirtualBox Guest Additions. While installing VirtualBox Guest Additions, I opted to install the Oracle VM VirtualBox WDDM Driver and not the Basic Direct3D support (see manual). Given this, the game should have had sufficient resources to run, not with stellar performance (this is a virtual machine, after all), but at least acceptably. DxDiag reports that the system has 383MB of display and dedicated memory, though it has 0MB of shared memory (not sure if that makes a difference).

Installation of the game went without a hitch (I did not install Ultimate Collection; I installed Double Deluxe, then all of the EPs, then the SPs), and installed all of the patches. I ran Sims Graphics Rules Maker and it appeared to have successfully updated the relevant config files; however, it failed to add the VirtualBox driver to the Video Cards.sgr file, even when prompted (no error message would appear; clicking on "Add now..." simply did nothing).

[Image: zcBrIg5.png]

The game started up with no issues (no errors about DirectX issues or any of that), and was able to successfully initialize Pleasantview. However, I was greeted with the unsightly "flashing pink" issue.

[Image: EXkHFmk.png]

When I loaded the Pleasant family lot, all of the wall textures flashed red.

[Image: YOa8klg.png]

The flashing pink issue was resolved by adding boolProp UseShaders false to the userStartup.cheat file. However, the game's graphics settings are still stuck at their lowest values, with no way to increase them (resolution is stuck at 800x600, for example).

According to -config-log.txt, the game isn't recognizing VirtualBox's graphics adapter and flags it as "NOT FOUND IN DATABASE!", is only using 32MB of texture memory, softwareDeviceLocalVideoMemorySize is set to 33554432, and activeDeviceUseSoftwareRasterizer is set to true. I attempted to add the adapter to Video Cards.sgr myself by adding the following to the bottom of the file:

Code:
#############################################################################
vendor "VirtualBox" 0x80ee
  card 0xbeef "VirtualBox Graphics Adapter (WDDM)"
end


I then went into Graphics Rules.sgr and made the following changes:

Code:
if (not $useSoftwareRasterizer)
   # failed to obtain device texture memory size, force to 32MB
   if ($textureMemory = 0)
      seti textureMemory       383
      setb textureMemorySizeOK false
   endif

Code:
if ($useSoftwareRasterizer)
   # ignore texture memory reported by gfx device, this is not hardware texture memory
   seti textureMemory 383
endif

...trying to force the game to recognize VirtualBox's adapter and force it to use 383MB of texture memory. However, none of these changes worked, and the game continued to run in software rasterization mode, with the lowest graphics settings chosen, and the game runs sluggishly.

Attached is my -config-log.txt file. I also uploaded my Graphics Rules.sgr and Video Cards.sgr files on Pastebin.


.txt  WIN-7-64BIT-VM-config-log.txt (Size: 10.3 KB / Downloads: 62)

0
#2 29-03-2020 
It looks like it's being forced into low settings.

Rather than letting the game decide, via if/then/else statements, I'd just add seti textureMemory 4096 at line 46 in the graphics rules.

At line 22-24 with seti low/medium/high, generally for newer systems it's changed to force high for all, so set all to 3. Not sure, but these constants might force options later in the file to force low/med to high.

You will also want to change the screenmoderesolution to the max screen size, or whatever is allotted with virtual box.

There are also shadow options that change based on low/med/high settings.

0
#3 29-03-2020 
  • Registered
  • 0
  • 4
Thanks for the response.

I attempted to add seti textureMemory 4096 to line 44, and changed the settings on line 22 and 23 to 3. The game continues to run as before, though, with all settings locked at their minimum values, only using 32MB of texture memory. I then went and changed the settings on line 780 - 797 to:

Code:
option ScreenModeResolution
   setting $Low
      uintProp maxResWidth      1280
      uintProp maxResHeight     1024
      uintProp defaultResWidth  1024
      uintProp defaultResHeight 768

   setting $MediumButDefaultLow
      uintProp maxResWidth      1280
      uintProp maxResHeight     1024
      uintProp defaultResWidth  1024
      uintProp defaultResHeight 768

   setting $Medium
      uintProp maxResWidth      1280
      uintProp maxResHeight     1024
      uintProp defaultResWidth  1024
      uintProp defaultResHeight 768

The game remained locked at 800x600 resolution, with no way to change them.

[Image: XEcPbJk.png]

I also renamed the Documents\EA Games\The Sims 2 folder to something else in order to force the game to regenerate the folder. The issues remained the same.

If I could describe what's happening, it's as if the game isn't reading the files at all.

For the record, I double checked to make sure I was editing the files in the M&G folder. I don't think it would make a difference to have to edit the files in all of the folders. It's a head-scratcher trying to figure out why the game isn't seemingly reading those files.

0
#4 30-03-2020 
  • Registered
  • 0
  • 4
I tried a myriad of different options, all of which failed. I'm exhausted, but I did keep a log of what I did. For anyone who is interested (say, the person looking at this thread ten, twenty years from now), here's a journal of sorts that detail what I tried.

I'm going to call it a day on this issue for now, but I'll keep trying, because a Google search shows that at least some people have had luck getting the game to run in VirtualBox.

0
#5 04-04-2020 
  • Registered
  • 0
  • 4
I'm not sure if I should start a new thread, but as it is still on the topic of running the game in a virtual machine, I think I'll keep it in this thread for now.

I installed Windows XP SP3 32-bit in VMware Workstation Player (not VirtualBox), gave it 100GB of storage, 4GB of RAM, and one processor rather than two. I was able to get the game to successfully run, though I only installed Double Deluxe (I did not install any other packs). Unlike VirtualBox, I was successful in getting the game to recognize the graphics adapter and not run in software rasterization mode, thereby unlocking the higher graphics settings. However, I now encountered a new problem: the terrain wouldn't load, instead replaced with a grey background.

[Image: E0kK3BZ.png]

When a lot is loaded, the terrain doesn't load either, although oddly enough the objects do load.

[Image: jb0nnUg.png]

Graphics Rules.sgr: https://pastebin.com/i8TLKe8S

Video Cards.sgr: https://pastebin.com/dtNEfThX


.txt  EXAMPLE-D3550F6-config-log.txt (Size: 9.7 KB / Downloads: 45)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option