Still Stuck in 800x600 after fixes (Win 10)
#1 24-04-2020 
  • Registered
  • 2
  • 7
Hi everyone!

I've been trying for some time to get the game to run in a higher resolution than 800x600, but haven't had any success. I've tried multiple fixes (editing/replacing the Graphic Rules files, Video Cards files, Graphics Rules Maker, etc) and in spite of all this my game still insists on running only in low res. I was hoping someone could take a look at my config file and give me an idea of where I might be getting it wrong.

Thank you! Big Grin

Attached File(s)
.txt  DESKTOP-JOEQN46-config-log.txt (Size: 10.32 KB / Downloads: 27)
.txt  Video Cards.sgr.txt (Size: 22.93 KB / Downloads: 22)
.txt  Graphics Rules.sgr.txt (Size: 34.13 KB / Downloads: 24)

0
#2 26-04-2020 
Hi @Denise,

I have two questions for you.

1. Would you please confirm that you are actually playing with Windows 7 here? I just want to make sure that I'm reading your log right.
2. Could you please attach a DxDiag.txt for me to look at? The 32MB your texture memory is currently set to, is probably a big part of the problem you're having. To help you change it, I need to see what DxDiag says about your system.

What I do find problematic, though, is that all the Screen Resolution settings in your graphics rules file seem to have been set to the max setting of 1920 x 1080. THAT should never be necessary, and in my experience it usually causes more problems than it solves. It's not just some whim that made the game developers choose for low, medium and high resolution settings to all be available as defaults. Now I wonder, did YOU do that, or is this one of the 'helpful' BLUNDERS of GRM? (really, I HATE GRM. It screws up more than it fixes!)

0
#3 27-04-2020 
  • Registered
  • 2
  • 7
Hi @BoilingOil!

Thanks for your response. I can confirm that I'm on Windows 10, not sure why something might have said I was on Windows 7. Checked the .exe and am not on any compatibility mode either.

The settings changed in the graphics rules files were my own doing, it's one of the "solutions" that was listed on google regarding my issue - I'll go ahead and restore the original values. Also, I've attached my dxdiag file as you requested.

Thanks again! Big Grin

Attached File(s)
.txt  DxDiag.txt (Size: 91.81 KB / Downloads: 13)

0
#4 27-04-2020 
Hi @Denise,

This is really odd. Your config-log.txt says the Operating System (OS) is "Windows NT 6.0", which actually means "Windows 7" (I know this, because I run Windows 7 myself)
When Windows 10 is used, it usually speaks of "Windows NT 6.2", which your game does not.
So now you know why I was asking, because your config-log was confusing the heck outta me. Thank you for clearing that up (although now the riddle is, why does your game say that?)

Now, let me have a look at your Dxdiag... OK, I think I've seen what I needed.

Clearly, you are aware how to edit your .sgr files AND you know where to find them, so I won't have to worry about explaining that Smile That makes life a lot easier :yay:
Open up the file "Graphics Rules.sgr" and look around line 50. You should see a section that looks like:
Code:
#############################################################################
#
# Identify gfx device
#

And just above that, there may be a line that says:
Code:
seti textureMemory 32

if that line exists, change the number 32 to read 4160
If that line does NOT exist, however, then please CREATE such a line. Remember, just above the "Identify gfx device" bit:
Code:
seti textureMemory 4160

And just in case it matters, make sure that the first M in textureMemory is a capital M, not a small m Smile Because you never know when the game is getting strict about these things.
When done, save the file, and copy it to the CSConfig folder, too.

Now I'm curious what happens if you start the game. Do you have access in the settings menu to other screensize modes, and will they actually work? Please let me know what happens, okay?

Good luck!

0
#5 28-04-2020 
  • Registered
  • 2
  • 7
Hi @BoilingOil!

Sad to say I had no luck with the changes made Sad Still only had the 800x600 option listed with the Shadows and Edge Smoothing greyed out as usual. I can't for the life of me figure out what's going wrong with my game lol

I went ahead and attached the updated copy of my Graphics Rules, just in case I goofed up adding the seti textureMemory line. Thanks again for your help Smile I really appreciate it!

Attached File(s)
.txt  Graphics Rules.sgr.txt (Size: 34.15 KB / Downloads: 14)

1
#6 28-04-2020 
Hi again, @Denise,

Thank you for not making me ask you to upload your Graphics Rules. That was absolutely PERFECT! Exactly the file that I wanted to see this time!
You're a lot smarter than the average bear, and I like that!

So, let me have a look... Ah... great job, but I see where we went wrong.

You made it look like:
Code:
#############################################################################
# seti textureMemory 4160
# Identify gfx device
#

But actually, you had to put that new line a little bit higher up, before ALL of the bit that I showed, where it didn't get a # in front of it.
Something like this:
Code:
seti textureMemory 4160
#############################################################################
#
# Identify gfx device
#

The # in front of the line makes the game think that it's a comment for us humans, and that it doesn't need to do anything with it.

On the other hand, I noted that you had indeed reverted the screensize data correctly. I would, however, suggest that you now change ONLY the "High" setting to your screen's REAL size, so that will be available to you. A bit like:
Code:
setting $High
      uintProp maxResWidth      1920
      uintProp maxResHeight     1080
      uintProp defaultResWidth  1024
      uintProp defaultResHeight 768

Just to make sure that you get me: ONLY the "setting $High" section, and not any of the others. All right?

And when that's done, I hope that it actually WILL work.
And if not, we will have to come up with something else, right? Because we don't give up just yet.
And in that case, I do not need to see your Graphics Rules again, ok? I trust that you will get it right, this time.
But the newest version of your config-log will be welcome, thank you.

And let me express my sincerest apologies, because seeing how you actually executed my instructions to the letter, precisely as I said, instead of what I meant (my fault, I should have been more precise), I would have written my instructions more like in THIS post. And that would have saved us a whole day of work. Sorry, that was MY mistake.

Good luck once again.

1
#7 28-04-2020 
I run windows 10 Pro and my config log says OS version: Windows NT 6.0. So I wouldn't believe the config.log as the definitive for OS versions, because 6.0 is actually Vista.

1
#8 29-04-2020 
  • Registered
  • 2
  • 7
Hi @BoilingOil!

Alas, no luck with the fixes Sad Still getting the usual options in the graphics settings. Man, this game really does not want to let us win! haha.

I've attached the config log as you've requested. Big thanks again for your help, you're the best! Big Grin

@HugeLunatic - That's so weird that it does that, glad it's not just mine that's being goofy lol.

Attached File(s)
.txt  DESKTOP-JOEQN46-config-log.txt (Size: 10.32 KB / Downloads: 14)
(This post was last modified: 29-04-2020 09:57 PM by Denise.)

0
#9 30-04-2020 
@HugeLunatic: Thank you for setting me straight. I was not aware of that, but made an assumption based on the evidence that I hadd seen so far. I had no doubt, however, that Denise would lie when she said that she's running Win 10. It is what it is, right?

@Denise: Alas, the config log still insists that you have only 32 MB textureMemory, so I fear that I have to aks you to send the latest Graphics Rules again after all. Sorry about that.

0
#10 30-04-2020 
  • Registered
  • 2
  • 7
@BoilingOil: No problem at all! Hopefully I didn't goof it up, that would be annoying of me lol

Attached File(s)
.txt  Graphics Rules.sgr.txt (Size: 34.15 KB / Downloads: 12)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option