DirecrX 9.0c error despite running Graphics Rules Maker?
#1 13-07-2020 
  • Registered
  • 0
  • 3
Hi all,

I'm having the classic "Failed to find any DirectX 9.0c compatible graphics adapters" error whenever I try to run TS2--the only way I can get the game to run is in windowed mode, which isn't particularly fun. I'm running Windows 10 with an Intel graphics card from 2018 (which you'll be able to see in my config-log file). I've tried many different things--I can tell that this is an issue with my video card not being recognized, so I used the Graphics Rules Maker to add my card to the database, which seemed to work since the card is being recognized in my config file, but I'm still getting the same DirectX error message. I've double checked that the path to the game is correct (Apartment Life is my most recent expansion, and the files are being modified in the AL folder, so that shouldn't be an issue), and I've even run dxdiag to make sure my card supports DirectX (it does--I have DirectX 12.0). It sounds like even though my card is in the database now, there is some sort of disconnect that makes the game not take advantage of my card or its features somehow.

Would anyone be able to give me some guidance? I'm also wondering if this could be related to texture memory, which is also odd because I'm pretty sure that I enabled Graphics Rules Maker to change texture memory.

I've included my config file, a screenshot of the error (just in case), and a screenshot of the settings I'm using with Graphics Rules Maker. I'm also running the game from the CD. I'm also running the game by using the command line (in admin mode) to execute the Sims 2 launcher because of a weird security feature that Windows added in an update that blocks any attempts to run the game from the shortcut, but I don't think that should change anything.

Thanks in advance!

Attached File(s) Thumbnail(s)
       

.txt  SAHAJTHEPC-config-log.txt (Size: 10.63 KB / Downloads: 38)

0
#2 13-07-2020 
I really have no clue how to help you... but I DO know this forum asks you to:

Before you post requesting help
Information we need
The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.

...and the GRM is known to cause problems with Win10.

Good luck! Cool

1
#3 13-07-2020 
  • Registered
  • 0
  • 3
I did attach my copy of -config-log.txt at the bottom of my post, beneath some screenshots--are other people not able to see it? I'll re-attach it here.

Yeah, I found out from browsing the threads here that GRM can cause issues with Win 10 once I posted...whoopsie! Confused I'm going to try some fiddling around later today based on re-reading the forum. Failing that, I suppose I could try re-installing...Sad


.txt  SAHAJTHEPC-config-log.txt (Size: 10.36 KB / Downloads: 41)

0
#4 13-07-2020 
I *did* (and still *do*) see the config-log.txt attached to the top post, so you did nothing wrong there, Geek (sorry, I hope you don't mind me shortening your name al ittle?)! I think that Cat was not yet quite awake when she read your post. We all have our blonde moments, from time to time.

My late mother taught me to keep my mouth shut if I had nothing positive to add. So I didn't want to say anything at first, but the continued use of GRM with Win 10 is a source of great frustration for some of us. And especially using GRM just to add your graphics card to the Video Cards.sgr is something that agravates me, because it is so easy to do manually. But hey, the damage was done, and THAT part at least worked... I hope that someone can help you with the DX9 issue, but chances of that happening get slimmer every time that Microsoft rolls out an update to Win10.

1
#5 13-07-2020 
I've posted this to another thread and never heard back if they tried it and it worked. Managed directx 9c is used to run SimPE. You could try installing it to see if it helps, after all, it still is directx 9c.

https://sourceforge.net/projects/simpe/f...ectX%209c/

I have no idea what security update you think makes the shortcut not work, but I suspect it's just your shortcut and/or avg that borked the shortcut. Try deleting it and creating a new one. Windows 10 has full screen optimization for gaming which could cause issues when playing in window mode. It's also only designed for newer games, maybe try disabling that. Right click the shortcut, compatibility tab, then tick the disable full screen optimization box.

The texture memory hasn't been fixed and you also appear not to have done the 4gb patch.

1
#6 13-07-2020 
  • Registered
  • 0
  • 3
@HugeLunatic--thanks so much! I'll try those changes and see what happens. What should I know about the 4GB patch before I use it? (If you would prefer sending a link over spending time on an explanation, I do not mind at all.)

0
#7 13-07-2020 
GAH! Yes - I hadn't had my coffee yet. Sorry Slap
...not so much a 'blonde moment' as a 'grey moment ere coffee' *sigh* HL to the rescue Blush

3

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option