Good old Sims 2 Ultimate DirectX issue
#1 17-08-2020 
  • Registered
  • 1
  • 6
Hi! Hello. I have the dreaded problem that many, many users seem to have when attempting to play the Sims 2 Ultimate Collection (digital download): my GPU is too new for the game to recognize. I've been scowering the forum for the past couple of days now, and have tried almost any and everything, to no avail. I'm running Windows 10 62-bit, which I understand has some issues with the game.

Basically my problem is that whenever I attempt to run the Sims 2, I get the dreaded text box of "failed to find any directx 9.0c compatible graphics adapters the application will terminate, etc..." I have installed Graphic Rules Maker. I've switched the GPU from Intel integrated to Nvidia GTX, ran as administrator, ran in compatibility mode for Windows XP 3, downloaded and unzipped/installed the Graphic and Video rules SGR files, made sure they were both in the "config" and "csconfig" folders, and added "-w" to open in windowed mode for the shortcut.

I don't have any problems with the game crashing when attempting to load, but when I open in windowed mode, it stays in 320x320 resolution, even though I've changed the max res to 1920x1080 in the game files. Additionally, I should add that I tried the video and graphic rules fix for my intel GPU, but haven't done so for the Nvidia one, but I'm losing hope here.

TL;DR: So, I can't open the game without adding the "-w" to the shortcut, or otherwise I get the DirectX error. If I open the program in windowed mode, it's stuck at 320x320 or something similar resolution.

Would anyone possibly have a solution to this? I'm a breath away from buying an old Windows 7 laptop just so I can play the game without wanting to rip out my hair. I'm pasting my most recent config log as well as graphic rules and video cards for further clarification. Any advice welcome!

Attached File(s)
.txt  LAPTOP-UPQQLORE-config-log.txt (Size: 10.42 KB / Downloads: 35)
.docx  Directx Error.docx (Size: 57.84 KB / Downloads: 37)
(This post was last modified: 17-08-2020 05:03 PM by rainbowroof.)

0
#2 17-08-2020 
Everything converted to .DOCX format? What was wrong with just giving everything a simple .txt extension?
Well, it doesn't matter much to me, because I know by far not enough about UC and Win10 to help anyway. Just wanted to express my surprise at such an odd choice.

0
#3 17-08-2020 
  • Registered
  • 1
  • 6
Lol! I tried uploading as .txt files, but it said the extension wasn't supported, so I just copy and pasted into Word.

0
#4 17-08-2020 
Well that is odd, because .txt is the primary format encouraged for use here.

0
#5 17-08-2020 
I'm sorry 320x320? Where in the world does that come from? But those docx files suck. Try using this graphics rule: http://www.leefish.nl/mybb/showthread.php?tid=6881 Then post back your config as a .txt.

I'm not sure you can play full screen without the direct x error? But you could try disabling the full screen optimation.
[Image: 2mbA4Jx.png]

0
#6 17-08-2020 
  • Registered
  • 1
  • 6
Yeah...I have no idea where that res comes from, either. Also, apparently it's 320x200, not 320x320. Tried the full screen optimization, but it didn't do anything. I've accepted at this point that I'll have to play in windowed mode, but the 320x200 res is killing me. Attached screencap of the res problem and config log.

[Image: e00280a02757d08710fa670270f383c15470c415.png]

Attached File(s)
.txt  LAPTOP-UPQQLORE-config-log.txt (Size: 10.45 KB / Downloads: 40)

0
#7 17-08-2020 
  • Registered
  • 1
  • 6

Most recent config log added here since I updated the Graphic Rules and Video Cards.

Attached File(s)
.txt  LAPTOP-UPQQLORE-config-log.txt (Size: 10.42 KB / Downloads: 34)
.txt  Video Cards.txt (Size: 21.83 KB / Downloads: 38)
.txt  Graphic Rules.txt (Size: 34.35 KB / Downloads: 35)

0
#8 18-08-2020 
@rainbowroof, may I request that when you reply to the LAST post in a thread, you do NOT quote the message? The original is already right above your own message, so people can read it back without having to search for it. Thanks in advance for your compliance Smile

1
#9 18-08-2020 
Yea, I wasn't convinced the full screen optimization would do anything, but I had read about other older games disabling it and it helping. I was hoping there was more logging in that graphics rule that would help.

So your config says you have 2048 of memory, which considering you have the 1050 Ti, I doubt that is your RAM. You'll want to enable the game exe to use 4gb. https://ntcore.com/?page_id=371

Trying to find anyone else with the size resolution and a fix, but no luck yet. Are you trying to force a resolution size in the exe? If so I would remove that.

EDIT: I found a user who DID force the resolution and it worked. -r1920x1080

0
#10 19-08-2020 
  • Registered
  • 1
  • 6
So I downloaded the program to get the extra RAM, but now the game itself doesn't launch. It asks me, twice, if I want to allow an unknown publisher to make changes to the app, I click yes both times, and then my Origin game library window pops up. I'm assuming I did something wrong...?

I chose the .exe from this path to execute the additional RAM:
C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9\TSBin\Sims2EP9.exe

I also tried adding the "-r1920x1080" to the shortcut, but that didn't work either. I was hoping it would!!

Attached File(s)
.txt  LAPTOP-UPQQLORE-config-log.txt (Size: 10.42 KB / Downloads: 32)

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option