[solved] Windows 10, UC, can't alt-tab out of game or run windowed mode
#1 13-09-2020 
  • Registered
  • 3
  • 3
Hi,
Thanks to reading your forums, I have finally managed to get TS2 to run on windows 10! (thank you all so much for your informative posts!) but I still have one problem - the game will only run in fullscreen (adding " -w" to the target of the shortcut results in the 'failed to find directx 9.0c' error), and I cannot use alt+tab to change to a different window (the interface for selecting a different window comes up but it just stays of the sims window or the screen goes black until i alt tab again). Also, this may be related, the config log is showing the wrong graphics card, even though I added it to VideoCards.sgr. I only have one, so I don't really understand where it gets this wrong one from.

I originally used graphics rules maker because i didn't know it had problems, but after reading that here I replaced the GraphicsRules and VideoCards .sgr files with the ones downloadable from this forum, but unfortunately it made no difference but lowering the resolution. I've also tried 'disable full screen optimisation' on the shortcut, which results in a different error message ('the application was unable to start correctly'), and in my graphics card setting program turning gpu scaling on which i think i read someone here saying worked for them, but it had no effect either.

Edit: I also can't run bodyshop, but I'm unsure if you guys offer help with that? just thought I'd mention it in case.

If anyone has any advice on what to do I would really appreciate it!

Attached File(s)
.txt  DESKTOP-6NGIKLG-config-log.txt (Size: 10.21 KB / Downloads: 29)
(This post was last modified: 25-09-2020 03:47 PM by tiredtired.)

0
#2 24-09-2020 
  • Registered
  • 6
  • 6
Hello tiredtired! I had the exact same problem.

Initially my game wouldn't launch at all, so I followed the whole guide: 4gb patch, fix Graphics rules and Video Cards (without Graphics Rules Maker) etc. Still no success. I found this article and used the last step (D9VK fix). Lo and behold! The game launches! Only problem: the minute I try to put it into windowed mode, I get the dreaded Directx 9.0c error. Now, I prefer windowed mode as a writer, and the thought of having the game fullscreen forever and being unable to alt-tab frustrated me. I initially found a messy workaround using software that forces the fullscreen game into a window, but I did not like it.

So, I continued searching. Today, I stumbled across this thread. It is still using the D9VK (or DXVK) fix, but the files you download and copy-paste are a bit different from the previous article I mentioned. Read and follow the doc carefully! My game now works in windowed mode without using other software. No failed launch, no Directx 9.0c error. I felt like crying when that familiar intro popped up.

Here are my specs too, so you get an idea of what kind of system I am running:
Windows 10 Home 64-Bit
AMD Ryzen R5 3600X
AMD Radeon RX 5700 MECH OC
16 GB RAM

2
#3 25-09-2020 
  • Registered
  • 3
  • 3
ReiraKurenai, you've saved me! The thread/doc you linked worked perfectly! Thank you so much!!! Big Grin

1
#4 25-09-2020 
  • Registered
  • 6
  • 6
Yay! I'm so glad it worked for you too!

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option