The Sims 2 Ultimate Collection Won't Launch!
#1 16-09-2020 
  • Registered
  • 0
  • 1
Hello,

I've had The Sims 2 Ultimate Collection for 5 years now and it worked fine on my old PC. Last year I bought a new gaming laptop since the PC I used to have was my dad's PC and he decided to take it back because I was moving and couldn't fit it at my new place, so that's when I got my gaming laptop. I'm sorry for rambling, anyway, I wanted to play The Sims 2 again, so I installed it on my new laptop, when I try to launch the game my mouse cursor indicates that it's loading but after a few seconds it'll stop and the game doesn't launch at all! There's no error message or anything, it just shows it's loading for about 10 or 20 seconds and then nothing happens. If anyone could help me out here I'd really appreciate it! I'm on Windows 10 with the current update.

0
#2 17-09-2020 
  • Registered
  • 2
  • 2
Hi! First suggestion would be that you go to your logs folder (C:\Users\[YOUR USERNAME]\Documents\EA Games\The Sims™ 2 Ultimate Collection\Logs) and look at the file ending in -config-log.txt & upload it in this thread.

Other information that would help:
Have you applied any memory patches? (2gb, 4gb)
Have you edited GraphicsRules.sgr or VideoCards.sgr?

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option