Stuck at 1024 MB even after 4GB patch
#1 04-12-2020 
  • Registered
  • 0
  • 3
Hi, hoping someone here can help. I am running Windows 10, have the sims 2 ultimate collection. My issue is it very often lags, then gives me the blue screen with the turning hourglass. After about 15 seconds the game resumes. This happens when I make a movement, like edge scrolling, or rotating, or even clicking through different menus in the game. I don't experience crashing or the pink flickering, but the constant lag/blue screen makes the game virtually unplayable.
My laptop has 8GB ram. However, in the log it says I am only using 1024MB. I've tried installing the 4GB patch from NTCore, but it does not recognize it no matter what I do. I tried moving the game .exe to the CS bin and applying the patch there. I've tried moving the game to my desktop and applying the patch there. Both times it gives me the popup that it was successful, but still it says 1024MB in the log.
I also tried installing the Graphic Rules Maker, but it cannot find my game. I manually route it to C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9\CSBin but there is no game found there (despite the fact I know it is there as when I go through file explorer I locate it easily in the same place).
I've attached the config-log.txt below.
Thanks in advance!

Attached File(s)
.txt  MK-config-log.txt (Size: 10.4 KB / Downloads: 54)

0
#2 04-12-2020 
Not sure why GRM cannot route to your game, but did you try right click/run as Admin fro GRM? Here is a 4gb enabled file, try replacing yours with it. https://app.box.com/s/rro0yj0r9ttn0ce0k296cuf00fxtg8n0

1
#3 04-12-2020 
Posted by mk3003 - Yesterday 10:54 PM
"I manually route it to C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9\CSBin but there is no game found there (despite the fact I know it is there as when I go through file explorer I locate it easily in the same place)."

I had the same issue/did the same thing on my new laptop Slap you just went to far with your routing... Stop at the SP9 folder. So, the routing should just be:
C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection\Fun with Pets\SP9
Then the GRM will find it Cool

1
#4 27-12-2020 
  • Registered
  • 0
  • 4
I have a similar issue, at least with the 1024 MB, but my game will not launch at ALL.

Log generated on 12/26/2020, 16:51

=== Application info ===
Name: The Sims 2 EP9
Version: 1.17.0.66
Build: ReleaseSRT
=== Machine info ===
OS version: Windows NT 6.2
CPU: 3493Mhz, Name:AuthenticAMD, FPU:1, MMX:1
Memory: 1024MB
Free memory: 1024MB
User: chris
Computer: DESKTOP-96EOE5A
=== Sound device info ===
Name: Unknown
Driver: Unknown
=== Graphics device info ===
Number: 0
Name (driver): AMD Radeon R7 Graphics
Name (database): AMD Radeon R7 Graphics <<NOT FOUND IN DATABASE!>>
Vendor: ATI
Chipset: Vendor: 1002, Device: 9874, Board: 13d01043, Chipset: 00c9
Driver: aticfx32.dll, Version: 27.20.14501.18003, GUID: D7B71EE2-DB34-11CF-A035-750B72C2D635
Driver version: 18003
Monitor: \\.\DISPLAY1
Monitor aspect: 1.782383, 16:9
Screen mode: 1920x1080x32BPP,60Hz
Texture memory: 32MB
HW T&L: Fixed function:1 Programmable:3.0
Pixel program: 3.0
Texture stages: 8
AppControlledAA: 1

0
#5 28-12-2020 
@desmei We'll need to see a dxdiag.txt before we can determine what's going on. And this time, INSTEAD of copying and pasting it into the post, try ATTACHING it. Press the "Full Editor" button below, to find the "Attach" options. If you don't attach, we do not get all the information we need, and then we CANNOT help you, however much we would want to.

However, I guess that you need to install the 4GB patch, and fix the video cards.sgr to include the correct details for your graphics card. TO BEGIN WITH, because there may be more issues later on.

0
#6 30-12-2020 
  • Registered
  • 0
  • 4
:Hi all, I'm actually "Mr." Desmei and I'm trying to sort this out for my mate. I'm more of Mac guy, so please bear with me; the learning curve has been steep. I've tried all of the suggestions in these threads but the game will not launch--it just cycles back to the Origin screen. I've uninstalled, reinstalled, ran the graphics rules maker, manually changed the .scr file and nothing. The only way I can get the game to launch is to repair it through Origin and it will load (it takes 18 minutes) and its only using 1024gb of memory at a 600x800 res. Any other fixes or patches just make it not work.

Thanks so much in advance!

[/quote]
Sorry, its Windows 10. 12gb of RAM

Attached File(s)
.txt  DESKTOP-96EOE5A-config-log_1st_after_reinstall.txt (Size: 10.31 KB / Downloads: 37)
(This post was last modified: 30-12-2020 05:36 PM by desmei.)

0
#7 31-12-2020 
Ok, I'll try to crash-course you through this, "Mr. Desmei" Smile

With 12 GB, this should run well, but in order to use more than 1GB of RAM, it *does* require a so-called 4GB patch... the best one out there is George. This package should be unpacked and it should overwrite the file named "Sims2EP9.exe", wherever that is installed.

Secondly, the Video Cards.sgr file must be updated:
Find this file in the folder "TSData\Res\Config" under the folder where Sims2EP9.ico is installed (sorry for the funky description, but I know little of the UC or of Win 10; I run the original Sims 2 under Win 7)
When you have the file, open it in a text editor, and find the line reading:
Code:
vendor "ATI" 0x1002
Right below that line, insert a new line reading:
Code:
card 0x9874 "AMD Radeon R7 Graphics"
Then save the file, and close the editor. Now this file should also be copied from the "Config" folder to the "CSConfig" folder.

Thirdly, the texture memory must be updated, but in order to do that correctly, I *do* still need to see the dxdiag.txt. For that, you need to run the DXDiag program and click "Save all data". Then find the dxdiag.txt and attach it in the same way as you did with the config-log.

I hope we can get this going without too much trouble. Good luck.

0
#8 31-12-2020 
And another quick hint - after using 'George' you will NEVER need to reinstall from Origin. 'George' severs all ties with Origin - the game will not "phone home" anymore. The game still lives in the OriginGames folder... but know in your head that it is no longer connected to Origin (and that is a VERY good thing!) Tongue

0
#9 14-01-2021 
  • Registered
  • 0
  • 3
@Huge Lunatic Sorry this is very late, but the 4gb file worked absolutely perfectly, thank you so much!

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option