Sims 2 resolution stuck at 320x200
#1 23-03-2021 
  • Registered
  • 1
  • 2
Hi!!Thanks in advanced for replying me.

Well,i got a new laptop and trying to get it work with sims 2.you know how ugly it can be,right?

So,after installation(not going very well....) ,i got a directx 9.0c adaptor warning.I googled everywhere and tried everything(updating your gpu driver,make it windowed mode,ect),none of them worked.but after checking some boxes in graphic rules maker.i finally got into the game,yay!!not sure how i did it though.Undecided

Then i found that the reslution stucked at 320x200,even though i set it as 1980x1080 in GRM,or rewrite ScreenModeResolution to 1980x1080 manually,or duplicate changed graphic rules.sgr to the sims 2 and AL config/csconfig folders.there's no new option in the resolution panel,and the anti-aliasing option remains grey.it's really frustrating...

Another thing is that,when i testing everything,i found that my game may be running with the intel card,not my nvidia card.is there anyway to change it?

I installed all the EPs and SPs,final SP is M&G.my computer configuration is
system:windows 10 cpu:Intel® Core™ i7-9750H CPU memory:8GB gpu: Nvidia GeForce GTX 1660Ti Intel® UHD Graphics 630.

Hope i made myself clear.and once more,THANKS FOR HELPING!!Blush

Attached File(s)
.txt  DESKTOP-KQ01D6V-config-log.txt (Size: 10.52 KB / Downloads: 65)
.txt  Graphics Rules.txt (Size: 34.13 KB / Downloads: 64)
.txt  Video Cards.txt (Size: 25.87 KB / Downloads: 62)

0
#2 24-03-2021 
  • Registered
  • 1
  • 2
Hello,i solve the problem.Thanks to Arg0n who reply this thread and provide his/her thought.HeartHeartHeart

here's the link: http://leefish.nl/mybb/showthread.php?tid=9481

I believe i cannot change my resolution because of my screen refresh rate only has 144hz,and the game requires 60hz.so the game can only runs in the lowest setting.what you need to do is that add 60hz in resolution option by using Custom Resolution Utility.
I learned that even though my laptop has nvidia card,yet the resolution controlled by my intel card.i believe many laptops work in that way,which i don't understand why they did that.you need to check what resolution you have at right-click on the desktop > Display settings > Advanced display settings > Display adapter properties > Monitor tab to see what's your refresh rate is,i believe laptops nowaday will be 120hz or 144hz.if there's 60hz,congrats!!just use it.
If there's no 60hz,do what Arg0n said in that thread to add 60hz option to your computer via Custom Resolution Utility.and i did it with a slightly difference with Agr0n.i ran restart.exe rather than restart64.exe after adding all resolutions in cru.exe.then restart your computer,you should see 60hz appears after 144hz.
And you need to change ScreenModeResolution Low option to your desired resolution in the graphic rules.srg as other tutorial told you,too.mine is 1920x1080.

Remember to restore your computer before doing that if you can,things might go wrong.your screen might flickering after running restart.exe,it's nromal i think.your computer will be the same after that(at least in my case).so do it at your own risk,i hope it works for you,too.Wink

And remember to change your refresh rate back when you open other newer games or softwares.they need higher settings.:)well,the smooth option still grey,and i haven't add any mods or open bodyshop yet.there's still a loooooong way to go.....

Agr0n.if you can see this thread,i will give you a big hug.THANK U!!!!!!!!!!HeartHeart

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option