Sims 2 & Windows 10 : Stuck at 320x200
#1 08-04-2021 
  • Registered
  • 2
  • 4
Hello guys,

I wish I didn't have to disturb you for my Sims 2 problems, but after days of struggle here I am...
I'm stuck at 320x200 no matter what I do, I can only run in windowed mode using "-w" in the sims 2 executable's shortcut.
Moreover, the shadows are greyed out, as well as refreshment.

I tried to modify GraphicRules and VideoCards according to your very kind helpful advice on this forum (thanks a lot for that !) and some more tips from other simmers on MTS. I hope I didn't end up messing up the file...Confused
My video card is now being recognized thanks to your tutorials, but the resolution struggle is real...

If you ever have some time to help a Sims 2 fan with this...

Thanks a lot and have a good day Heart
PS : I'm French so the Sims 2 UI is translated but it looks the same as in English...

Attached File(s) Thumbnail(s)
   

.txt  config-log.txt (Size: 10.24 KB / Downloads: 45)

0
#2 08-04-2021 
HI @Alessyo,

Do not apologise or be sorry for asking for help. You're not alone, as many people have graphics probems, especially when trying to run TS2 on a Win10 computer.
This forum is especially there to help anyone who has such issues. We're glad to help if we can.

Could you please run DXDiag, have it save all data, and attach the resulting dxdiag.txt file to your next post?
I would like to see what it says about your system memory and the memory on your video card, because according to your config-log, it looks like you have only 2048 MB of memoy (2 GB).
Also, your videocard is supposed to have 6 GB of GDDR memory onboard, but the system allows only 2000 MB (less than 2 GB) of that as texture memory.

I'm beginning to think that it might be a good idea to delete your Graphic Rules.sgr files and let the game generate new ones, but do NOT do that yet until we know more.

~ BO

1
#3 08-04-2021 
  • Registered
  • 2
  • 4
Here is the DxDiag file !
Clearly I don't understand why there's a problem with memory, my laptop is brand new and especially made for gaming...old games issues as always

Attached File(s)
.txt  DxDiag.txt (Size: 125.77 KB / Downloads: 48)

0
#4 08-04-2021 
Do not delete the graphics rules!

It does not regenerate as it's part of the games install.

Have you tried using the updated graphics rule maker? Try reading this tutorial on setting up TS2 with newer pc's. If you are on discord you can join Pleasant Sims and ask for help in the help channel.

The config log reads only 2048 because that is all sims 2 can read by default as it's a 32 bit program. You need to apply the 4gb patch to the game's exe.

https://docs.google.com/document/d/1UT0H...Fsx5U/edit

2
#5 09-04-2021 
  • Registered
  • 2
  • 4
Wow that's impressive, the game was able to go full screen after that ! Thanks a lot !!
However I still get no other option than 320x200 when in game, shadows and edge smoothing are greyed out...so it looks a bit pixelated still but this is so much of an improvement
Any clues about the way the UI gets greyed out like that ?

1
#6 10-04-2021 
Hi @Alessyo,

Let' s both thank @HugeLunatic for correcting me on the idea of deleting the .sgr file. I was not sure about it to begin with, so that's why I said to wait, in case someone else knew better.
And yes, the 4GB fix is exactly what you needed. That's why I requested to see the dxdiag. I cannot smell at a distance what kind of computer you're using, and how much memory there is. And indeed, as Lunie said, the game registers only 2GB due to its age. If dxdiag said that you had more than 2GB, then the 4GB fix was required. But otherwise, you would've needed to buy more memory.

And now for your question: as said before, without the 4GB fix the game registers only 2GB of memory. The game can run in that much, but only just. So, in order to prevent you from selecting options that it cannot handle in 2GB, it greys out those options. As soon as it saw that you have 4GB, it enabled those options again.
Also, I would like to know if your Texture memory setting has changed since you followed Lunie's suggestion. If all is well, it should really read something like 6144 MB instead of 2000 MB.

I'm glad you got your game to behave normal now. Congratulations, and happy simming.

~ BO

1
#7 10-04-2021 
  • Registered
  • 2
  • 4
I don't think deleting the .sgr would have been an issue, from what I know the "Repair" option on Origin tends to regenerate lost files quite well.

Thanks to Sims2RPC, the game got patched and the memory part in config file said 4096mb. But I saw it used my Intel card instead of the Nvidia one (much better for gaming). I used Graphic Rules Maker to tweak this, and increase memory size up to 6144 mb and now it works like a charm ! The game is crisp-looking, fullscreen and pretty fast compared to the old Sims 2 days.

I got a little lag here and there when moving around the neighbourhood (random tiny screen freeze) but it's not a big matter. I think there's a thread about this on MTS so I'll just read and see what I can do but this ain't much of a bother to me.

Thanks a lot again, to both of you, for your kindness and helplfulness ! Happy Simming !

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option