Sims 2 Flickering in game
#1 18-04-2021 
  • Registered
  • 1
  • 4
Hi there

i've never done this, so please forgive me if I don't provide needed information immediately!

I've just installed The Sims 2 Ultimate Collection on my PC (Windows 10) and have followed various tips I found online so my game would run smoothley. Tha last issue I am facing is a graphic one. My game was flickering so I downloaded Video Card and Graphic Rules files from this website. But it only helped partially. I set "Smooth Edges" to max and the Neighborhood-overview is now flicker-free, but whenever I move into a houshold the flickering is back. But since I've already maxed out on "smooth edges" I don't really know what to do. I even tried making my own Video Card file, but that didn't help. I am working with Graphic Rules Maker and have tried all kind of settings and combinations but nothing worked.

My operating system is 64-bit. I've added pictures too.

I hope someone can help me!

Attached File(s) Thumbnail(s)
       

.txt  DESKTOP-A26JMUO-config-log.txt (Size: 10.52 KB / Downloads: 16)

0
#2 18-04-2021 
That looks like your graphics card is having problems.
Do you really have the GeForce 7800 GTX - or is does your log say you have that one because you used that dvkx-whatever it is?
IF you did the dvkx-thing, undo it. And make sure your game is using the correct GPU.

That's where I'd start... but, I'm no expert Wink

Oh! And, welcome to the pond! :waves:

0
#3 18-04-2021 
  • Registered
  • 1
  • 4
Hi,

first of all thanks so much for helping!! Smile
You're right! I checked and I actually have the Radeon RX 570! I don't understand why it is showing the wrong info in the log? I now deleted the dxvk.conf file, but the flickering is still there.
And how do i use the correct GPU? (Sorry, I know absolutely nothing about this stuff Big Grin )

Thanks for the welcome Big Grin

0
#4 18-04-2021 
Use the GraphicsRulesMaker to add your card to the database.
You may also have to go in from the Graphics card end of things... I don't use a Radeon card - but you'll need to go into the card's control panel and set your TS2 game to the correct graphics card.

In the picture below - I have an NVIDIA card, and it is set up like this:
[Image: attachment.php?aid=4299]

Your panel will be different, of course, but that's the idea you're looking for. Good luck! Smile
The Dx-thing is known for changing the GPU info - that is part of how it works, I think. I tried it once, but don't use it now - so I'm not really sure.

0
#5 19-04-2021 
  • Registered
  • 1
  • 4
Hey,

so I've decided to reinstall the game completely, bc I think I just downloaded and applied a whole bunch of things that just screwed up the game even more Big Grin

So here is a list of things I've applied/changed to my game before launching it for the first time:

- added d3d9.dll file, bc otherwise my game wouldn't launch but would keep crashing
- changed resolution to 1920x1080

I then saw that the flickering was still there and since "smoothing edges" was greyed out i followed the guideline from the simscomminity.com by changing enumerateMultisampleLevels from false to true in my graphics card file. it worked, but when maxing out on smoothing the edges, it again only worked for the neighborhood overview, when playing a houshold its still there.

Regarding the my log.file: it still shows the GeForce 7800 GTX as my graphic device even though its the Radeon RX 570 -.- So I went into the AMD control panel and added the game. I also went into the graphics settings from windows and made sure it was using my Readeon GPU. (see pics) Still flickering occurs and still wrong info in my log file.

I also have GraphicRulesMaker installed, and under "devices" it has the Radeon RX 570 listed. It's also added to the Database.

What do I do?

Attached File(s) Thumbnail(s)
               

.txt  DESKTOP-A26JMUO-config-log.txt (Size: 10.52 KB / Downloads: 12)
(This post was last modified: 19-04-2021 02:51 PM by adiamrim.)

0
#6 19-04-2021 
I don't know... hopefully someone with more knowledge than I will happen along Smile

I DO know that the reason your log still says the GeForce 7800 GTX is because you're using the d3d9.dll file. ...which I wouldn't recommend because it messed up my game; but, I know others use it and everything is fine for them. So good luck with it!

Are you using a noCD.exe to launch your game? (So it doesn't "phone home" to Origin?) And have you done the 4Gb fix?
The NoCD that we recommend is "George" - and it is already 4Gb'ed, if you get the bottom one.
Hint: Once you have George in place, do NOT click "Run as Admin" - that will undo the 4Gb'edness Wink

0
#7 19-04-2021 
The d3d9.dll is a last resort file. You should be using graphics rule maker and the 4gb patch, adjusting texture, before you just chuck the dvxk thing in.

1
#8 20-04-2021 
  • Registered
  • 1
  • 4
Oh my god, it's working!!! I deleted the d3d9.dll file and applied the 4gb patch and the game is running flawlessly! Thank you SOOOO much for taking the time to answer and helping me out!!! You guys are the best!! Smile

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option