The sims 2 UC freezes after a couple of in game days
#1 22-06-2021 
  • Registered
  • 2
  • 3
Hello everyone, this is my first post here so I'm sorry if I make some mistakes. I have Windows 10. I don't really know what happened, but suddenly my Sims 2, usually after a couple of in game days, just starts lagging for a few seconds then completely freezes and I can't do anything but shutting down my computer, because it neither crashes nor restarts, so I can't really do anything. I only have installed a few mods and default replacement CC. I have followed many guides and download the Cards from this site, everything (from my ignorant eyes' point of view) seems alright in the config log, but of course I am no expert. Can you please help me? I don't know what to do, I've tried everything![/php]

Attached File(s)
.txt  LAPTOP-M20426PI-config-log.txt (Size: 10.38 KB / Downloads: 47)

0
#2 22-06-2021 
Hi @Feltonistas,

Would you be a dear and attach your DxDiag as well? Because, to me, your config looks fine as well, except for only one point: your texture memory. I would like to see if we can set that properly. But for that, I need more information than the config provides.
Besides that, I have a question: do you save your current lot regularly? Usually, it helps to save and exit the lot and then reload it, at least once every sim day. I've made it a habit to do this at 6 AM.
Anyway, Windows is notorious for poor memory management, and TS2 is not the most sanitary in this respect, either. So after a few sim days of gameplay, RAM memory gets very fragmented, if not completely clogged with old data. If your machine has limited RAM -- like 8GB or less -- then it may just be that THIS is exactly why the freezing occurs. Many players will exit the game and restart it after a couple of sim days, just because of these facts. Even restarting the entire computer can be helpful. And thirdly, not having too many programs running in the background -- system tray -- is helpful and beneficial to TS2 game speed and preventing freezes.

Good luck and happy simming,
~ BO

2
#3 23-06-2021 
  • Registered
  • 2
  • 3
Hi @BoilingOil,
thank you for your helpful answer! Here's my DxDiag, hope I did it correctly.
I save my lot often, because I don't want to lose progress since it freezes out of nowhere, but I haven't tried to exit and reload the lot every day, so I'll try it, thanks for your advice! My computer has 16 GB of RAM, not sure if RAM is the problem!

Attached File(s)
.txt  DxDiag.txt (Size: 141.39 KB / Downloads: 52)

1
#4 23-06-2021 
Hi @Feltonistas,

I'm happy to help, if I can. Don't worry about it. And yes, you did fine. You even ran DxDiag fresh and attached the latest version of your system's configuration. That is perfect!
And no, indeed, with 16 GB, RAM isn't the issue. But that was one of the reasons I wanted to see your DxDiag, because you didn't mention that detail in your initial post.
Now I see that there are two video cards in your system, too. Sometimes, that confuses systems a little, but your game is correctly configured to use the nVIDIA card.
However, the card could use more texture memory. It is also possible, that the video performance, due to lack of texture memory is causing the lag/freezing. The game tries to give you the best it can, and then the video memory seems insufficient, so it needs to move graphics around a lot.

There are several ways to improve the situation. If you have Graphics Rules Maker installed, there should be a way in that program to alter your card's texture memory; I want you to try setting that to 6144 MB. I don't know how to do this, because I do not have GRM. If I have to change my config, I do so manually, in a text editor.
If you do NOT have GRM, then it's a bit more involved, and it depends on what version of The Sims 2 you have. If you have the old version on discs, you should find the TSData/Res/Config/Graphics Rules.sgr file in the installation folder for Mansion & Garden Stuff (EP9), but if you have the UC, you should look for the same file in the Fun with Pets/SP9 folder.

When you find the required file (Graphics Rules.sgr), open it with Notepad and find the first line that says: seti textureMemory 1744
On that line, change the number to 6144, and then save the file.

Whichever method you use, this should be sufficient to improve video performance. And there is now a good chance that this will also decrease the chance of freezing. But with a dayly save/exit/reload, freezing should already occur less frequently.

Once again, good luck,
Hasppy Simming,
~ BO

1
#5 23-06-2021 
  • Registered
  • 2
  • 3
Thanks @BoilingOil,
I’ll try to do that. I’ll do it manually, since I don’t have GRM and I’ll let you know! By the way, I played a bit and relodead the lot every day and it seems that the freezing has stopped! Thank you so much again!

1
#6 23-06-2021 
I'm glad that it works out so well for you. You're welcome!

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option