Sims 2 UC has started randomly crashing
#1 15-07-2021 
  • Registered
  • 0
  • 5
Hi everyone,

I’m hoping someone can help me (please) - posting this really is my last resort.

I have a Predator desktop which I only purchased in January and managed to sort everything out to get The Sims 2 Ultimate Collection to work (4GB patch, Graphic Rules Maker, Memory Allocation Fix) but all of a sudden whenever I load a lot I get the usual “the application has crashed and will now terminate” message. Sometimes I also get the dreaded flashing pink on my sims and certain objects.

I’m really really hoping someone can help me.
I’ve been through all of my custom content using the 50/50 method and there doesn’t appear to be any corruption from anything.

Please let me know if you need my system specs or any logs and I will provide them ASAP. I’m just desperate to try and get this sorted as it seems to have come out of now where and nothing I’ve Googled or seen on YouTube seems to have helped so far.

Thanks so much in advance!
Natalie

0
#2 16-07-2021 
Hi,

I've moved this topic from the "Sims Discussion" board (where it didn't belong) to this one, the "Sims2 Graphics Cards" board.
Here you find a lot of information, including the instructions at the bottom, which explain what information we need, if there is ever to be a chance that we can help you.
So please attach your latest ****-config-log.txt and DxDiag.txt, so we can see what is going on in your system.

0
#3 16-07-2021 
  • Registered
  • 0
  • 5
@BoilingOil Apologies, I've never posted in the forum before - thank you for moving it for me.

Please now find attached both my config log and dxdiag text files.

Thanks again in advance for the help Smile
Natalie

Attached File(s)
.txt  DESKTOP-OPO3IOV-config-log.txt (Size: 10.69 KB / Downloads: 11)
.txt  DxDiag.txt (Size: 89.49 KB / Downloads: 13)

0
#4 17-07-2021 
No problem, you're welcome, @Natalieee93.

I think I've also already identified the issue... It's nice that DxDiag tells you you have 16.157MB of texture memory available. But that does NOT mean that you definitely MUST use it all.
And with an active window size of 1920x1080, there is most certainly NO NEED for that much, either. In fact, I think that that is what your system trips up over!
Try a number like 6144MB (or 8192MB, if you really must); I think that this will be quite sufficient, and I guess that it might just cause the crashes to stop!

Good luck and happy simming,
~ BO

0
#5 17-07-2021 
It looks like you may also by trying to use DXVK as the video card listed in the config log is different than that listed in the dxdiag. Try running the game without that, it doesn't always work and certain versions will crash the game.

0
#6 17-07-2021 
  • Registered
  • 0
  • 5
@BoilingOil Thanks for the suggestion, I amended my texture memory to 6144MB as suggested but I'm still experiencing the 'pink' and the crashing (I've attached a screenshot as well as my updated config log FYI). Do you think it might be worth amending my default resolution to 1024 x 768 or would that not make any difference?

@HugeLunatic Thank you for trying to help, this might be a stupid question but how do I run the game without DXVK?

Thanks again both,
Natalie

Attached File(s) Thumbnail(s)
   

.txt  DESKTOP-OPO3IOV-config-log.txt (Size: 10.69 KB / Downloads: 10)

0
#7 17-07-2021 
Using without the DXVK would be uninstalling in the opposite direction you installed? I've not used it, so sadly I cannot be more specific. I noticed you enabled Intel High Quality when using GRM, but you shouldn't have to. I am not sure if that would actually make a difference if you unchecked that when running GRM.

Too much high poly and large texture sizesin cc will cause the pink flashing. Too many creators are converting cc from other games that use textures over 1024x1024, which is unnecessary for TS2 and will contribute to the pink flashing. You may need to whittle your cc down or go through and reducing texture sizes.

0
#8 17-07-2021 
  • Registered
  • 0
  • 5
@HugeLunatic I didn’t even realise I had DXVK installed haha! Anyway, I think I’ve uninstalled it now (and unchecked the Intel High Quality in GRM) however when I ran the game it became extremely laggy and then crashed Sad
(This post was last modified: 18-07-2021 08:24 PM by Natalieee93.)

0
#9 18-07-2021 
  • Registered
  • 0
  • 5
I've attached my latest config file where the video card that shows now matches that of the DxDiag file (presumably from uninstalling DXVK)

Attached File(s)
.txt  DESKTOP-OPO3IOV-config-log.txt (Size: 10.7 KB / Downloads: 10)

0
#10 18-07-2021 
The config sure LOOKS a lot better. But that doesn't help you much if the game refuses to run properly without crashing. I'm not smart enough to help you, Natalie. Sorry.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option