CAS and textures not loading (Win 10)
#1 02-08-2021 
  • Registered
  • 4
  • 6
So I apologize if this has been solved countless times before, I have skimmed through the threads to try and fix it myself, but no such luck. Basically, certain textures aren't loading, only white chunks with the texture name on it. When I go to CAS, the termination message pops up. Same thing applies for going into any household. Build mode works though. Side note, I do run the disc version through an external disc player as my pc didn't come with one. I am running dual core but when I did the shortcut fix by adding -w -CPUCount:2, nothing changed game-wise, in fact the window just got really small and I couldn't make it fullscreen. I have tried countless graphics rules files from the threads and have tried making my own with the graphics rules maker. Nothing seems to work. I am hoping one of you could at least point me in the right direction.

config log:

.txt  DESKTOP-HLG2IRA-config-log.txt (Size: 10.5 KB / Downloads: 47)

graphics rules (as a txt file since the site won't let me upload the sgr)

.txt  Graphics Rules txt.txt (Size: 34.47 KB / Downloads: 51)

0
#2 02-08-2021 
Hi, could you attach the DxDiag.txt for us, please?

0
#3 02-08-2021 
Does this also happen in a fresh/CC-Free game?

1
#4 03-08-2021 
  • Registered
  • 4
  • 6
(02-08-2021 09:26 PM)BoilingOil Wrote:  Hi, could you attach the DxDiag.txt for us, please?

(02-08-2021 09:32 PM)CatherineTCJD Wrote:  Does this also happen in a fresh/CC-Free game?
On this pc I don't have any CC yet, was waiting to make sure the game ran vanilla first.

Attached File(s)
.txt  DxDiag.txt (Size: 96.58 KB / Downloads: 42)
(This post was last modified: 03-08-2021 07:17 AM by maxtornetta.)

1
#5 03-08-2021 
Your config-log says that the game sees only 2GB of RAM, but DxDiag reports 16GB. Clearly, you're not (properly) using a 4GB patch. This is limiting the amount of memory the game has to work in, which is a partial explanation for your problem. You obviously need George.

Also, you seem to have TWO graphics cards, and the one that you're using, has 4GB of dedicated texture memory, but is configured to also use 8GB of your system RAM. The latter is totally unnecessary. 4GB should be quite enough! However, your game is configured to use only 2GB. Maybe you should run the GRM once more, and make only ONE change: set the texture memory to 4096 MB.

When these things have been taken care of, everything should go a lot smoother, unless someone else uncovers a problem that I've missed.

1
#6 03-08-2021 
  • Registered
  • 4
  • 6
The 4gb patch was extracted into the Tsbin folder but when I try to run it an error message pops up saying it's missing needed files.

0
#7 03-08-2021 
Dang, apparently, there is some idjit here on this board, who didn't pay attention, and that kicks the legs out from under my assumptions about the 4GB patch.
Because this specific patch that I linked you to, REQUIRES M&G files being present, and it seems that you're not playing M&G, but something older...

So you need a 4GB patch for a different version of the game.

Oh, and please, don't be offended... because the idjit that I was talking about, is yours truly... I did not pay attention and made a rectum of myself!

1
#8 03-08-2021 
  • Registered
  • 4
  • 6
That's fine, no worries! I don't have my head wrapped around the UC and the patch itself but it seemed off that its labeled as EP 9 since unless the UC isn't 9 then there isn't a 9th right? Anyways the latest pack I'm running is Free Time.

1
#9 04-08-2021 
Thank you for understanding. Anyway, this means that you need a patch for FreeTime, which I hope someone here can point you to.

Btw. I don't have the UC, either. I'm old-fashioned and am running the game from the original CDs and DVDs. ALL OF THEM!
Sims2EP9.exe is officially the executable for Mansion & Gardens Stuff. The UC simply uses the same one, because M&G was the last official Maxis/EA/Origin pack ever to be released. Big Grin

0
#10 04-08-2021 
Sounds like ya'll are getting things sorted...

But I must say, since you are just now getting into the game - and don't have it set up yet - why not just get the UC (it is the complete set) and use 'George'.
It is free to download; many people consider it abandonware - and, especially if you have the physical disks, and since the UC was offered free from EA to those who owned the discs... etc... go for it!

I have all the Disks, and I downloaded, but didn't use the UC from EA when it was offered all those years ago. When I got my latest computer I finally installed from Origin/UC; I wouldn't go back to the disks for anything now.

HL posted the link to download the UC on here pretty recently too... (I think it was on here - it may have been on the MTS Discord?) Anyway, if you need a link - I can find it for you tomorrow. Now it's late, and I'm off to bed. Good night! And, good luck!

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option