Unable to apply 4gb patch, memory stuck at 1024
#1 17-08-2021 
  • Registered
  • 0
  • 4
Hi,

For whatever reason, my game, which I successfully applied the 4gb patch to previously, is telling me I only have 1024meg My laptop has 8GB ram. However, in the log it says I am only using 1024MB memor. I tried reinstalling the patch, but have been unsucccessful. I tried copying the exe to the CS. I tried moving the game .exe to the CS bin and applying the patch there, then moving it back to TSBin.i've also tried copying the exe to my desktop, applying the patch, andd copying it back, but this didn't work either. Additionally, I'm using Lazy Duchess's launcher, which is supposed to automatically apply the patch. Everytime I apply the patch, it tells me it was successfully applied, but it is still saying 1024mb in the config log. I haven't changed anything since my initial use of GRM, and the graphicsrule/video sgrs that had worked properly up until now.I am running the original Sims 2 on Windows 10.

Attached File(s)
.txt  DxDiag.txt (Size: 93.07 KB / Downloads: 22)
.txt  DEATHSTAR-3-config-log.txt (Size: 10.63 KB / Downloads: 24)
.txt  Graphics Rules.txt (Size: 34.4 KB / Downloads: 19)
.txt  Video Cards.txt (Size: 25.91 KB / Downloads: 20)

0
#2 17-08-2021 
I think I see the issue here. Here's a little quote from your config-log:

Code:
=== Machine info ===
OS version:      Windows NT 6.2
CPU:             3796.800048Mhz, Name:GenuineIntel, FPU:1, MMX:1
Memory:          1024MB
Free memory:     1024MB
User:            elvis
Computer:        DEATHSTAR-3
=== Sound device info ===
Name:            Unknown
Driver:          Unknown
=== Graphics Rules Maker Configuration ===
Force texture memory: 6060 Mb

Look at that last line: FORCE texture memory: 6060 MB !!! That means that of your 8192 MB TOTAL RAM, only 2132 remains for windows and the game... How must the 4GB patch reserve 4 GB from a total of only 2 GB?? That is impossible!

And THIS is from your DxDiag:

Code:
Driver Problem Code: Unknown
      Display Memory: 4178 MB
    Dedicated Memory: 128 MB
       Shared Memory: 4050 MB

The built-in graphics card has only 128 MB of on-board memory, and can use AT BEST 4178MB. And 4050MB of that must be drawn from your 8GB system RAM, which is thereby already halved to the point where there is JUST not enough left to apply the 4GB patch to, after Windows has taken its share of memory to run in.
Also, as said, your Graphics Rules FORCE the game to use 6060MB as Texture memory, which the video card is not designed to do, because 4178MB is the max it can work with. And even if it was, it means that less than 2GB of system memory remains... The 4GB patch needs more than 4GB of physical memory available, if it is to reserve 4GB of it for the game!

Also remember that Windows itself uses quite a chunk of your physical RAM for itself. So I think you would do best to reduce the texture memory to something more reasonable, in this case 2048MB, in your graphics rules, and disable the FORCE texture memory thing!

2
#3 18-08-2021 
  • Registered
  • 0
  • 4
Those are the settings that GRM determined when I first installed it, and selected auto-detect. I'm not running the game on my Intel card, I used the Nvidia control panel to set that the game always runs on my Nvidia card. The Nvidia has more memory. I made the changes you suggested, and now the game crashes anytime I try to enter any of my lots. It loads to the neighborhood fine, but any house I try to enter crashes. I have been able to apply the $gb patch, after doing further reading, the problem was that I was playing in compatability mode. As soon as I took that off, I was able to apply the patch. The problem now is that after making those changes to my graphics rules, the game crashes anytime I trry entering a lot. I never get past the family loading screens.

Attached File(s) Thumbnail(s)
       

.txt  DxDiag.txt (Size: 93.07 KB / Downloads: 18)
.txt  Graphics Rules.txt (Size: 33.51 KB / Downloads: 15)
.txt  Video Cards.txt (Size: 21.75 KB / Downloads: 20)
.txt  DEATHSTAR-3-config-log.txt (Size: 10.29 KB / Downloads: 21)

0
#4 18-08-2021 
Oh, my apologies, but I missed that. The Nvidia card was reported so far down the DxDiag that I hadn't seen that. That teaches me to look farther than merely the length of my nose! Big Grin

The numbers that the NVidia card uses, though, are rather strange... 2010, 4050, 6060... I would not use such numbers, because the game often doesn't understand and makes a mess of them. Try changing your texture memory to 4096 or, if you really must, 5120. But really, for this game 4096 is usually quite enough!

I had not thought about the compatibility setting; I've never used, or even needed, it myself, so checking or asking for that usually escapes me. Again, my apologies.

Thank you for so faithfully uploading the Config-log and DxDiag files. It helps a lot if we do not have to ask for them. Especially in the first post we really need those.
But after that, you usually only need to re-upload them if someone asks because a fix didn't work. And there is usually no need at all anymore to upload the Video Cards and Graphics Rules files, unless someone asks for them. In olden days, we would ask, because we needed to manually edit them, but nowadays, the GRM does it well enough. So the Config-log and DxDiag are usually quite enough, thank you. Anyway, thank you for being so attentive. It is much appreciated.

1
#5 18-08-2021 
Try running GRM again, your card is not in the database.

1
#6 19-08-2021 
Odd thing is, though, that it was in the first copy of her config-log.

1
#7 21-08-2021 
  • Registered
  • 0
  • 4
STATE OF THE UNION: Ok, as per @BoilingOil, I've changed my texture memory to 4096, and as per @HugeLunatic I've run the GRM again, updated txt versions of my sgrs attached.

I created a test hood to see if I was still experiencing crashing while entering lots still, and I'm no longer having that issue. I played around briefly in live/build and buy mode, an so far everything looks good. I just copied my old hood into the Neighborhoods folder, and the game is booting up now. Fingers crossed!

I just include the all the files with each reply because i am accutely paranoid that I've done a glaringly obvious dumb thing that willl turn my laptop into a smoldering cinder.

Semi-related question - is there an arbitrary limit to the amount of cc that Windows 10 will process before it just says "nope!" and crashes? On my old Win 8.1 Samsung laptop, I had something like 20G/75,000 files of cc, and it would handle with no difficulty except occasional lagging. I copied all My Documents/EA Games/The Sims 2 folders over to my current Win10 Samsung laptop, and it is not having it. It will let me have about 10G/45000 files of cc before it crashes anytime I try adding more. I've 50/50 tested all myy cc, and everything checks out fine until I put it all back together in my downloads folder, then the crashing begins again. I've done pretty much every troubleshooting tutorial out there, esp the ones for pink flashing, and haven't been able to find a solution.

ETA: I've seen several references to DXVK in your conversations with other posters. Is this something I need to do?

Quote:Anyway, thank you for being so attentive. It is much appreciated.

Are you kidding? You are doing me a HUGE favor. It's the absolute least I can do!

Attached File(s)
.txt  DxDiag.txt (Size: 93.07 KB / Downloads: 14)
.txt  DEATHSTAR-3-config-log.txt (Size: 10.63 KB / Downloads: 20)
.txt  Graphics Rules.txt (Size: 34.33 KB / Downloads: 18)
.txt  Video Cards.txt (Size: 21.16 KB / Downloads: 16)

0
#8 21-08-2021 
(21-08-2021 06:40 AM)elvisgrace Wrote:  I just include the all the files with each reply because i am accutely paranoid that I've done a glaringly obvious dumb thing that willl turn my laptop into a smoldering cinder.

Truly, right now, you say your system is working, so we don't need any files. Please, stop attaching them with every new post?

With respect to the CC situation, every system is different. The version of Windows that your using, is a part of this. I don't know what the conditions are that affect the amount of CC that you can load. I've never seen a need for more than 2GB, and that is working well for me.

0
#9 21-08-2021 
YAY! I'm glad you got things working Wink

I would caution against that DVX thingy - I tried it, without success, and removing it from my game was not straight-forward easy Confused *sigh*

I have run into a CC-limit-kinda-problem since about Win8 - and it has persisted into W10.
In the very beginning (2004/5) on my old XP machine, I had around 25Gb of CC... it was still good when I went through the Vista and W7 phase.
My game ran into trouble with W8 - I never got the game to play right. But, I did cull through a lot of CC during that time - and I know it all works, just not together!
Then on W10 - after I had the game running smoothly with no CC (and with the minimal must have 2.78Gb) - I started to add back parts of my 25Gbs of stuff. Nope!
I can't go over about 3.4Gb now (which is better than the 2.78 I was stuck with for a long time, but no where near the 25Gb I'd like!)

If you find ever find a solution - please share! I'd love to know Big Grin

A guide you might find helpful is How to Install TS2 on W10

Good luck! Angel
(This post was last modified: 21-08-2021 03:22 PM by CatherineTCJD.)

1
#10 23-08-2021 
The dvxk thing is a last resort to cure texture issues. RAM plays a big part of how much cc you can have in game. Windows XP used little RAM, and every iteration of Windows since just used more. If you increase texture memory more than what your video card has available, then it too will start using RAM after it consumes all of it's dedicated memory.

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option