Sims 2 Graphics Glitch with new graphics card.
#1 25-12-2021 
  • Registered
  • 1
  • 5
Hello...I upgraded my graphics cards to a GTX 2070 and now im having pink flashing and graphic glitches. I have the 4 gb patch and everthing
(Windows ten, i5 operation. HP OMEN)    

Attached File(s)
.txt  DESKTOP-SHQ97P3-config-log.txt (Size: 10.54 KB / Downloads: 28)

0
#2 26-12-2021 
I see this bit in your config-log that I do not particularly like, because it forces your system to ignore its natural tendencies.

Code:
=== Graphics Rules Maker Configuration ===
Force texture memory: 4096 Mb
Disable Texture Memory Estimate Adjustment: No
Enable Driver Memory Manager: No

For example, the "Force Texture Memory" setting. If your Video Card has more than 4 GB VRAM, it is now forced to ignore that, and use ONLY 4GB. But if it has less than 4 GB, it is now forced to use system RAM in addition, taking memory from the game. IF I were you, I would turn this option OFF in GRM. Also, try switching "Enable Driver Memory Manager" to Yes.

And if all that doesn't help, then please, with your next post, attach your DxDiag.txt, so we can see some information about your system that the config-log does not show us.
Good luck, and happy holidays,
~BO

0
#3 28-12-2021 
  • Registered
  • 1
  • 5
Thank you, I fixed the issue but now my game is crashing loading a lot. I did the gb patch, and everything. My dxdiag is wrong, my display is something else.

Attached File(s)
.txt  DxDiag.txt (Size: 67.96 KB / Downloads: 15)

0
#4 28-12-2021 
Sorry, but that's an OLD DxDiag report (July 14, 2019), which doesn't help us at all. I'd rather you just run the DxDiag program and upload the new, updated report, please.

0
#5 28-12-2021 
  • Registered
  • 1
  • 5
here it is, sorry

Attached File(s)
.txt  DxDiag.txt (Size: 88.55 KB / Downloads: 17)

1
#6 28-12-2021 
Thanks, that's a lot better. It even shows your new Graphics Card.

Now I think I would suggest that you try goint into GRM and setting the Texture Memory to be 8192 MB. But do NOT use "Force Texture Memory" for that, please. Even 4096 MB might be good, tbh.

And let's hope that someone else has more good ideas, now we have all the info we need Smile

0
#7 28-12-2021 
  • Registered
  • 1
  • 5
Ok, my 4 gb patch isnt working. Idk what is happening. I set the texture memory to 8192, but still crashes

0
#8 29-12-2021 
(28-12-2021 03:40 PM)Miik Wrote:  Ok, my 4 gb patch isnt working. Idk what is happening. I set the texture memory to 8192, but still crashes

Actually, according to your config-log in the first post, the 4GB patch is working just fine! When the 8192 MB setting didn't work, have you tried the 4096 MB setting? Don't give up too quickly, try everything. If right now the game isn't working, it can't get any worse anyway...

0
#9 29-12-2021 
(28-12-2021 07:02 AM)BoilingOil Wrote:  Now I think I would suggest that you try goint into GRM and setting the Texture Memory to be 8192 MB. But do NOT use "Force Texture Memory" for that, please. Even 4096 MB might be good, tbh.

@BoilingOil you misunderstand how the GRM works. Using Force Texture Memory is how you set the texture memory (you enter the number you want to set beside the option), and it's not any different than manually entering the value in the file.

0
#10 29-12-2021 
@TheDarkLady, I may not know how GRM works, but if I simply add the Texture memory number in the .sgr file myself, it does NOT apply the "Force Texture Memory", nor does that line show up in the config-log.txt.

Tip: if you quote a person, you do NOT need to also mention their name... because this causes them to receive TWO notifications Big Grin

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option