Smooth Edges greyed out
#1 08-02-2022 
  • Registered
  • 1
  • 3
Hi ^^

So, the Smooth Edges option is not available to me when I'm playing TS2. I've tried everything I could find on the internet: changing all "enumeratemultisamplelevels" to true and changing "seti textureMemory 32" to 1744. And nothing worked. I know my graphics card sucks but what I don't get about this issue it's that I used to play TS3 before and the smooth edges there worked properly (not at max, but I could still set it at a low or medium setting). And as far as I know, TS3 requires a lot more from a computer than TS2. So why can't I enable the Smooth Edges option on my TS2? Hope someone could help me with that. ^^ And sorry if anything goes wrong with my english, I'm not a native speaker. x-x

My operating system is Windows 7.

Thanks.

Attached File(s)
.txt  config-log.txt (Size: 10.37 KB / Downloads: 45)

0
#2 08-02-2022 
Hi @Yuxie,

The game tends to disable functions that it has not enough memory to support.
From your config-log, it seems like you have no more than 4 GB of system RAM in total, which is clearly not sufficient to run TS2 with high resolution and most of the advanced graphic options. Smooth Edges is one of the options that needs more than your system seems to support.
But to verify my suspicion, I think I need to see your DxDiag report, if that's possible.

And to be honest, setting the texture memory to 1744 is not the optimal solution for all computers, either. I believe that, whoever suggests that to TS2 players in general, has no idea what they are doing.

0
#3 08-02-2022 
  • Registered
  • 1
  • 3
Hi, thanks for answering. ^^

I didn't know that my RAM was not enough. ):
At least now I understand why it doesn't work.

I'm attaching my DxDiag report in case my game has any salvation. xD

Oh, the DxDiag report had not been attached in the previous post, sorry. x-x

Attached File(s)
.txt  DxDiag.txt (Size: 37.69 KB / Downloads: 42)
(This post was last modified: 08-02-2022 05:45 PM by Yuxie.)

0
#4 09-02-2022 
Hello again, @Yuxie.

I'm sorry to disappoint you again. I see more trouble, which will not make it better.
Your system cannot even give the game the 1744 MB of texture memory, because according to DxDiag, there is only 1695 MB available.
Code:
Display Memory: 1695 MB
   Dedicated Memory: 32 MB
      Shared Memory: 1663 MB

This shows that your (built-in) graphics card has no real texture memory of its own, so it needs to borrow from system RAM (the 'Shared Memory' part).
So, with your low total RAM, and your graphics card using a large portion of it, there is not enough room to even PLAY this game.

So, to summarize: I'm afraid you need a much better computer. One with AT LEAST 8 GB RAM, and a graphics card with at least 1 or 2 GB of VRAM.

I'm so sorry. ;-(

0
#5 09-02-2022 
  • Registered
  • 1
  • 3
Oh it's okay, no need to apologize. ^^

I was already expecting something like this to be honest. Guess I'll have to start thinking about getting another computer if I want to continue being a Sims player. xD Oh, and thanks for the specs you recommended, btw.

Thank you for trying to help. (:

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option