TS2 won't open getting "Failed to find any directx 9.0c"
#1 06-03-2023 
  • Registered
  • 1
  • 4
Hi, I'm trying to play TS2 Ultimate Collection on my laptop. I know I've played TS2 on this laptop before but it was outside of Origin. I want to say the option to register your game popped up and I entered all my TS2 codes, but I ended up uninstalling it since getting the TS2 UC from EA.

I've tried all sorts of steps to get the game open; using GRM, using Windowed Mode, using the 4gb Patch, adjusting the Graphics settings, uninstalling/reinstalling TS2 several times, and I've tried using Safe Mode but the EA app won't open. Here are some screenshots of my laptop. Please let me know if you need more info. Your help will be greatly appreciated.

Attached File(s) Thumbnail(s)
       

.txt  ASUSROG-config-log.txt (Size: 9.84 KB / Downloads: 103)

0
#2 06-03-2023 
In the GRM drop-dwon menu - you should be able to select your NVIDIA card. It will need to add it too the database.
Make sure you are using the GRM with Admin privileges. Wink
The GRM undoes the 4gb patch - so you will have to run that again after...
Also - make sure the games cache files are empty (just delete them.)

Although... your log says that both the 4Gb and correct graphics card are being used. So, maybe, just clearing the caches will work? *fingers crossed!*

0
#3 06-03-2023 
  • Registered
  • 1
  • 4
Hii! Thank you for responding to me. Yes, did the run as Admin thing. Smile I've tried the steps but I don't have the caches file, but I sent the screenshots of what I see, just in case I'm overlooking. Plus I'm sending the Config-log file again just in case it changed. The error message came back again.

Attached File(s) Thumbnail(s)
   

.txt  ASUSROG-config-log.txt (Size: 9.84 KB / Downloads: 116)

0
#4 06-03-2023 
These are the caches I mean...    

If you can run the game, and it creates the log file... then it will create the caches.

0
#5 06-03-2023 
  • Registered
  • 1
  • 4
Ahh gotcha, that's right it will show all those other folders & files when the game can run. Since that didn't work, I end up uninstalled/reinstalled TS2 again. But now the Config-log doesn't show NVIDIA graphics card, and I did the GRM + 4gb patch again. I added it to this post just in case it shows something that causing the game not to run. But if the NVIDIA graphics suppose to run the game, I can re-do it over in the NVIDIA Control Panel so the Config-log can show NVIDIA graphics card. I really appreciate your help!

0
#6 07-03-2023 
  • Registered
  • 1
  • 4
I got it working! I had to add 60Hz in the Advanced display settings. Big GrinHeart

Attached File(s) Thumbnail(s)
   

1
#7 07-03-2023 
YAY!!! I'm glad you figured it out Big Grin

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option