Sims 2 and Graphics Cards - the fixes.

GRAPHICS RULES MAKER
A new program is out to help you with graphics rules
Click here to download

#21 27-03-2014 
I just joined this site to say thank you. I just got a new laptop last week, and for the first time ever I'm seeing water instead of blue blocks (I was running Sims 2 on a 7-year-old laptop running Vista before this one).

However, I've had this other grating issue which I'm not sure is related, but I want to point it out.

I run Windows 8, and some parts of the screen flickers. Changing everything to low didn't help, but like...in build mode, it would go all wonky and then in a few seconds just go back to normal. This NEVER happened on my old laptop. I'm gonna post my log here in case there is something here that can be pointed out. Compatibility mode actually made it worse (go into a neighborhood and the screen is completely black), and since the game works fine for me in Windows 8 mode, I think it's not needed.

Attached File(s)
.txt  NAMA-config-log.txt (Size: 10.34 KB / Downloads: 735)
namakyori, proud to be a member of LeeFish since Mar 2014.

Stay classy.

1
#22 27-03-2014 
When you ran in compatibility mode did you run the program as admin?

0
#23 27-03-2014 
I did not. Would that have made a difference?

0
#24 27-03-2014 
@namakyori

Yes, when you use the Win8 fix and run in compatibility mode ALWAYS run as admin.

2
#25 27-03-2014 
Okay, I'll try it out and report the news.

0
#26 27-03-2014 
What Leefish says is correct. Running as Admin is the way to go.

0
#27 27-03-2014 
So I set the compatibility to Win XP SP 3, and ran as administrator. Got the black screen issue mentioned above. Pressing alt+tab allows me to see the screen for a split second.

Running as admin under windows 8 works, but the random flickering still persists. It's not game breaking by any means, just REALLY annoying, especially since I'm in the process of remaking a home.

0
#28 27-03-2014 
ok, I think you need to let kiri have a look at the logs.

0
#29 27-03-2014 
For reference, I used this graphics rules (the same one posted on the original post for intel cards).

Once again, I can see water as water and not blue blocks, just that there's that annoying flicker that gets worse during build/buy mode.

Oh and I should also say that I noticed video card.sgr, and my card (Intel HD Graphics) isn't on there when I opened it.

This is what it looks like for me. It's not my video, but it's akin to what's happening.

https://www.youtube.com/watch?v=LWJg4jV9XyM

And dxdiag stuffs:

Another edit: thank you to leefish for pointing this out, it seemed like someone else had the same issue I did on the board and they managed to have fixed it. I'm not very saavy in stuff like that (irony since I am a small-time web designer, so code shouldn't be intimidating), but this is that post:

http://www.leefish.nl/mybb/showthread.ph...3#pid23553

Solution that worked for them: http://www.leefish.nl/mybb/showthread.ph...5#pid23565

Attached File(s)
.txt  Graphics Rules.txt (Size: 34.12 KB / Downloads: 1040)
namakyori, proud to be a member of LeeFish since Mar 2014.

Stay classy.
(This post was last modified: 28-03-2014 12:24 AM by namakyori.)

0
#30 28-03-2014 
I'll have a look and fix it up for you.

No worries. Be back to you later

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option