Creating a CEP-Extra
#1 21-10-2015 
I want to create a CEP-Extra file for the MALM endtable with two drawers, where the drawer fronts are a seperate, recolorable subset. I'm using this tutorial as a starting point, but I've done a few steps differently to make an actual override.

What I've done:
1. Clone the MALM object with all the options unticked, except for 'pull default color'.
2. Added the subset in the GMDC as per IB's instructions.
3. Cloned the TXMT in the file and renamed it with the new subset name. Then I clicked fix TGI as per these instructions. I also changed the cMaterialDefinition to match the new TXMT-name.
4. Edited the shape. I didn't fix the integrity.
5. Edited the GMND.
6. Cloned the MMAT in the file and renamed it. Changed the instance and the family. Edited the subsetname to match the new subset and the name to match the new TXMT.
7. Extracted these five resources, made one package with GMDC, TXMT, GMND and Shape (to go in the Documents folder), and one package with the MMAT (in the Program Files folder).

The drawerfronts are flashing blue in game. When I clone the MALM endtable in SimPE with my CEP-files installed, all the new and edited resources are pulled with it, except for the TXMT. Can anybody help me find out what I'm doing wrong or what steps I'm missing?
Klaartje, proud to be a member of LeeFish since Sep 2013.
(This post was last modified: 22-10-2015 07:20 AM by Klaartje.)

#2 22-10-2015 
Klaartje, I haven't been able to add new subsets but do you think it's one of the instances where you need 2 zCEP-extra files, one for Documents and one for Program Files? HugeLunatic and Hafiseazale know MUCH more about that obviously, maybe Lunie will see you question Smile

#3 22-10-2015 
Chances of that will be bigger if we *mention* @HugeLunatic. As done now Smile

#4 22-10-2015 
Thanks Shasta Smile I should have clarified, I put the MMAT-package in Program Files and the other in Documents. I tried this same method with another object and that worked fine. Maybe it's related to the type of object? I think Hafiseazale had a lot of issues with the barstool, maybe I should study that one more closely...

#5 24-10-2015 
In the GMND it has a tsDesignModeSlaveSubsets. Try removing that line, that thing messes with stuff.

#6 25-10-2015 
Yay, that fixed the issue Big Grin Thank you HL!

#7 25-10-2015 
* leefish looks round for the link to this thing?

#8 25-10-2015 
* Klaartje throws a tantrum about stupid EA mapping


Sorry, that is a members only option