Sims 2 - UC Access_Violation Error after Windows 10 updated
#1 02-01-2016 
  • Registered
  • 6
  • 8
I think this is the right place to post this? Cottonary on tumblr was so nice and tried to help me figure out what's causing my error, but as it turns out it is not a NVIDIA problem as it crashes with the same error even if I run it on the Intel card. They suggested I ask over here, so here I am!

The problem didn't start when I upgraded to Windows 10 this past summer; it started when Windows 10 pushed the November update. Before that update the game was running fine with Windows 10. I have uninstalled and reinstalled all graphics drivers, and fully uninstalled and reinstalled Sims 2 UC from Origin. My laptop is 8 months old and has never had a problem with the game before now.

Here is my Direct X Diagnostic report and here is my Sims 2 error log.

I would very much appreciate any advice you can give me! I really miss my game.

#2 03-01-2016 
@chiaroscuro - yeah, I was watching on tumblr and hoping that would work. Can you upload the config-log.txt as well.

This is a really tricky problem and it's not one I've come across before. I'm hoping that there is something that will stand out in the config-log.txt.
In the meantime I will study your exception log and diagnostic report.

I'm sorry I'm not able to give you an immediate fix. But I'll do my best.

ETA: I've have a couple of ideas, from looking at the logs, once you've got the config-log.txt uploaded I might have something for you.

The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\

Click "full editor" below to attach a text file.

#3 03-01-2016 
  • Registered
  • 6
  • 8
Here it is currently. I ran the graphics rules maker earlier to test a theory but I can restore it to the original settings if I need to. I really appreciate you looking into this!

Attached File(s)
.txt  DRUSILLA-config-log.txt (Size: 10.21 KB / Downloads: 880)

#4 03-01-2016 
The graphics rule maker isn't correct 100% of the time unfortunately. But that's ok.

You're on the NVidia card - is that the one you want to stick to?

OK - What I'm giving you is a graphic rules.sgr and video cards.sgr You will need to put it in the following folders

\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\

Download GraphicsCard-NVidia-TextureFix
DownloadVideo Cards Nvidia

There needs to be no CC in the game whatsoever, when you're doing this test for me.

Step 1: unzip the Graphic Rules and Video Cards into the folders mentioned above.

Step 2: Make sure that your sims2SP9.exe is set up as admin, and compatibility to windows 8
[Image: attachment.php?aid=2064]

Step 3: Delete the caches, Run the game. Does it load ok? Come out of the game again.

Step 4: Post up your config-log.txt here and let me know how it went. What I will be looking for is trace that is in the graphic rules.


An Access Violation occurs when the game tries to write something where it shouldn't. Rather than overwriting a piece of code it gives the violation and stops.

You have a very high memory usage when this occurs - MemoryUsage: 321192K
On tumblr, you said that you didn't have any CC in the game - this game crash was occurring when you first went in, is that correct?

If you don't have any CC in the game - then that much memory usage when you go in, tells me that it has an infinite loop.
If you do have CC in the game - then we can guess that their is a CC conflict.

Now - although you had run the graphic rules maker, you had a few errors in your graphic rules card - the NVidia Texture set to 32Mb, The video card not set up in the database, and the rules set to low res even though you have a machine that obviously can cope with it.

The cards I've given to you will fix those problems. There's no guarantee that those were the problem though. We can cross fingers that the loop was because it couldn't work out where to set things.
The other thing I noticed that that you have an octo-core. That can cause problems because your CPU actually goes too fast for the game to keep up. That *may* also cause problems for you as well. We'll only put in that change if the graphic rules doesn't fix it.

The other place where the game tends to have problems is the caches. They get corrupted pretty quickly, and then the game hangs or crashes. Now, I know on tumblr you were saying that you delete the caches. The other way of dealing with the caches is to make them read-only so they don't get over-written.

Given that the game didn't crash before the november windows 10 update, my hope is that the graphics cards changes are the ones that need to be done and then it will work.

#5 04-01-2016 
  • Registered
  • 6
  • 8
Oh my goodness you are amazing! I ran it once completely clean with the new files you uploaded, then tested it again with all of my CC and both times it started up, created a neighborhood and generated cache files perfectly. The only snag is the resolution seems to be stuck in whatever the default is (800x600 maybe?) There are options in the list but none of them actually change the screen at all, and there isn't one for my native screen size (1920x1080). Is that something I can fix easily? If not, honestly I'm just so happy to have my game back. Thank you so very much!

#6 04-01-2016 
Yup - that's easy to fix - load me up your new config-log.txt and I'll make sure it's offered.

#7 05-01-2016 
  • Registered
  • 6
  • 8
Here it is. Thank you bunches and bunches! Do you have any advice-for-dummies that might help me prevent windows from sabotaging the game with another update?

Attached File(s)
.txt  DRUSILLA-config-log.txt (Size: 10.31 KB / Downloads: 696)

#8 05-01-2016 
The default for you is 1024x768
The Max goes up to 1600x1200.

I've updated your graphic rules to have a max of 1920x1080, download and let it overwrite your previous one.

Download Graphic Rules

That should be all you need. I'm assuming you're playing full screen.

If it looks like its not changing - try it as windowed first, then change it back to full screen.

#9 05-01-2016 
  • Registered
  • 6
  • 8
Thank you so very much! Hugs and baskets of pixel kittens for your amazing help!

#10 05-01-2016 
You're welcome 10littlepandas. Smile


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option