Sims who use my modded object skip some animations
#1 01-04-2016 
[Image: 33wBrK8.png]

In game, the object runs lines 0, 1, 3, 6 and 7 and completely skips over lines 2 and 5, like they're not even there. It generates empty missing-anim.txt files in the Log folder. I was having this problem with a bunch of animations that I chose. As a test, I started over with a completely different object, searched my downloads for CC made by other people, then I edited some of the animations they'd used into my statue (a2a-plead and a-react-naked). Does anyone know if there's a trick to using these that I'm missing?
semio, proud to be a member of LeeFish since Apr 2016.
(This post was last modified: 02-04-2016 05:43 AM by semio.)

#2 02-04-2016 
Line 2 is a2a and probably should be a2o - my memory is rather rusty but I do believe that a2a is adult to adult so no, that one wouldn't run. O is object so changing that should work.
Line 5 - that one most likely doesn't run because there is nothing naked for the sim to react to. Some animations don't run because they rely on other things to be present/happening to run. That said, you got that animation from another object so check to make sure you haven't misspelled it anywhere.

#3 02-04-2016 
I feel so foolish. I wrote the animation in line 5 from memory, and I remembered it wrong. That works now. Thanks.

But the a2a line seems to be spelled right, and it should work, even though it's for Sim to Sim (I got that from peaking into the Plumbbob of Praise. Hope you don't mind Smile ). I'm starting to think something might just be wrong with that package. I'm going to try remaking it again tomorrow.

#4 02-04-2016 
Another thing, you haven't linked things properly. With Sim animations, both True and False should point to the next line you want to run (like you do with line 2), not just True.

Many times the animations will run just fine anyway, but it can still muck things up, so it's better to be on the safe side and do it right.

@mustluvcatz bad cat for not spotting that. Tongue

#5 02-04-2016 
Oh, thanks. I didn't know that.

#6 02-04-2016 
@semio Of course I don't mind. Smile a2a is how I have it? Really? My game is running (and I really don't want to exit it, lol) so I can't check.. but I'm going to at some point in time.

@NixNivis Only a half bad cat here. I DID spot that but it was after I replied. I meant to come back and edit my post but.. yeah, bad cat!

#7 02-04-2016 
I accidentally solved the issue. I'd been copying all the animations I wanted to try into a word document, then pasting them into SimPE. I just tried erasing a2a-plead, then typing it back in by hand, and now it works. The same trick also worked for all the different animations that I couldn't get to run before. Even though they're written exactly the same as the original line I pasted in, and I haven't changed anything else. I don't know what the deal is, since I'd c&p'd other animations into the list and those did work, but at least it's fixed. Thanks again, mustluvcatz and NixNivis.


Sorry, that is a members only option