Bodyshop Direct3D Error
#1 09-04-2016 
  • Registered
  • 3
  • 6
I use DVD/CD Sims game installations on Windows 10 with Nvidia GeForce graphics. The game itself works perfectly fine, and even CAS runs smoothly. However, whenever I try to run bodyshop I wind up with this error:

Direct3D returned an error: E_INVALIDARG!

The application will now terminate...

I also get this error when trying to open up the game in windowed mode, but bodyshop holds more priority for me than windowed more. That being said, if I run bodyshop through my intel graphics instead of nvidia, it works fine. Is it not possible to use bodyshop with graphic cards other than intel?

Attached File(s)
.txt  KOREDIS-config-log.txt (Size: 8.1 KB / Downloads: 566)
(This post was last modified: 10-04-2016 06:17 AM by noodlement.)

#2 09-04-2016 
@noodlement A lot of us on Nvidia are getting this error. For me it happens with the game too, windowed or fullscreen mode. Maybe it's a related problem?

#3 10-04-2016 
@noodlement hrikosaunders is right. I'm looking into it at the moment hoping to find a solution, but in the meantime if you use the Intel card, and Intel Graphic Rules/Video Card.sgr you should get at least an acceptable graphics quality.

#4 10-04-2016 
  • Registered
  • 3
  • 6
@celebkiriedhel If it helps, I've done a little bit of experimenting. I originally installed each game expansion individually in order, and it worked perfectly until I tried installing Sims 2 Mansion and Gardens. At which point, it suddenly became unplayable and began throwing the Direct3D error at me. I made sure to add my display adapter to the video card database before attempting to play, but even then it still wouldn't worked. So it's possible this problem with Nvidia might depend on the expansion packs installed? Also, I've noticed those with Sims AIOs installed have this Nvidia issue, I'm not sure if those with Sims UC do as well though and I haven't tested it myself either. However, I have a friend who uses a Sims UC repacked (it had all the expansion packs, but instead of having Fun with Pets, it had Family Fun, Pets, etc... Which sort of just sounds like another Sims AIO to me), and we were able to get the game working with Nvidia graphics card.

#5 11-04-2016 

Thanks for the experimenting. (I'm not sure what you mean by AIO?)

#6 11-04-2016 
All-In-One??? If so, then I wonder All-In-One what? Smile


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option