Runtime Error & Not Found In Database
#1 13-11-2017 
  • Registered
  • 0
  • 4
EDIT: I managed to fix the issue with the runtime error so that's no longer a problem, but I'm still stuck at the game loading up and then crashing when I load a neighborhood. I checked my logs and it says the issue with the graphics card not being in the database is a problem still, even though I have added my graphics card in the Video Card rules file. Not sure what I'm doing wrong that it won't accept it. :/

Hi, so I've just set up TS2 Ultimate Collection on a new laptop and when I first started the game, it was running from the integrated graphics card. It would load all the way up and all the way into my neighborhood but looked like garbage. I changed it so that the default would be to run it with the dedicated graphics card and the game would load all the point of loading a neighborhood and then my whole system would crash and say "Driver Power State Failure" and restart. I updated my graphics driver, assuming that was the issue and tried again but experienced the same error. I then tried to run my game in compatibility mode and cleared the 2 caches the game creates (in case that was an issue, since they've caused me issue before) and when I tried to open the game again I got the runtime error on Sims2EP9. I have turned off compatibility mode and taken my entire EA Games folder from my documents file to try to narrow down what's causing this issue but I still feel like it's the graphics card. The log says my graphics card is not found in the database and I tried downloading the files I could find to fix that issue but nothings working and I'm not sure what else to do. :/

My PC is running Windows 10 Home Edition
Intel Core i5-7300HQ 2.50 GHz
Nvidia GeForce GTX 1050 card

Attached File(s) Thumbnail(s)

.txt  DESKTOP-VQ90EKP-config-log.txt (Size: 9.5 KB / Downloads: 447)
(This post was last modified: 13-11-2017 03:10 AM by iplaywithlife.)

#2 13-11-2017 
Hi @iplaywithlife,

Ok, first things first. When I see a phrase like "Driver Power State Failure", my thought process gears towards "maybe the laptop cannot provide enough power to run the GTX 1050 graphics card." That would make it a hardware problem. I cannot be certain that this is really what's going on, but that's where my gut goes.

Second: The config-log.txt suggests that your system has only 1GB of memory.
If this is NOT true, then someone needs to help you figure out how to get the game to recognize all the memory that you have. I'm not qualified for that, alas.
But if IS true, then I believe you should stop trying to play the UC on it. Your system just doesn't have what it takes to play such a demanding game. Windows already eats up a large portion, so the game will not get what it needs to run.

Third: the video card isn't in the Database. We can fix that fairly easily, IF you know how to open files and add a line of text to them. If not, then you need better help than I can provide.
Go to the folder \Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
and open the file named Video Cards.sgr in a text editor.
find the NVidia section and add a single new line reading: card 0x1c8d "GeForce GTX 1050"
Now save the file.

Fourth, you need to set the Texture memory to something other than 32 MB. Again fairly simple if you know how to edit a file.
You need to right-click the desktop and select the NVIDIA Control Panel. In the panel, at the lower left, you'll find a link "system information" which you need to click. Now a window opens, where you get all the details of your graphics card. Look for a line reading "Dedicated Video Memory" and note down the number that you see on that line.
Now, in the same folder, \Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\,
open up the file Graphics Rules.sgr in a text editor,
find the line that reads "seti textureMemory 32" (somewhere in the first 50 lines, I suspect)
replace the 32 with the number you just wrote down.
Again, save the file.

Now the next step is to copy both the edited files to the folder \Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\

Perhaps, all that fixes your game into a state where it can run normally. If not, then you need help from someone more qualified, like @celebkiriedhel (Kiri for short). She has more knowledge of these things, and can probably do more for you, but I cannot promise when she'll be here. Please be patient.

If the above works, let us know, please. And if it does NOT work, let us know as well. But in that case, report whatever new error, and post a new config-log.txt. And perhaps it might be helpful for Kiri if you also added a DxDiag report.

Good luck with your game,

#3 13-11-2017 
  • Registered
  • 0
  • 4

I'm not really sure about it being a hardware issue. This is a brand new Dell gaming laptop so I'd really hope it's not bad hardware.

I followed the instructions for the graphics card not being found and the config-log says the game recognizes my graphics card now. I was trying to do that before but I was just doing it wrong. The game IS still crashing though so I'd assume this may be traceable to the memory thing but I'm not sure where to find that information on the config-log. I'll attach it below and also try to look into the issue myself.

Attached File(s)
.txt  DESKTOP-VQ90EKP-config-log.txt (Size: 10.42 KB / Downloads: 437)

#4 13-11-2017 

I think we misunderstand each other a little here. When I say "a hardware issue" I do not necessarily mean that something is broken or bad. And it has nothing at all to do with the age of your laptop.
But the fact is that in a laptop, there is only limited space, so the power system that's built in is not too strong. And this is true for old AND new laptops. If the graphics card needs more power than this power unit can supply, then there is a problem that can NOT be fixed with software. THAT is what I mean with "a hardware issue". And I *did* say that I'm not certain about it, because I do not know everything. And of course, I *too* hope that it is not a hardware issue.

Somehow, the game now suddenly sees 2GB of memory. That's progress. Still not enough, but a little more than the 1GB it saw before.

You seem to have fixed the Video Cards.sgr and the Graphics Rules.sgr, so that's a good thing. But your game still crashing is not what we wanted to achieve.

I have no more ideas how to help you any further. I hope that someone else (like @celebkiriedhel) still has ideas to help you fix it.

#5 14-11-2017 
  • Registered
  • 0
  • 4
@BoilingOil Thank you for your help. All progress is good progress. Still not finding much on any of the issues. It seems all the solutions for driver power state failure are to update or uninstall/reinstall problematic drivers. Still unsure about anything memory related with the game.

#6 14-11-2017 

Hi Hi. I saw my name invoked.

Can you please do the following for me?

Run DXDiag, and upload the text file that you can save from that program. It will give me a clearer idea on what is happening.

I don't know what if anything I can do to help - but I can surely look at it and see if there is anything that can be done.

#7 15-11-2017 
  • Registered
  • 0
  • 4

Hope this is the correct file.

Attached File(s)
.txt  DxDiag.txt (Size: 92.28 KB / Downloads: 596)

#8 02-01-2018 

Sorry about the delay.

8G of Ram is fine, although I'd be careful to keep your CC coming in under 10G.

Your Processor is ok - Processor: Intel® Core™ i5-7300HQ CPU @ 2.50GHz (4 CPUs), ~2.5GHz

Although the Sims game usually only uses 1 or 2 cores (hence the reason why you've got 3.4GHz and not more), 3.4GHz is generally enough to run the Sims in High resolution.

I'm just wondering if this is a problem caused because of the origin update. Origin updated the game to remove Securom (a good thing) - but managed to break other things at the same time.

I'm wondering if we'll have the same problem if we free the game from Origin.

What we're going to do is free the game from needing to be launched through Origin first -
1. Download No_CD version of Sims2EP9.exe .
This is the version I use so I know it doesn't have any viruses, and it works ok.

2. Then go to this folder:
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSBin\
and rename Sims2EP9.exe to Sims2EP9.old

3. Install the NoCD version into the folder

4. Run the game from this exe - Does it load? Does it ask for Origin?

Come back and let me know.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option